Steam for Linux > Limited Beta > Подробности за темата
SUSEd 15 ноември 2012 в 4:46 сутринта
Issue Report: No sound in Team Fortress 2
After lanching TF2 in console appears message
SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'pulse' not available

When game loads it hasnt any sounds.

Tested on openSUSE 12.2 x86_64 (yes, I know that limited beta only for Ubuntu, but)
It working normal on Ubuntu 12.10 on same PC.
Последно редактиран от SUSEd; 28 ноември 2012 в 2:48 сутринта
Показване на 1-15 от 37 коментара
< >
Netist 15 ноември 2012 в 6:20 сутринта 
Also have this problem on Arch x86_64. Probably because I don't have PulseAudio installed.

Supporting PulseAudio is one thing, but it's a little odd for a program to depend on PulseAudio.
SUSEd 15 ноември 2012 в 7:23 сутринта 
in openSUSE PulseAudio is default sound server. Game detects it but does not provides.
Others question is how it works in Ubuntu? It also uses Pulse?
Последно редактиран от SUSEd; 15 ноември 2012 в 7:27 сутринта
SUSEd 15 ноември 2012 в 7:34 сутринта 
When i launched game with disabled Pulse (used ALSA instead) log shows this
SDLAUDIO: SDL_OpenAudioDevice() failed: Could not setup connection to PulseAudio

This means that sound must work only with PulseAudio.
Последно редактиран от SUSEd; 15 ноември 2012 в 7:35 сутринта
Frank 15 ноември 2012 в 1:09 следобед 
Thanks for the info, we'll look into it.
Последно редактиран от Frank; 15 ноември 2012 в 1:09 следобед
mikesart 15 ноември 2012 в 1:38 следобед 
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
Pad 15 ноември 2012 в 2:47 следобед 
Първоначално публикувано от mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
I just tried that and still no sound, now it shows this error:

SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'alsa' not available

Running Arch x64, no Pulseaudio, only Alsa.
Plagman 15 ноември 2012 в 4:19 следобед 
Do you have libasound.so.2 present somewhere libSDL can dlopen it?
Netist 15 ноември 2012 в 5:31 следобед 
I have the same problem. Even with SDL_AUDIODRIVER=alsa, I get a target not available message.

$ pacman -Ql alsa-lib
--snip--
alsa-lib /usr/lib/libasound.so
alsa-lib /usr/lib/libasound.so.2
alsa-lib /usr/lib/libasound.so.2.0.0
--snip--

Or, perhaps more relevant:
$ pacman -Ql lib32-alsa-lib
--snip--
lib32-alsa-lib /usr/lib32/libasound.so
lib32-alsa-lib /usr/lib32/libasound.so.2
lib32-alsa-lib /usr/lib32/libasound.so.2.0.0
--snip--

Whether these directories would be accessible by SDL, I can't say, since I'm not familiar with SDL. Though, since the directories are pretty standard directories, I would assume they're available.
Последно редактиран от Netist; 15 ноември 2012 в 5:31 следобед
SUSEd 16 ноември 2012 в 12:20 сутринта 
Първоначално публикувано от mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!

For ALSA it will not work because it uses pulseaudio, but when use
export SDL_AUDIODRIVER=pulseaudio

Sound works, off course on system with pulseaudio installed.
Thank you.
SUSEd 16 ноември 2012 в 12:24 сутринта 
1. Open in gedit file /usr/bin/steam as root
2. add after #! line this
export SDL_AUDIODRIVER=pulseaudio
3. Save file and restart Steam.
mikesart 16 ноември 2012 в 2:55 следобед 
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!
SUSEd 17 ноември 2012 в 7:24 сутринта 
Първоначално публикувано от mikesart:
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!

$printenv | grep SDL
$SDL_AUDIODRIVER=pulse

To get sound it must be 'pulseaudio'.
Последно редактиран от SUSEd; 17 ноември 2012 в 7:24 сутринта
mikesart 18 ноември 2012 в 9:40 следобед 
But it's already set to pulse before we do anything. Guess I could add code that unsets SDL_AUDIODRIVER if the audio initialization fails so it will retry. I'll add a bug to our database and think this one over. Thanks for the help.
msv_Tomsk 24 ноември 2012 в 4:49 сутринта 
Gentoo64 same problem. TF fails to launch
Update: installing pulseaudio solves that problem
Последно редактиран от msv_Tomsk; 24 ноември 2012 в 5:15 сутринта
powrtoch 24 ноември 2012 в 7:24 сутринта 
Първоначално публикувано от mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
This fix works fine on Arch32 with ALSA installed.
Показване на 1-15 от 37 коментара
< >
На страница: 15 30 50
Дата на публикуване: 15 ноември 2012 в 4:46 сутринта
Публикации: 37