Steam for Linux > Limited Beta > Emnedetaljer
SUSEd 15. nov, 2012 @ 4:46am
Issue Report: No sound in Team Fortress 2
After lanching TF2 in console appears message
SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'pulse' not available

When game loads it hasnt any sounds.

Tested on openSUSE 12.2 x86_64 (yes, I know that limited beta only for Ubuntu, but)
It working normal on Ubuntu 12.10 on same PC.
Sist redigert av SUSEd; 28. nov, 2012 @ 2:48am
Viser 1-15 av 37 kommentarer
< >
Netist 15. nov, 2012 @ 6:20am 
Also have this problem on Arch x86_64. Probably because I don't have PulseAudio installed.

Supporting PulseAudio is one thing, but it's a little odd for a program to depend on PulseAudio.
SUSEd 15. nov, 2012 @ 7:23am 
in openSUSE PulseAudio is default sound server. Game detects it but does not provides.
Others question is how it works in Ubuntu? It also uses Pulse?
SUSEd 15. nov, 2012 @ 7:34am 
When i launched game with disabled Pulse (used ALSA instead) log shows this
SDLAUDIO: SDL_OpenAudioDevice() failed: Could not setup connection to PulseAudio

This means that sound must work only with PulseAudio.
Frank 15. nov, 2012 @ 1:09pm 
Thanks for the info, we'll look into it.
mikesart 15. nov, 2012 @ 1:38pm 
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
Pad 15. nov, 2012 @ 2:47pm 
Opprinnelig skrevet av mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
I just tried that and still no sound, now it shows this error:

SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'alsa' not available

Running Arch x64, no Pulseaudio, only Alsa.
Plagman 15. nov, 2012 @ 4:19pm 
Do you have libasound.so.2 present somewhere libSDL can dlopen it?
Netist 15. nov, 2012 @ 5:31pm 
I have the same problem. Even with SDL_AUDIODRIVER=alsa, I get a target not available message.

$ pacman -Ql alsa-lib
--snip--
alsa-lib /usr/lib/libasound.so
alsa-lib /usr/lib/libasound.so.2
alsa-lib /usr/lib/libasound.so.2.0.0
--snip--

Or, perhaps more relevant:
$ pacman -Ql lib32-alsa-lib
--snip--
lib32-alsa-lib /usr/lib32/libasound.so
lib32-alsa-lib /usr/lib32/libasound.so.2
lib32-alsa-lib /usr/lib32/libasound.so.2.0.0
--snip--

Whether these directories would be accessible by SDL, I can't say, since I'm not familiar with SDL. Though, since the directories are pretty standard directories, I would assume they're available.
SUSEd 16. nov, 2012 @ 12:20am 
Opprinnelig skrevet av mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!

For ALSA it will not work because it uses pulseaudio, but when use
export SDL_AUDIODRIVER=pulseaudio

Sound works, off course on system with pulseaudio installed.
Thank you.
SUSEd 16. nov, 2012 @ 12:24am 
1. Open in gedit file /usr/bin/steam as root
2. add after #! line this
export SDL_AUDIODRIVER=pulseaudio
3. Save file and restart Steam.
mikesart 16. nov, 2012 @ 2:55pm 
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!
SUSEd 17. nov, 2012 @ 7:24am 
Opprinnelig skrevet av mikesart:
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!

$printenv | grep SDL
$SDL_AUDIODRIVER=pulse

To get sound it must be 'pulseaudio'.
mikesart 18. nov, 2012 @ 9:40pm 
But it's already set to pulse before we do anything. Guess I could add code that unsets SDL_AUDIODRIVER if the audio initialization fails so it will retry. I'll add a bug to our database and think this one over. Thanks for the help.
msv_Tomsk 24. nov, 2012 @ 4:49am 
Gentoo64 same problem. TF fails to launch
Update: installing pulseaudio solves that problem
powrtoch 24. nov, 2012 @ 7:24am 
Opprinnelig skrevet av mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
This fix works fine on Arch32 with ALSA installed.
Viser 1-15 av 37 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 15. nov, 2012 @ 4:46am
Innlegg: 37