Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Dettagli della discussione
Issue Report: No sound in Team Fortress 2
After lanching TF2 in console appears message
SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'pulse' not available

When game loads it hasnt any sounds.

Tested on openSUSE 12.2 x86_64 (yes, I know that limited beta only for Ubuntu, but)
It working normal on Ubuntu 12.10 on same PC.
Ultima modifica da SUSEd; 28 nov 2012, ore 2:48
< >
Visualizzazione di 1-15 commenti su 37
Also have this problem on Arch x86_64. Probably because I don't have PulseAudio installed.

Supporting PulseAudio is one thing, but it's a little odd for a program to depend on PulseAudio.
in openSUSE PulseAudio is default sound server. Game detects it but does not provides.
Others question is how it works in Ubuntu? It also uses Pulse?
Ultima modifica da SUSEd; 15 nov 2012, ore 7:27
When i launched game with disabled Pulse (used ALSA instead) log shows this
SDLAUDIO: SDL_OpenAudioDevice() failed: Could not setup connection to PulseAudio

This means that sound must work only with PulseAudio.
Ultima modifica da SUSEd; 15 nov 2012, ore 7:35
Thanks for the info, we'll look into it.
Ultima modifica da Frank; 15 nov 2012, ore 13:09
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
Messaggio originale di mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
I just tried that and still no sound, now it shows this error:

SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'alsa' not available

Running Arch x64, no Pulseaudio, only Alsa.
Do you have libasound.so.2 present somewhere libSDL can dlopen it?
I have the same problem. Even with SDL_AUDIODRIVER=alsa, I get a target not available message.

$ pacman -Ql alsa-lib
--snip--
alsa-lib /usr/lib/libasound.so
alsa-lib /usr/lib/libasound.so.2
alsa-lib /usr/lib/libasound.so.2.0.0
--snip--

Or, perhaps more relevant:
$ pacman -Ql lib32-alsa-lib
--snip--
lib32-alsa-lib /usr/lib32/libasound.so
lib32-alsa-lib /usr/lib32/libasound.so.2
lib32-alsa-lib /usr/lib32/libasound.so.2.0.0
--snip--

Whether these directories would be accessible by SDL, I can't say, since I'm not familiar with SDL. Though, since the directories are pretty standard directories, I would assume they're available.
Ultima modifica da Netist; 15 nov 2012, ore 17:31
Messaggio originale di mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!

For ALSA it will not work because it uses pulseaudio, but when use
export SDL_AUDIODRIVER=pulseaudio

Sound works, off course on system with pulseaudio installed.
Thank you.
1. Open in gedit file /usr/bin/steam as root
2. add after #! line this
export SDL_AUDIODRIVER=pulseaudio
3. Save file and restart Steam.
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!
Messaggio originale di mikesart:
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!

$printenv | grep SDL
$SDL_AUDIODRIVER=pulse

To get sound it must be 'pulseaudio'.
Ultima modifica da SUSEd; 17 nov 2012, ore 7:24
But it's already set to pulse before we do anything. Guess I could add code that unsets SDL_AUDIODRIVER if the audio initialization fails so it will retry. I'll add a bug to our database and think this one over. Thanks for the help.
Gentoo64 same problem. TF fails to launch
Update: installing pulseaudio solves that problem
Ultima modifica da msv_Tomsk; 24 nov 2012, ore 5:15
Messaggio originale di mikesart:
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
This fix works fine on Arch32 with ALSA installed.
< >
Visualizzazione di 1-15 commenti su 37
Per pagina: 15 30 50

Steam for Linux > Limited Beta > Dettagli della discussione
Data di pubblicazione: 15 nov 2012, ore 4:46
Messaggi: 37