Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Détails du sujet
Issue Report: No sound in Team Fortress 2
After lanching TF2 in console appears message
SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'pulse' not available

When game loads it hasnt any sounds.

Tested on openSUSE 12.2 x86_64 (yes, I know that limited beta only for Ubuntu, but)
It working normal on Ubuntu 12.10 on same PC.
Dernière modification de SUSEd; 28 nov 2012 à 2h48
< >
Affichage des commentaires 1 à 15 sur 37
Also have this problem on Arch x86_64. Probably because I don't have PulseAudio installed.

Supporting PulseAudio is one thing, but it's a little odd for a program to depend on PulseAudio.
in openSUSE PulseAudio is default sound server. Game detects it but does not provides.
Others question is how it works in Ubuntu? It also uses Pulse?
Dernière modification de SUSEd; 15 nov 2012 à 7h27
When i launched game with disabled Pulse (used ALSA instead) log shows this
SDLAUDIO: SDL_OpenAudioDevice() failed: Could not setup connection to PulseAudio

This means that sound must work only with PulseAudio.
Dernière modification de SUSEd; 15 nov 2012 à 7h35
Thanks for the info, we'll look into it.
Dernière modification de Frank; 15 nov 2012 à 13h09
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
Pad 15 nov 2012 à 14h47 
mikesart a écrit :
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
I just tried that and still no sound, now it shows this error:

SDLAUDIO: SDL_InitSubSystem(SDL_INIT_AUDIO) failed: Audio target 'alsa' not available

Running Arch x64, no Pulseaudio, only Alsa.
Do you have libasound.so.2 present somewhere libSDL can dlopen it?
I have the same problem. Even with SDL_AUDIODRIVER=alsa, I get a target not available message.

$ pacman -Ql alsa-lib
--snip--
alsa-lib /usr/lib/libasound.so
alsa-lib /usr/lib/libasound.so.2
alsa-lib /usr/lib/libasound.so.2.0.0
--snip--

Or, perhaps more relevant:
$ pacman -Ql lib32-alsa-lib
--snip--
lib32-alsa-lib /usr/lib32/libasound.so
lib32-alsa-lib /usr/lib32/libasound.so.2
lib32-alsa-lib /usr/lib32/libasound.so.2.0.0
--snip--

Whether these directories would be accessible by SDL, I can't say, since I'm not familiar with SDL. Though, since the directories are pretty standard directories, I would assume they're available.
Dernière modification de Netist; 15 nov 2012 à 17h31
mikesart a écrit :
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!

For ALSA it will not work because it uses pulseaudio, but when use
export SDL_AUDIODRIVER=pulseaudio

Sound works, off course on system with pulseaudio installed.
Thank you.
1. Open in gedit file /usr/bin/steam as root
2. add after #! line this
export SDL_AUDIODRIVER=pulseaudio
3. Save file and restart Steam.
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!
mikesart a écrit :
So just to be clear, before you went in and modified usr/bin/steam, was SDL_AUDIODRIVER set to pulse? Ie, if you do something like "printenv | grep SDL" in a terminal, what are the results? Thanks!

$printenv | grep SDL
$SDL_AUDIODRIVER=pulse

To get sound it must be 'pulseaudio'.
Dernière modification de SUSEd; 17 nov 2012 à 7h24
But it's already set to pulse before we do anything. Guess I could add code that unsets SDL_AUDIODRIVER if the audio initialization fails so it will retry. I'll add a bug to our database and think this one over. Thanks for the help.
Gentoo64 same problem. TF fails to launch
Update: installing pulseaudio solves that problem
Dernière modification de msv_Tomsk; 24 nov 2012 à 5h15
mikesart a écrit :
Can someone give this a try (set before starting Steam so TF2 will see it).

export SDL_AUDIODRIVER=alsa

And let me know if that works? Thanks!
This fix works fine on Arch32 with ALSA installed.
< >
Affichage des commentaires 1 à 15 sur 37
Par page : 15 30 50

Steam for Linux > Limited Beta > Détails du sujet