3,162 ratings
File Size
18.470 MB
Sep 13, 2017 @ 5:25am
Apr 13 @ 12:06pm
37 Change Notes ( view )

Subscribe to download


A mod that replaces core packages of the game in order to make the game more moddable and mod-compatible, as well as fixing some bugs.

As implied by the name, only one mod at a time can replace core packages. Hence, the X2WOTCCommunityHighlander tries to address as many use cases as possible, without changing the behavior of the game unless other mods make use of its features.

The full list of changes can be found here[github.com].

How do I use the Highlander?

Enable the mod as per normal, and check if the Highlander's name + version appears in the lower right corner.

A page with troubleshooting advice can be found here[github.com].

We accept contributions[github.com] and issue reports[github.com] through the GitHub page[github.com]. Please follow the troubleshooting steps first.

Thank you for using the Highlander. Our objective is to support all modders to be all they can be, so if you have suggestions please let us know. The Highlander will try to preserve vanilla behaviour as much as possible besides literal bugfixes; behavioral changes will have to be gated behind configuration or runtime flags.
Popular Discussions View All (9)
Jul 1 @ 5:55am
PINNED: Any problems getting the Highlander loaded
Sep 19, 2018 @ 10:07am
How to get highlander to work on Mac system.
Jun 10 @ 5:04am
To disable the "my2k" button and popup, this mod can do this ?
< >
Dragon32 Jul 2 @ 6:40am 
Turning it off and on again works again. Cool.
paulaskew2 Jul 2 @ 4:02am 
Morning Dragon32.

I'm not sure what I've done (it's more than likely that somebody far cleverer than me has fixed something in a galaxy far far away) but Highlander has finally appeared on the Alternate Mod Launcher.

I've just gone through everything that you suggested again and thrown in a few deletes and power off and on for good measure and its working.

Thank you so much for your help - I don't think that I could have faced another 4 weeks of furlough with being able to kill some Advent!
paulaskew2 Jul 2 @ 1:39am 
Thanks for all your suggestions so far, very much appreciated. But unfortunately no joy as yet.

I will talk you through what I have done on your suggestions -

Are you shown as Subscribed to this mod? - Yes

Does this folder have ~18MB of files and folders in?
<Steam>\SteamApps\workshop\content\268500\1134256495 - I think so, it shows a file size of 18.470MB

Run File > Update mod information - done, I saw the update bottom left running but no change

The check if it's marked as Hidden? Options > Show hidden mods - done, nothing discernible happened

If neither of those work try deleting settings.json from AML's folder, that'll reset everything so is a bit of a nuclear option - done, all that happened was the existing mods were changed to new ie in green and the tick mark removed
Dragon32 Jul 1 @ 2:41pm 
Thanks. That's clearer. What you originally wrote just didn't make sense to me.


Are you shown as Subscribed to this mod?

Does this folder have ~18MB of files and folders in?

If yes to both of those then it looks like the Highlander's installed OK locally. So for some reason the AML isn't displaying it.

Run File > Update mod information

The check if it's marked as Hidden? Options > Show hidden mods

If neither of those work try deleting settings.json from AML's folder, that'll reset everything so is a bit of a nuclear option
paulaskew2 Jul 1 @ 11:51am 
I have also noted that the 'swappimg) mod was updated just before I started having these issues - maybe just a co-incidence?
paulaskew2 Jul 1 @ 11:49am 
Apologies for my vagueness. I took the X2WOTCCommunityHighlander off the Alternate Mod Launcher, by took it off I mean that my games was constantly crashing during the mission load up - usually around 10 missions in. I researched trouble shooting and the suggestion was to load the Highlander in first and then a few mods at a time to try and identify which mod was causing the crash. Therefore I unsubscribed to all mods, emptied my config folder and also checked that the steam file (is it 268500?) was also empty. Then, finally I deleted the Alternate Mod Launcher and reloaded it.

After this I subscribed to the Highlander but it didn't appear on the Alternate Mod Launcher, I tried this several times with no luck so to check things were working I tried another 7 apps including robojumpers squad select (which requires the Alternate Mod Launcher). Robojumper and the other 6 mods appeared on Alternate Mod Launcher but no Highlander.

Have I explained myself better?
Dragon32 Jul 1 @ 7:21am 
In each of the three cases where you use "it" in that sentence, what is "it"?
What does "took it off my AML" mean? Presumably AML is Alternate Mod Launcher.
paulaskew2 Jul 1 @ 5:50am 
For various reasons I took it off my AML and now I cant get it back on, even though it says I'm subscribed?
The Guy Jun 30 @ 3:54pm 
Sorry to disturb you, I have figured my problem but thank you for willing to assist.
Dragon32 Jun 30 @ 3:03am 
@The Guy
Are you launching WotC or XCOM 2 when this mod is enabled?