in account

Recent reviews by God, owner of the Universe

< 1  2  3  4  5  6  7 >
Showing 1-10 of 68 entries
8 people found this review helpful
2 people found this review funny
3.6 hrs on record
The game really has A LOT going for it, but I ended up HATING it, that's why I won't go into the details of the various things that are really good about it. So, what made me hate it?

The bad BAD difficulty "curve" (balancing). I went through all those corridors to finally open that door - only to find an almost unbeatable BOSS? :( I hate boss fights, but this one is really higher on the annoyance scale. And this is THE FIRST boss, what am I going to encounter LATER?

This guy jumps all over the place and throws grenades/drones, hard to not get damaged. After a few attempts, I ended up reducing the difficulty from normal to easy, which♥♥♥♥♥♥♥♥me off, because it insinuates to be a permanent measure / a measure with more consequences than just the difficulty. And one can assume that a difficulty change affects THE WHOLE game even though only the boss fight (Significantly!) requires it.

So I went in there again - and saw a save-spot. Since the boss wasn't easier at all, I guess the save-spot was the consequence of the lower difficulty. And what does it do? Well, after I died AGAIN, the game continued with me being in that place. But the boss was FULLY RECHARGED. So, it ONLY saved me the traversal of like three rooms! No help at all.

And, what's more: I HAD him this time! He was exploding. But then, with me in the outermost corner, no way to go anywhere, the already exploding boss JUMPED ONCE MORE, so in parallel to the boss exploding, the player death animation was playing. And then the game congratulated me on beating the boss. And then I respawned - and so did the boss.

Plus, the music track you hear in almost ALL rooms is far from good enough to be played ALL THE TIME! It's annoying!


  • Super repetitive music.
  • First boss is already super hard, giving the outlook that the later game will suck extremely, so why keep struggling?
  • Reducing the difficulty does nothing except give you the impression that you lost something.
  • Even if you beat the boss, 3 seconds later he may attack and kill you, but the game isn't even programmed to deal with that.

There are also a lot of positives (making this game better than many others in those regards), but that kind of pulls the score down even more, because you experience the incredibly wasted potential. What could have been a fun Metroid game with some interesting mechanics just became an annoying disappointment with promises of incredible frustration, accompanied by an annoyingly repetitive soundtrack.

I heartily suggest that you spend your money on other games instead. This is A FIRM THUMBS DOWN! I really hate this game. What a failure.
Posted July 21, 2017.
Was this review helpful? Yes No Funny
4 people found this review helpful
1.1 hrs on record
Wow. These guys did everything right. The music, how it plays hand in hand with the level events, how the ball steers, the level design, definitely what things look like (Was blessed with playing this on 4K, really great looks.), the puzzles, the difficulty, the kinda constant rewards (other than finishing), and the humor.

Got this in the current Bundle Stars "Neon Bundle" that cost me €3.39, which this game alone is easily worth, if not doubly so.

Recommended! :D
Posted February 19, 2017. Last edited February 19, 2017.
Was this review helpful? Yes No Funny
1 person found this review helpful
0.1 hrs on record
This is aboutSniper Ghost Warrior 3 Open Beta

The key reason for uninstall and thumbs-down is that the forced intro-video that explains the concepts can not be skipped, and its video/audio was asynchronous. This may have happened because I Alt-Tabbed out 1 time - which did not pause the video even though any proper application should pause its activity (if that makes sense) when it is not the active application, a simple thing to do. So, the video/audio didn't pause, and the video was running at about half the speed of the audio, which may have been caused by the Alt-Tab. But since the only way they devised to abort the video is ALT+F4, that is also the verdict the game gets from me: The only winning move is not to play. If I get a chance to stop an upcoming game in its tracks whose developers decided for the INCREDIBLE AFFRONT of not allowing their users to skip their long videos / cut-scenes, I will do so happily.

Btw., if I had gotten into the game and found out that the FOV (field of view) is too low and not fixable, I would also have given a thumbs-down. This illness must be beaten out of the world with an acid-soaked glowing-hot titan hammer into the balls of every developer who dares to yet again fail at this.

Other small things that didn't quite factor into this, while we're at it:

The big campaign start button says "Normal", suggesting that it's normal difficulty. But I didn't find a way to change the difficulty, so that's confusing.

The usual "Don't quit while it's saving." message explicitly said "hard disk", so an obtuse person might assume that their SSD machine can't save at all. And when will the industry stop with that stupid message in the first place? They are suggesting that they are not living up to the MINIMUM industry standard of using safe saves, where first the file is written in full, then it is renamed to replace the old save file, thereby always at least one full file exists.
Posted February 5, 2017. Last edited February 5, 2017.
Was this review helpful? Yes No Funny
4 people found this review helpful
0.1 hrs on record
Has the following controls: WASD for walking, space for jumping, f and g for action 1 and 2 (which you can also do with the left and right mouse button), and Tab for camera.

I only played a few minutes: The first room. This introduction to the game didn't work for me at all. The camera was fixed in place (Tab didn't have any effect.), and I walked to the ringing phone, and when I clicked with the left mouse button, the phone just exploded. Then the hint came up that I can pick up objects with left mouse button, so I picked up / threw around the cube and the stool. The door didn't open. There was no further interactivity. Nothing. So I jumped out the window. Which killed me (apparently) and restarted the room.

I did the whole thing three times, then uninstalled and wrote this short review.

You need to guide your users better. I have no idea *at all* what I did wrong. Or did I meet some kind of glitch? No idea, because the game didn't try to tell me what's supposed to happen, rather the opposite. Because certainly, one can not expect that the phone *explodes* when it is picked up. "Haha, surprise! Jumbling your expectations a little!" Yeah, nice. I just don't know now what to expect at all. Well, something. Anything. But nothing happened or worked.
Posted November 28, 2016.
Was this review helpful? Yes No Funny
4 people found this review helpful
0.5 hrs on record

That's what it is. Either connect 111... or 123(45...) or some other combinations. There are three game modes: classic, timeless, puzzle. "timeless" is boring, and if you play that first, you'll quickly think that the whole product is boring. "puzzle" is a lot more interesting: The shape of the level and the setup of the numbers makes it tricky to even get every block (cause you need at least 3 in a chain), let alone be efficient about it.

But what really makes this game is "classic" mode. You only have limited time (but plenty up to level 6 or so, or I was lucky), and whenver you make a chain, a bar fills up until you have completed the level. At the start of almost every level, there's a message introducing a new element (which also appear in the other modes), and when fire blocks come in, that's a sudden game changer, because once they are burned out, they are black coal that you can only get out of the way by letting it drop out at the bottom. But below level 10, you're more likely to just complete the level. But it goes on and becomes more interesting, and the pressure increases ...

It's a minimalist simple but well done connect-3 game. Nothing to write home about, but it does deserve a thumbs up. Even if games like this are available by the ton as Flash games on the Web. (But I don't have Flash, abandoned it at home and at work June 2016. It's a good life that I can recommend.)

The game deserves a thumbs-up, because the gameplay is partly interesting and even exciting. I first wanted to give it a "meh" (without a review, since you can't side-vote), but that was because I started with "timeless". Next up was "puzzle", but then I played "classic" up to level 10 or something, and it was an increasingly interesting ride with some tension and stuff.


The "for free" checkbox is odd: I've bought a few games in the last few days with 90% off via coupons I got from crafting card badges. So, if the game is only 50ct, it's not free, but if it's 0ct, it's free? I bought those 50ct games mostly because they were so drastially reduced, and because the coupons die in a week. I don't see the significant difference to "free" that would justify the special treatment (whatever treatment that is - is it only information for the readers?)
Posted November 13, 2016. Last edited November 14, 2016.
Was this review helpful? Yes No Funny
5 people found this review helpful
75.8 hrs on record
Revised review 2017-01-01.

I've done two playthroughs and do like the product. It's not flawless, but it's a great creation which even breaks a bit of some new ground here and there. I'll stick with my thumbs-down, though, because of the too-low-FOV idiocy that is just inexcusable. I am fed up with the damn trouble stupid developers keep forcing me through, so thumbs-down is what they get, period.

Also, really: DO. NOT. PRE-ORDER. No matter how great a company's products had been in the past. Eidos Montreal / Square Enix fkd us over with surprise-episodic format consumable-preorder-bonus "Deus Ex: Mankind Divided" and all its bugs, now Arkane Studios did the same with their buggy release (mouse speed was bound to FPS, which is unthinkably wrong and also impossible if the game is tested for like 5 minutes, showing the pre-order "Out the door you go! No matter if done!" attitude). We are the beta-testers. If we pre-order. Also, 1.7 months after release, the game was already available for half the price at Saturn Germany, a media store which usually has quite higher prices than discounted Steam games. Just wait, ok.


The FOV slider only goes from 65 to 110 (horizontal; seems to become wider on screens that have wider aspect ratio, so at least there's that), and editing the config file's FOV variable outside this range does not have effect. So, as per my new policy, this game gets a thumbs-down. Failing the primary interface in a 3D video game means that the developers do not know or care about their job. So I don't care about their game. Learn your interface already, developers! It's not funny any more. Everybody looks at graphics quality, but the actual functionality of the 3D view doesn't matter? Is everybody crazy these days?

Since 2016-11-14 (3 days after the game was published), thanks to Matti Hietanen we now have a FOV solution[pcgamingwiki.com] (with the downside that the FOV resets whenever you load a savegame). It's a DLL that you have to inject into the game, which turned out to be childishly simple: 1) Run the game and also Cheat Engine. 2) In Cheat Engine, choose the game via the button at the left top button, as per usual. Then click on the "memory view" button in the left half of the window. 3) From the new window, via the "tools" menu, select "inject DLL", choose the downloaded DLL (Unpacked from the ZIP, of course.), and confirm "Execute?" with yes. Done. A window will pop up immediately that is bound to the game as you can see in the Windows task bar where the game's icon now has two windows. You can close Cheat Engine now. [PAGEUP]/[PAGEDOWN] changes the FOV, [POS1] toggles the HUD objective locators, which is super useful and should even have been a real hotkey in the game, because sometimes you just need to take a peek at where you have to go, but most of the time, you don't want that, and traversing the menus each time is just stupid.


This does not weigh into the verdict, but you should know it. No mouse or keyboard action can skip them, and renaming the files so that the game doesn't find them makes the game freeze/crash - welcome to total beginner level development. But they can be replaced with a very short video, so I made one and uploaded it to PCGW[pcgamingwiki.com].

There's a lot that can be said about how to (not) do the logo videos part of a product. If you're interested in that, and in a lot of other things games still do wrong so routinely, take a look at my Compendium for the perfectionist game developer


Very early in the game, you actually step up to a hurt person who proceeds to give you important information and then immediately dies. The very same thing happens a few missions later in the game. ... It's ok, everybody does it, e.g. the "Missing Link" section in "Deus Ex: Human Revolution". What a tired trope :(

The voice of the Outsider was a lot better in DH1. An imho completely unnecessary change and step down.

The ending ... I won't spoil it, but by now you stopped reading this paragraph, so I can say that it does feel a bit rushed, certainly as if obvious possibilities were left unexplored because time was short and therefore just the obligatory things were done, and that's it. The game is not like that in every place, but the ending has this a bit. It doesn't hurt, but it feels less than it should feel based on the story that leads up to those moments. Another thing about the ending is that a key element is quite known to Dishonored 1 players already, so it feels like the same idea has been recycled.


I've met two mission/map design that I can't describe further because of spoilers. Let's just say that the gameplay mechanisms that are employed there are a near novelty and are well implemented, a good source for fun and exploration. Must have been mind-boggling to design those. Very engaging, mind-teasing, interesting. Not just a step up from Dishonored, but somewhere in the upper levels of gaming.


It's not like Dishonored 1 squared, but it's certainly a considerable improvement

On the one hand, it's just more of the same. If you liked DH1 and its great DLCs, which I certainly did, then you will enjoy DH2. But if you were expecting something beyond, then you will realize that it's only a boosted version but not a new evolutionary step, other than some mission/map design highlights and the fact that you can play two characters with different powers, meaning that you have a lot of replay value if you don't directly chain playthroughs to each other, cause that gets boring. You have the low/high chaos variants, the stealth vs alert variants, and finally the powers vs no powers variants. That's a lot of replay value. Just, you know, give it some downtime in between.
Posted November 9, 2016. Last edited January 1, 2017.
Was this review helpful? Yes No Funny
8 people found this review helpful
1 person found this review funny
2.1 hrs on record
THIS GAME SCORES [0 *1* | 2 3] = ~38% (25%-50%)

Got the game for €8 instead of €20 in the Steam Halloween Sales 2016. After exactly 2 hours, I asked for a refund, but the threshold timing is coincidence.

Reason: Random game-breaking bug(s?) in combination with a ridiculous savegame concept where you have to do a whole mission again if you abort it (and, only slightly annoying, you start over in the mission hub, not at the start of the mission), so e.g. you can't stop at some point in a mission, because the missions' checkpoint concept only applies in-memory. The hub world's checkpoint concept is persistent, but those checkpoints are far apart; can't say if that matters, didn't play enough to find out if this can result in annoying situations, so far it was alright.

At first, I had trouble finding emotional access to the game, because there was no context of how to interpret the literally otherworldly situations, but then eventually the world was explained and made sense. At this point, I was finally beginning to actually be interested, but before this could gain momentum, I reached the hub and chose one of the missions - the leftmost one - and, far in, encountered a game-breaking bug that, based on a video I saw where it didn't occur, seems to happen randomly.

The only thing I could do was to exit to the menu and then click "continue" - which placed me in the hub again. When I had first entered the mission and turned around to touch the exit, I had already seen the message that says the mission would completely reset if I leave it before completing it, and I assume this applies to all missions. The video showing the first mission was almost 7 minutes long, but the person playing it knew exactly what to do at all times, so expect 10-25 minutes while you still need to figure out what's what. And you can't interrupt, or you have to do it all over again, place the platforms, push the buttons, carefully navigate above the abyss.

Far in the first mission, there was a pipeline-like puzzle where I had to arrange two sets of pipes. When I was done with the left set, I fiddled with the right set, but suddenly those pipes stopped being interactive. So I had to start the mission over. The savegame concept is unacceptable as it is, but when game-breaking bugs like this are in the mix, the only winning move is not to play.

It would feel like walking a tightrope, constantly thinking "I hope the game doesn't break". How are you supposed to enjoy the world / story with that load on your mind, gnawing at your nerves? You're constantly threatened with extreme frustration - why should I put up with this when there are hundreds of other games I could play or spend money on?

If the developers choose to work on this: The key solution would be persistent and not-too-far-apart checkpoints. Fixing the game-breaking bug(s?) would help, too, but that's secondary.


You see your body when looking down (at least the legs). You can walk, run (optionally as a toggle), crouch (optionally as a toggle; I found the process of crouching down a bit too slow, and it also doesn't go down far enough for my taste), jump. There's no mantling/climbing, so if you meet a wall that's a wee bit to high for your jump, you're out of luck.

The footstep sounds of normal ground (e.g. in hub) seem to be the original Dark Engine sounds (Thief, System Shock 2), which I liked a lot. I'm not sure if I find them completely apt, and I guess the reason is that as opposed to the Dark Engine games, you're just a levitating camera (With legs.) in Soul Axiom: The natural walk-sway isn't there. I know some people have problems with such things, but making such effects optional has been normal in gaming for the longest time.

You will attain powers that you can use at any time, but they are only effective on specific (clearly marked, once you know what to look for) objects. I agree with the complaint of another reviewer: The powers are delayed too much, you feel hindered. This is ok most of the time, but at other times you feel imprisoned (e.g. when turning the pipes in that game-breaking bug situation). After handling several dozens of objects with the green power, due to the delay I still don't know if the reset animation of objects always plays in full or if I can interrupt it. The delay makes use of the powers feel wooden. It would also have been a lot better if the powers' sounds would not play when you're not actually affecting an object: You can make the power gesture at any time, and if you do that while aiming at the right type of object, the effect this has on the object makes the sound fit well, and that's why it feels wrong when the sound plays even if you're just aiming at thin air. Silence or an alternative sound would be better.


You can reconfigure the input. I think I also saw options for controllers but don't remember. I moved all controls from WASD to arrow keys with no problems.

Mouse is not accelerated - just like it has to be. Mouse speed is adjustable.


Thankfully, and this is rare enough, the game has FOV controls that go far enough for my needs. I use a 49" 16:9 screen at arm's length distance, because as opposed to the vast majority, I have understood that a 3D 1st person interface is meant to replace your real-world 1st person, so a bigger screen means better use of / better working interface, which e.g. expresses in the fact that I have no problems doing 1st person 3D platforming, because due to higher FOV, objects that are further away are clearly smaller, so I can estimate distances properly. I like to be immersed when I play, so I try to be in the world instead of just looking at it on a rectangle somewhere over there in front of me.

I had to crank up the FOV slider to max, which showed "100", and I am convinced that this is vertical FOV, because 100° horizontal (at 16:9) would be way too low for me. When standing with my back in a 90° corner in this game, I could see both walls, even when I reduced the FOV to "90", so it's definitely higher than 90° horizontal.

I tried to play at 4K with all settings maxed, but my (powerful) machine couldn't give me full 60 FPS, which is normal, so the game's rendering doesn't seem to either be slow or lightning-fast. Playing at 1920x1080 was just fine.

The graphics are very dark, but there's a gamma slider which helps a little. The darkness is in the design, not in the rendering. With your powers "out", you emit a bit of light, so you can amend this when standing close to stuff. The darkness is not really a problem, it's just a bit much overall, I find.

The graphics are simple and (mainly due to their glow and glowing lines) remind a lot of the awesome Tron 2.0 while by far not reaching their heights (at least up to the point where I played), but they are also not bad: They have proper game studio level, not just amateur level.


Don't buy unless the savegame concept is completely overhauled, or considerable frustration from time to time is guaranteed.

If they fix those problems, and if they also reduce the powers' delay that feels so wooden, it might be a great 3D 1st person story campaign puzzler. Can't tell because I stopped at 2 hours.
Posted November 1, 2016. Last edited November 1, 2016.
Was this review helpful? Yes No Funny
6 people found this review helpful
1 person found this review funny
0.0 hrs on record
THIS DLC SCORES [0 1 2 | 3 *4* 5] = ~75% (67%-83%)

Very well done, except the almost-ending is a bit weak, but then you once again choose your path (this time to leave), and if you choose the long path, there's again a bunch of fun to be had.

€12 seems a bit steep for 6h (If very thorough!), steeper than €50 for 50+h (If very thorough!) for the main game. But Deus Ex seriously is a game that needs to be played through several times. These are conservative estimates to ensure the numbers are not wrong: I have 20+ playthroughs on DX (2000), 10+ on DX:IW, 5+ on DX:HR. These games are designed to be played several times.

The story requires more exposure to fully sink in. Also, the game's design allows to experience the story from various perspectives. A properly made DX game that is played only once is a wasted purchase. Therefore, it's safe to assume that you get quite more than 1 hour of gametime per $/€ for the main game and also for this slightly steeper priced DLC. (And in addition to the magical 1h per $/€ threshold that is sure reached, the quality of the experience is very high, if we ignore the failure that is DX:MD's ending. Failure why? Because it does not announce itself, and it also feels a lot less impactful than the endings of DX (2000), DX:IW, and DX:HR, it's far from what you expect from a DX game, and again: It's too sudden.)


The DLC is started from the "JENSEN'S STORIES" menu, does not build on an existing savegame, also doesn't have a newgame+ modus. You start with minimal equipment and augs and with ~14 Praxis kits. Even though I explored extremely (and thereby found/earned a few more kits), I had to choose wisely how to spend them.

My initial choices focused on freedom to explore: High jump, punch-through-walls, heavy lifting. Then I kept striving for hacking. When I was at the end, I had the following augs (in addition to the ones you start with, which e.g. includes this ghost vision thing where you can see where they last saw you, and probably others):

Hacking to level 5 incl. almost all related augs (e.g. stealth) and turret/bot domination. Remote hacking completely. High jump. Icarus landing. Heavy lifting. Punch through walls. Max inventory. Augmented vision (incl. object highlighting). Battery recharge delay to minimum.

As you can see, a lot of augs are missing. Well, the mission is short: If you'd get enough Praxis kits to max out almost everything, you'd find Praxis kits all the time and would unlock augs all the time, would start using new augs all the time. Since you wouldn't use all kinds of augs all the time even if you had all of them, unlocking them all in such fast succession would be almost similar to having them unlocked completely right from the start, because (as I said) you wouldn't use all of them all the time, so you might not even feel the absence of some until you're maxed out. Also, "having to" use new augs every few minutes would bias the game experience too much.

The mission is just too short to max out all augs, the balancing would suck. Also, as you can see, I (almost) maxed out all kinds of hacking. That is very expensive. If I hadn't done that, I could unlock a lot of other augs. And hacking heavily distorts the game: You hack all the time, because you have no need to find other ways through doors etc., so the gameplay aspect of hunting for codes, using/crafting multitools, and maybe just not being able to get through a door are all not there. That's why it's justified that hacking is so expensive. And that might even justify (on top of the balancing I talked about) that the mission does not give you enough Praxis to unlock most augs. (All this logic might fall apart, though, given that hacking also gives you a lot of experience and therefore a few additional Praxis. I don't know, need to do a few more playthroughs.)

Try a playthrough where you leave hacking completely alone. That will give you a completely different experience with interesting challenges etc., and you can use a lot more other augs. The argument can be made that this DLC is balanced for micro-transactions, since I had to search / hack-grind a lot to get as many Praxis kit as I got. Maybe that's indeed what they did. Even given the balancing and "hacking is expensive and distorts gameplay" argument, a few more Praxis kits might have been right, so maybe they balanced this somewhat for MTs.

But in DX:HR we got too many Praxis if we thoroughly explored the world. In DX:MD, you can also end up with (almost?) full augs at the end. With this DLC, we finally have the DX (2000) balancing where you have to make choices, can't just become a Jack of all trades.

Btw.: THERE IS NO MERCHANT! So, you might as well drop all the alcohol. You can't sell anything anywhere. At some point, I tried to drink it all, but I couldn't: There's only so much you can drink at once. I wish they had translated the rate of drunkenness a bit into how you walk, but Eidos didn't much care about that part of the avatar implementation, anyway: There's no walk-sway option in the main game :( Jensen's extreme agility (e.g climbing, and grabbing ledges while you're jumping/falling) would have done the old Thief games honor if Jensen wouldn't walk like a floating camera.


This DLC took me 7 hours, but without troubleshooting (FOV, see below.) and some superfluous goofing, 6 hours is realistic for my playthrough. I went stealth and tried to explore every existing path, hacked almost everything (but only few alarm panels), and properly took the environment in. - Especially the start of the DLC has very impressive environment to enjoy/explore, the mood is somewhat magical.

Some guesses: 4 hours would be realistic for a playthrough that does not explore every existing path but is stealthy/thorough on the paths it chooses and also does not aim straight for the objectives. 3 hours would be for objective oriented stealthing. Less than 3 hours for directly pursuing objectives with all means (e.g. shooting) but without the intention to be done quickly (aka not speedrunning). Less than 2 hours if you play as if all you want to see is the credits.


In my 70+ hours of DX:MD (incl. DLCs) so far, I had one crash. One. That's nothing. And apart from memory-swapping stuttering, I had almost constant 60 FPS. i7-6700K @ 4GHz, GTX980 4GB, 16GB RAM, game is on SSD - Have 4GB VRAM but use max settings everywhere except MSAA and volumetric lighting. Too bad others aren't this lucky and there are still engine bugs that need to be fixed. Cause I'm looking forward to the UI bug fixing and other such less essential stuff.

As always in DX:MD, I used a Cheat Engine script to fix the broken FOV (see PCGamingWiki). A necessity that is inacceptable, therefore the main game (DX:MD), which would be a sure thumbs-up, gets a thumbs-down from me. The devs need to god damn wake up already! Big screens are becoming more prevalent, and games with too low FOV are plain simply unplayable for those who bought setups designed for this higher visual immersion.

Hey, look at the awesome graphics and hundreds of thousands of person-hours of visual design! Locked away behind unnecessarily low FOV for some satanic reason.

My CE-script-supported playthroughs prove that all it would have taken is to raise the max slider value by 20 or 30°, work that takes A MINUTE at the most. But no. Someone needed to hate serious PC gamers.

As always in DX:MD, the FOV fix I was using did not work in the virtual reality levels. (Which is odd, because it works when I explicitly play Breach mode.) So, the supposed high point of the DLC was a low point for me, walking around like a drunkard due to the forced binoculars, didn't even see that one door near the end. Well, but that part only lasts like 10 minutes. That does not make it ok, but the DLC is good enough otherwise.
Posted September 25, 2016. Last edited October 31, 2016.
Was this review helpful? Yes No Funny
3 people found this review helpful
5.9 hrs on record
THIS GAME SCORES [0 1 | 2 *3*] = ~88% (75%-100%)

This is a great physics-based platformer with a unique feel that I can heartily recommend. It has mechanical physics but also liquid physics, which isn't limited to filling containers, the liquids even form beings that run around and do stuff, and it's not fake that the beings are made of liquid (like, a hidden transition from one model to the other), because if you mechanically affect them enough, they dissolve and flow around again.

On the one hand, your avatar's look and animation are a bit goofy (which doesn't matter, anyway), but on the other hand, that's because he consists of parts, if I remember correctly. (Writing this review from memory years after last play.)

The sounds work well with the physical gameplay, they have a good realistic feel to them.

Full disclosure: I haven't played through the whole game yet, but I can say that the 5+ hours I played have been good physics puzzle fun in one mostly continuous environment. I don't know if I would recommend the game for the full price of €20, but it's definitely a good product, you will not be disappointed.

(For some reason, whenever I think of Vessel I also have to think of Rochard which is a quite different physics platformer. Both are relatively hidden gems. Maybe I bought them at the same time or something.)
Posted September 7, 2016. Last edited October 31, 2016.
Was this review helpful? Yes No Funny
3 people found this review helpful
30.7 hrs on record
THIS GAME SCORES [0 1 | 2 *3*] = ~88% (75%-100%)

Firm double-thumbs-up for the probably best LEGO computer game there is, so if you don't have any yet, definitely buy this one! As opposed to all other LEGO games (<-- A fact as of 2013. I didn't update my knowledge since, so forgive me.), this one has voice acting: The original voice samples from the film(s) are used.

The game has really high entertainment value, and once you're done with the main campaign, there is still plenty to do, so the game is really worth its current price of €20, but it has been discounted already, so ...

There's a quest bug (screenshot) that I stumbled upon that might still exist: In that section where you're controlling Gandalf to climb up a mountain or something, you can manually switch to other characters and do their stuff first, which I did. This effected for some buggy reason that there was a fish too few so I could not complete the quest. Playing the quest without switching (to a different character before the Gandalf section is completed) evades the bug - there will be enough fish in the following sequence.
Posted September 7, 2016. Last edited October 31, 2016.
Was this review helpful? Yes No Funny
< 1  2  3  4  5  6  7 >
Showing 1-10 of 68 entries