Cities: Skylines

Cities: Skylines

194 ratings
Custom Light Effects
File Size
0.009 MB
Jun 30, 2017 @ 2:34am
Aug 20, 2017 @ 11:23pm
4 Change Notes ( view )

Subscribe to download
Custom Light Effects

This mod loads custom light effects for props.

The mod may throw an error on level load but it still should work.

Even if it works, it may still be a performance hit, apparently creating new light effects ingame is inefficient in some way...

Video showing what the mod/script can do:

Scripts for asset creators:

Mod source code:

Thanks to vasimr22 for bringing this idea up again, and helping with experimentation and development.

Example by vasimr22:
< >
Longu Jan 1 @ 10:24am 
soo can i place them in-game or they're just for the asset editor?
Lamar17 Dec 8, 2017 @ 10:10am 
Ronyx69  [author] Nov 15, 2017 @ 6:47am 
@nickvet419 Yeah I get it as well even though it works, I have no idea why it's there.
nickvet419 Nov 15, 2017 @ 6:44am 
still seems to work, but got an error on load.
nickvet419 Nov 15, 2017 @ 6:42am 
The Mod C:\Program Files (x86)\Steam\steamapps\workshop\content\255710\959894658 [LightEffect.dll] has caused an error [ModException]

System.NullReferenceException: Object reference not set to an instance of an object
at LightEffects.LightEffectsMod.ApplyParams () [0x00000] in <filename unknown>:0
at LightEffects.LightEffectsMod.OnLevelLoaded (LoadMode mode) [0x00000] in <filename unknown>:0
at LoadingWrapper.OnLevelLoaded (UpdateMode mode) [0x00000] in <filename unknown>:0
Polarstorm Aug 20, 2017 @ 11:33pm 
Thx for the quick reaction ronyx. Hope the leak is history, i will report if there are still problems.
Ronyx69  [author] Aug 20, 2017 @ 11:30pm 
@Polarstorm The mod is now updated to be disabled in the asset editor. But I did test it before, and couldn't reproduce a memory leak, I have 109 mods, tried loading a custom light effect asset and adding lights, worked fine.
Ronyx69  [author] Aug 20, 2017 @ 10:37pm 
@Polarstorm I have never ran the mod in the asset editor, I didn't think of this since I always run the editor in no workshop mode, which is recommended anyway. But yeah that is advice in general, don't try to go back to the menu, don't try loading a save from ingame, don't run asset editor with the workshop enabled. Also make sure you run the presave script before saving the asset.
Polarstorm Aug 20, 2017 @ 8:22pm 
Vasimr and me did a bit of testing and it seems that the problem is based on the "OnLevelLoad" param. Vasimr will inform ronyx about the problem, as long as there is no updatedt Version of the mod all of you guys (who have the same problem) should do it the way i made it work (as posted below).
Polarstorm Aug 20, 2017 @ 7:38pm 
Will do, gimme a sec.