Space Engineers

Space Engineers

213 ratings
Making Planetfall - a building scenario
4
3
2
2
   
Award
Favorite
Favorited
Unfavorite
Type: World
Mod category: Exploration, Experimental
Tags: story, survival
File Size
Posted
Updated
55.205 MB
Nov 22, 2023 @ 7:21am
Jan 25 @ 1:45pm
3 Change Notes ( view )

Subscribe to download
Making Planetfall - a building scenario

In 1 collection by Sarekh
Colonized Worlds
9 items
Description
an open-ended building scenario for single- and multiplayer



What is this?
This is an open-ended building scenario that aims to bring lore-driven tasks to your Space Engineers experience. The goal of this scenario is to layout the foundations of a colony on a newly claimed planet. You will join one of six factions, the Houses, and take a starting vehicle from the colony ship in orbit down to your designated starting zone. The colony ship will drop building tasks in the form of drop pods that contain blueprints that you are supposed to collect and build.
You will start with a small starting base, continue with faction-specific larger buildings, proceed to large public infrastructure projects and finally advance to space in order to build orbital stations and starships.
The scenario is highly customizable! You can change the settings and add mods at any given time, the scenario should still work with most of them.

Who is this for?
“Making Planetfall” can be played by up to 18 users but can be played in single player as well.
Playing this scenario in single player is absolutely doable, you will just need to adjust your playstyle slightly.
This is a scenario for the experienced Space Engineers player with survival experience. If you do not know how to save GPS coordinates or how to properly manage hydrogen fuel consumption, this scenario might not be (yet) for you.
In the vanilla experience, this scenario is also NOT combat oriented and definitely not PVP.

How to play it
The AIVR Minhera II is an Emperor Class Colonisation Ship that is in orbit around Arkhestas I. You start your briefing here, join a faction, launch the projects for your faction and take your faction hover craft from orbit to your designated landing zone. The Minhera II will send drop pods with projectors into your general area of operations from time to time. They are the tasks you are supposed to fulfil.

ATTENTION: LEAVE YOUR STARTING FACTION AND JOIN THE HOUSE FACTION YOU WANT TO PLAY IN BEFORE TRYING TO START THE SCENARIO

While you can stay in your designated landing zone that has guaranteed resources in the ground in order to set up operations, you are supposed to build a colony in the designated “settlement area”.
A part of the challenge is to find the drop pods in time before they run out of power, secure them and get them to their construction site without damaging them.
Every faction will have a series of building tasks that are tailored to their area of expertise. If you like to build refineries, join the House of Mizuel! If you prefer to bring power to the city, the House of Ripejut and their energy specialisation are for you.
Some of the projects are bigger and some are smaller than others, even in the same tier. This does not mean that some Houses get less work, as their later projects might turn out bigger.
This is a cooperative scenario. You are tasked with building a settlement – that means that your highly specialized facilities should be set to be accessible for everyone. If you built a refinery, other factions may use it.
There is no real goal beside the construction of the colony and all the interaction that might come along with it. However, the faction that takes on the most public and orbital contracts should be considered the most successful House of this scenario.



you can find the manual for this scenario here: https://steamcommunity.com/sharedfiles/filedetails/?id=3091930081

you can now find an add-on for this scenario here: https://steamcommunity.com/sharedfiles/filedetails/?id=3159994005


This World comes with OPTIONAL mods. You can remove them, but they are adding much to the atmosphere of the scenario.
The world comes with a NON-OPTIONAL mod:
Satreus by Major Jon
https://steamcommunity.com/sharedfiles/filedetails/?id=2266665708


Special thanks to Smokki and t0rx for beta-testing and giving me continuous feedback!




“How do winning conditions and progress conditions trigger?”
There are none. This is “just” a world with things placed in a story-telling order. The scenariowill “start” when you chose to follow the instructions on the stsarting ship

“Akhi.. Hakhu… what the heck?!”
Akhinnae – it’s my own world, with lore, language, history – I am a nerd, you know?

“DLC split the community, why do you use them here?”
For this scenario, you do not need to own any DLC. Please have a look in the scenario guide under "different ways to play"
94 Comments
LootGoblin Apr 12 @ 4:29am 
@Cardboard Overlord
Many thanks for the Tests. I did use the plugin as well and suspected it of some weird behavior but didnt want to belive it. Now i got rid of it, just to be sure. Also thanks a lot for the clarification what might caused the issue for you. Im like you, i hate when people do NOT mention what caused the issue for them.
Then again, no offense against the modder, im still using multigrid projector from him, which is awesome ;)
Again, Thank you ... very much appreciated
RaidenR Mar 24 @ 1:29am 
Many thanks! Amazing relaxing szenario until now!

Gonna go back to building now... hope there aren't too many metal grids (even though I know there are)
Sarekh  [author] Mar 23 @ 4:07pm 
@Raiden
Thanks for the feedback, it's on my to-fiy list now!

and here you go with the correct blueprint:

https://steamcommunity.com/sharedfiles/filedetails/?id=3198102041
RaidenR Mar 23 @ 1:14pm 
Seems like the Orbital Project III (orbital administration station) is the same as Orbital Project II (orbital hospital station)

The administration station is missing...
Cardboard Overlord Mar 23 @ 9:05am 
No worries. It's the least I could do after raising a false alarm. Besides, I hate it when people say "Nevermind, I fixed it" without saying what the fix was.

FYI, Performance Improvements is here:
https://sepluginloader.github.io/hub/details?type=plugin&id=viktor-ferenczi%2Fperformance-improvements

I've not noticed any problems before, but I've not really played scenarios much. There's a lot going on with changing game-systems in the background. Seems like it might be a likely culprit (out of what I was using) to cause problems with automation/scripting/scenario stuff.

Looking forward to playing this now, so I don't want to spend time troubleshooting, but if I ever decide to go back and try mods/plugins one-by-one to see which one broke it, I'll let you know what I find out.
Sarekh  [author] Mar 23 @ 8:41am 
Thanks for following up! :)
That does indeed not look like a terribly long mod-list (recently got an error-report from a user with over 100 mods installed, that was fun to go through - I suspect you're right and it might be the performance improvements - it might go through too few update ticks while in a complex environment - but it's only a suspicion. Thanks for sticking with it and I hope you have fun, still
Cardboard Overlord Mar 23 @ 8:09am 
Just tried it again without mods/plugins and it worked fine. Sorry, I should have checked before posting. That was lazy of me. Still, it might be useful info for others with the same problem. I don't know which was the problem (or if saving and quitting to add mods at the start broke something). For now here's a list of what I used:

PLUGINS:
Block Picker
Disable Analytics
Disable Spectator Mouse Sensitivity
File Cleaner
GPS Folders
In Game Exit
Performance Improvements (I wonder if this might be the culprit?)
Prevent Block Resize
Remove Intro Video
Tool Switcher

MODS (through workshop, not plugin loader):
Ore Detector + (by ACrispyCookie)
Welder Eyestrain Reduction
Colorful Icons
HUD - Modern and Fancy (Color)
Smooth Voxels
My own mod to change the highlight colour
Sarekh  [author] Mar 23 @ 7:14am 
The GPS coordinates will not get assigned automatically, you need to go to the library to the right of the briefing room and read the text panels with the GPS coordinates and then save the GPS coordinates in your GPS tab by double clicking on the grey, temporary coordinates.

The thruster issue sounds very much like a mod conflict to me. What mods do you run? (2/2)
Sarekh  [author] Mar 23 @ 7:14am 
Hey Cardboard Overlord, thanks for trying this out. I just downloaded a fresh copy and tried it out and was not able ato reproduce any of this for myself. All the hovercrafts, including the reserve units work as intended with thrusters for me.
The curiositas has this weird bug that some blocks in these scenarios even without computer components are "owned" (like thrusters who cannot be owned) because technically, the majority of the grid belongs to the founding NPC of the faction. You can quickly turn on admin privilges and fiy it by transferring the majority or all of the blocks to your ownership. That's a KSH limitation I can do nothing about. (1/2)
Cardboard Overlord Mar 23 @ 6:38am 
I thought I'd give this a try (in singleplayer) because it looks really great and I love the idea, but it doesn't seem to work properly.

Leave faction, join another, press 'start' - announcements happen, etc (ok so far). In a Beeblebum video, he got gps added here (I think) but this doesn't happen for me (but I already took GPS points from data pads). I go to faction sled, press the button outside the room, go in and unlock the magnet, get in and turn on power. Power comes on but no engines light up. They're all 'on' in the terminal and have fuel, but they don't work (no flame). I decided to take Curiositas instead, but after un-docking I don't own a lot of the blocks (more of an annoyance than anything else). I crashed that spectacularly because I didn't realise the parachute wasn't setup.

I'm running just a few plugins and mods, but nothing heavy, just a few visual/QoL things. Not sure if there's really a problem or if I'm just doing it wrong.