Cities: Skylines

Cities: Skylines

3,574 ratings
Advanced Vehicle Options
5
18
5
7
4
2
2
   
Award
Favorite
Favorited
Unfavorite
Mod
File Size
Posted
Updated
0.196 MB
Oct 26, 2018 @ 6:33pm
May 22 @ 1:22am
16 Change Notes ( view )

Subscribe to download
Advanced Vehicle Options

Description
Advanced Vehicle Options 1.9.8




Airports DLC Mod Compatibility and Loading Issues
If you have any issues with the new Airport DLC, please be sure to read Avanya's support discussions Game not working and the list of compatible mods.

Mod Description
This mod let you customize various options about vehicles. To access those options simply click on the vehicle icon at the bottom right of your screen (next to the policy icon). This workshop object is a fork of AVO version 1.8.2 published by Boogieman Sam[github.com], who has retired from the Cities Skylines modding community and left this mod open-sourced for the community.

Changelog
The Changelog can be found here or on the Wiki[github.com].

Compatibility
This mod can be safely removed without impact on the savegame. The AVO setting is kept inside the save file but will not cause any harm.

Source Code
Get the source code from the repository at GitHub. Feel free to contribute more functionality and help to fix existing issues. Link to AVO GitHub repository[github.com].

Known Issues
Still existing... Vanilla passenger trains no longer spawn in color variation. (31/12/2020)
New... Service Vehicle Selector (SVS2) will not show the Passenger Planes in the new selected Stand Type sizes. (22/05/2022)

Translations
Multi-language support is now available (thanks to algernon for setting up the translation framework!). English and German language is supported out of the box.

Additional languages (with contributors):
- Chinese Simplified (by YuLun)
- Japanese (by Adon)
- Korean (by TwotoolusFLY LSh.st)
- French (by mjm92150)
- Dutch (by Olympic1)

You can help translating this mod by contributing to the AVO Crowdin project[crowdin.com]. Leave a comment in the Language Translation discussion, if you want to support the community.


User Guide and Troubleshooting
[github.com]

[github.com]
Popular Discussions View All (6)
3
Sep 21 @ 10:43am
Workshop vehicles not showing up in Advanced Vehicle Options
mega mojo
16
Jul 21 @ 1:34pm
PINNED: Language Translation
Tim
1
May 21 @ 5:42pm
PINNED: Errors & Exceptions (Version 1.9.8)
Tim
< >
1,204 Comments
Tim  [author] 23 hours ago 
@braydenisdude - also as a side note:

Disabling a mod under circumstance is not sufficent, as the mods will be loaded anyway, but not visible in the game. You would need to unsubscribe. Your best bet is the Compatibility Checker for the time being to identify the issue.
Tim  [author] Sep 26 @ 11:46am 
@braydenisdude - here is a short guide for Compatibility Checker:

1 Subscribe to the mod "Compatibility Checker"
2 Start the game and enable the mod from the Content Manager in the main menu.
3 Setup in the mod options the report style [HTML/TXT], click either onetime "Generate Report(s)" or restart the game.
4 Your report(s) will be created every time you start the game. It will be ready when the main menu appears. You can turn of this function,
5 Inside the mod options there is a button to open the report as text file.

The Compatibility checker will tell you, if a mod is broker and will name you a replacement, if available. If not 100% clear, you can ask in the Compatibility Checker discussions for more guidance. Just click the link mentioned above to reach the workshop page for it.
Clunk Sep 25 @ 10:10pm 
@bradenisdude Extended Error Reporting can turn your error message into something more useful, at least to help identify the mod or asset in question - https://steamcommunity.com/sharedfiles/filedetails/?id=2055465280
braydenisdude Sep 25 @ 8:57am 
@Tim it still does not work, I disabled all of my mods besides advanced vehicle options and I keep getting the message, I'm not sure how to work the Compality Checker.
Tim  [author] Sep 23 @ 10:45am 
@braydenisdude - this error message means, that you have a mod which causes issues. Run the Compatibility Checker mod linked in the beginning to find broken mods and remove/replace them.
braydenisdude Sep 22 @ 5:31pm 
What does

"Object reference not set to an instance of an object [System.NullReferenceException]

Details:
No details" mean?
geospil Sep 20 @ 2:17pm 
I had cars from another build that I usually would just ban from spawning in the main menu (by deselecting ''alllow vehicle to spawn''). This has always worked for me, but hasn't since this last patch. So I just unsubscribed from those vehicles now.
Tim  [author] Sep 20 @ 12:28pm 
@Clunk - that is a wise decision and good recommendation. Here is a guide [thale5.github.io] for interested users, how to do that.
Clunk Sep 20 @ 12:12pm 
Restrict a vehicle from spawning by going to each building it spawns from and un/selecting it is not viable in a big city. I use Block Services and there's loads of them so there's no way I could visit every police station, fire station, hospital, garbage and crem block service etc., so I just added all the undesirable vanilla vehicles and bikes to the LSM prefabskip file. Works a treat. Just make sure you subscribe to a valid replacement from the workshop.
Tim  [author] Sep 20 @ 10:40am 
@Sotrax - this feature was introduced in the Airports DLC and it is a bit annoying, as they put the vanilla vehicles here instead of the "random" setting.