STEAM GROUP
Final Fantasy - Modding FF-Modding
STEAM GROUP
Final Fantasy - Modding FF-Modding
157
IN-GAME
1,773
ONLINE
Founded
July 26, 2015
Language
English
Location
United States 
All Discussions > Final Fantasy IX > Topic Details
gdi May 23, 2017 @ 12:18pm
Scaled UI (Memoria)
Just reposting a couple posts I made in the Memoria thread for greater exposure! Enjoy!

Originally posted by gdi:
Nevermind. I ported the UI mod I was working on from the old version of Memoria to the newer one.

http://imgur.com/01K04XG
http://imgur.com/GXy3ZsQ
http://imgur.com/NNxP2Q6
http://imgur.com/00dVTP3

Font in the latter 3 images here:
http://steamcommunity.com/groups/ff-modding/discussions/13/1290690926872942437/

Build which hopefully works no problem here:
mediafire [dot] com/file/ud03geydbz403ed

Left/Right will select Change/Defend respectively.

Apologies for not just releasing this back in apparently November when I first posted the source. I wasn't happy with it and it is incomplete(the Items menu(and possibly other menus?) doesn't scale IIRC). So I posted the source hoping someone more competent would take over the reigns and complete it. That hasn't happened, and something is obviously better than nothing.

It's pretty much untested outside of the first fight. I'm hoping it works. I'm like a sub-.200 batting average when it comes to me writing a program, building it, it working no problem for me but then when I give it to someone else to try... lol. Hopefully that isn't the case with this!

And to be clear, I probably won't be updating this or once it's confirmed to be working for people, even checking back here until RPG Limit Break next year gets me in the mood to play FFIX again. :p

It's pretty much just like Memoria. Extract, run Memoria.Patcher, play.

Once someone confirms it's working for them, I'll post a seperate thread for greater exposure. GL! lol

Originally posted by gdi:
Alright, awesome. Thanks Sefie! Yeah, I remember trying to scale the cursor and the sub-menus without much luck. I don't remember specifically what problems I was having though.

I'll go make a separate thread for it so more people see it.

I'm pretty much doing the same thing I did in November here, with the exception of I'm correcting the mistake of only providing the source, and providing a build as well. This is being provided AS-IS. No future updates or fixes are guaranteed and if I do update it, it will most likely just to make it functional again(which is pretty much what I did here). I'll provide the source for it in the separate thread if anyone wants to take over the reigns. Please do!

DOWNLOADS:
Build(FOR PLAYERS): mediafire [dot] com/file/ud03geydbz403ed
Source(FOR DEVELOPERS): mediafire [dot] com/file/79mqhihok7otoid

Players: Pretty much the same thing as Memoria. Download, extract, run Memoria.Patcher, play. Again, provided AS-IS. Don't expect me to update or fix anything here. It is incomplete, it's buggy, but it's something. And something is better than nothing, right? Hopefully someone else will take over, and complete it.

Developers: Do whatever you want with it. As much yours as it is mine as far as I'm concerned. Changes are commented with //gdi and //end. Only roughly ~10 changes. Have fun.

KNOWN ISSUES:
- Cursor will (always?) not appear at the start of the fight. Moving it will make it appear.
- Cursor positioning, specifically in the Target submenu, is off quite a bit.
- Magic and Item submenus are not scaled.
- Selecting Change or Defend with Cursor Memory on will cause some bugs, assuming the cursor is still trying to select them. Moving it looks like it solves it.
Last edited by gdi; May 24, 2017 @ 3:20pm
< >
Showing 1-15 of 22 comments
GuyInDogSuit May 23, 2017 @ 6:11pm 
Hopefully this can get fixed and integrated into Memoria.
Fraggoso May 24, 2017 @ 2:56am 
Didn't saw your posting here, gdi.

This is fantastic! I think the GUI overall was more demanding than my HD backgrounds and you (almost) did a perfect job on it!
Are you considering posting this on qhimm forum as well? If not, can I relink this over there?
gdi May 24, 2017 @ 6:58am 
@GuyInDogSuit
Are you having any significant issues with it or just the flaky cursor and unscaled Magic and Item submenus? I'll add a known issues to the main post so people know more what they're getting into.

@Fraggoso
I don't think I have an account there, so go right ahead. The "as much yours as mine" I put in the to developers section should probably go to the players as well. Anyone out there do whatever the fuck you want with it. :p
GuyInDogSuit May 24, 2017 @ 1:23pm 
Originally posted by gdi:
@GuyInDogSuit
Are you having any significant issues with it or just the flaky cursor and unscaled Magic and Item submenus? I'll add a known issues to the main post so people know more what they're getting into.

I haven't tried it yet as it's still in the early stages and I'm currently playing other things.
Fraggoso May 24, 2017 @ 1:50pm 
Can you pinpoint me to the scripts you changed to achieve this?
gdi May 24, 2017 @ 3:13pm 
Searching now, it looks like the 4 files changed are:

Assembly-CSharp/Global/battle/BattleHUD/BattleHUD.cs
Assembly-CSharp/Global/battle/BattleHUD/BattleHUD.Public.cs
Assembly-CSharp/Global/battle/BattleHUD/BattleHUD.Unity.cs
Assembly-CSharp/Memoria/Scenes/GONavigationButton.cs

BattleHUD.cs looks like it hides Change/Defend and does some shit with the cursor.
BattleHUD.Public.cs looks like it scales the Party's HP/MP/ATB part of the UI.
BattleHUD.Unity.cs looks like it resizes and scales the Command menu... in realtime. Probably a better way of doing that. And handles hiding/showing Change/Defend.
GONavigationButton.cs looks like it's removes the background and glow from the buttons.

Changes commented with "//gdi".
Last edited by gdi; May 24, 2017 @ 3:21pm
KaidenJames May 29, 2017 @ 10:13pm 
I'm a little confused as to how to install this. Can someone help please? Haha.
Dan Lel May 29, 2017 @ 10:31pm 
Kaiden I just hit the memoria patcher and it found my game folder somehow by itself. But the battle UI isn't complete, there are some cursor problems and skills/items aren't scaled properly. Is this still being worked on? It would be really nice to see this change.
freezeman42 Jun 3, 2017 @ 3:35am 
Hey there! I don't know if it's just me as I haven't seen it on this board but.. is it normal that I lost access to the steam overlay while installing it? I have the new UI with combats a little faster and all but when I shift+tab to get access to the overlay for the guides it doesn't work.. do you guys know if it's normal or is it something the creator is working on? Thanks a lot in advance! Great mod btw!! :rosewink::steamhappy:
(Shadow) Jul 12, 2017 @ 11:06am 
has there been any updates on this? it's pretty awesome I just wish some of the bugs could be fixed.
Eli Parker Aug 26, 2017 @ 12:00am 
Any update on this?
Eli Parker Aug 26, 2017 @ 9:47am 
Originally posted by Gwendalin:
Albeoris may, and I say MAY, be working on it, from what I heard from some source that properly isn't even true. So I'm not sure myself.
Upon that, I've added it to my "list of things to do on the side".
Not that I'm committing to it though, it should've been finished by the starter.

Thank you for the respones.
Fellox Sep 9, 2017 @ 9:44pm 
Hey, I am REALLY diggin the idea of this mod. Im not sure why, but Im getting some odd error. My install path is plainly in x86 program files. I had to put the memoria.path files right into the FFIX directory for the console to pick it up and try. This is the error when patching.

10.09.2017 12:12:57 |E| Unexpected error.
10.09.2017 12:12:57 |E| System.IO.IOException: The process cannot access the file 'C:\Users\ADMN-CRMSN\Desktop\FINAL FANTASY IX\Debugger\x64\Memoria.Debugger.exe' because it is being used by another process.
10.09.2017 12:12:57 |E| at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
10.09.2017 12:12:57 |E| at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
10.09.2017 12:12:57 |E| at Memoria.Patcher.Program.ReplaceDebugger(GameLocationInfo gameLocation) in F:\SIWO\Modding\FFIX\misc\Memoria-main\Memoria.Patcher\Program.cs:line 97
10.09.2017 12:12:57 |E| at Memoria.Patcher.Program.Main(String[] args) in F:\SIWO\Modding\FFIX\misc\Memoria-main\Memoria.Patcher\Program.cs:line 25

Im really saavy and can always figure this stuff out and get it going, this however stumps me. I tried running the debugger, I tried running the memoria script compiler itself, nada. No one else seems to have any issues like this, why me lol
GuyInDogSuit Sep 10, 2017 @ 1:18pm 
Delete the two folders inside the Debugger directory and run Memoria again.
Fellox Sep 11, 2017 @ 7:49pm 
Originally posted by GuyInDogSuit:
Delete the two folders inside the Debugger directory and run Memoria again.

Awesome! Fast reply, and it did indeed work- the game patched successfully! Thank you much

The game now only opens to a black screen, no sound, but maybe ill figure this out. I was also having those battle intro freezes before. Likely an AMD thing (another! Grrr..)
Thank you again for the hasty help though, my man
< >
Showing 1-15 of 22 comments
Per page: 1530 50

All Discussions > Final Fantasy IX > Topic Details