X4: Foundations

X4: Foundations

View Stats:
This topic has been locked
EGO_zav  [developer] Nov 30, 2018 @ 12:44pm
VULKAN issues / Game not starting up / Instant crash
This thread collects various solutions to issues with for graphiccard related crashes and issues.
The general rule is: If the game does not run or causes problems FIRST try upgrading to the latest driver.



Crash on startup / related o steam overlay not working with Vulkan

If the game crashes at gamestart and/or when starting a new game, try if disabling the Steam overlay fixes it. --> We are working on fixing this on our side of course.


Vulkan crashes 1

1. Try run vulkaninfo in command promt, If get error goto 2 :)
2. uninstall Nvidia driver with DDU(Display Driver Uninstaller)
3. Install latest driver.

for AMD Graphic cards users: Please consider to upgrade your driver to optional version 18.12.1


--> If DDU delete did not work vulcan(simply reinstall driver no fixing problem in vulcan)


Laptop with Nviia + Intel GPU / Computer with multiple graphic cards

Vulkan engine might be trying to open the wrong graphic card. To fix this you can temporarily disable a graphic card in your device manager without physically taking the card out of your machine.

Problems with Windows 8.1 on AMD hardware

We are aware that on Windows 8/8.1 the minimum recommended driver version is officially not supported by AMD anymore. You can try out the Windows 7 drivers, but have to do on your own risk.

We are currently investigating the situation and looking into alternative solutions.


Vulkan new driver installation not fixing issues

Because an older AMD driver did not correctly uninstall there are sometimes incorrect files left on the systems. If you have amd-vulkan64.json in your system32 folder

Solution1:
Please open this file:
C:\WINDOWS\System32\amd-vulkan64.json
and search for "abi_versions" and replace it with "api_version".

Solution 1:
Alternative solution which does not require editing this file is to delete
C:\WINDOWS\System32\amd-vulkan64.json
and then reinstall the driver!

VULKAN.dll ERROR

If you see a message about "vulkan-1.dll was not found", then you must update your graphics card driver! We require up to date drivers with VULKAN support!


Obvious graphical glitches after longer time of playing

This could be caused by your GPU running out of memory. We have this reproduced with 3 to 4GB GPUs when running in 4K for example. The game does currently not warn you that this is a bad idea. We will add a warning.

A note about VSync for Nvidia based systems:

Nvidia drivers have a minor issue with how they name their VSync options towards Vulkan games (like X4). You will therefore note, that the default VSync mode name "Triple Buffering VSync” is in fact NO VSYNC. You may have to try out the others modes depending on your driver version. Nvidia is working on fixing this naming issue.


If everything else fails, please email your DXDiag and VULKANINFO output to info@egosoft.com

-Bernd
Last edited by EGO_zav; Nov 30, 2018 @ 1:03pm
< >
Showing 1-15 of 36 comments
Bullraku Nov 30, 2018 @ 12:46pm 
wenn man die amd-vulkan64.json datei löscht kommt zumindest nichmehr die meldung"x4 stopped working" dann kommt nur noch blackscreen mitm cursor und dann gehts nimmer weiter :`D
critic Nov 30, 2018 @ 12:47pm 
I was crashing on startup, my "vulkaninfo" in CMD was reporting that the Vulkan driver was missing, downloaded the latest Nvidia driver directly from Nvidia site, the game works now and vulkaninfo is reporting a few pages of stuff.

You don't need to uninstall the current driver.

https://developer.nvidia.com/vulkan-driver
EGO_zav  [developer] Nov 30, 2018 @ 12:47pm 
Ha

Originally posted by Bullraku:
wenn man die amd-vulkan64.json datei löscht kommt zumindest nichmehr die meldung"x4 stopped working" dann kommt nur noch blackscreen mitm cursor und dann gehts nimmer weiter :`D

Hast Du dann die Treiber neu installiert?
Bullraku Nov 30, 2018 @ 1:01pm 
hm.. ne davor ich teste mal :D
Bullraku Nov 30, 2018 @ 1:08pm 
treiber neu installiert kommt bis zum menübild mit musik drückst iwas crasht es..:`D
Laffinguy Nov 30, 2018 @ 1:09pm 
The old AMD driver was my problem, game is now running fine.
Thanks Bernd you the man!
GhostSpartan Nov 30, 2018 @ 1:10pm 
To people commenting in this post, another potential fix that just worked for me. My game installation was not located in my C drive. I just moved the game to my C drive and it now launches for me.
Alex [GER] Nov 30, 2018 @ 1:20pm 
Hey Leute, mein Spiel startet leider nicht...,
Kann mir jmd sagen ob eine AMD Radeon R9 200 Series Grafikkarte Vulkan unterstützt?
Bekomme immer die Fehlermeldung, wie oben schon geschrieben: "vulkan-1.dll was not found".
Hab über Systemsteuerung Win7 bereits versucht die Treiber zu aktualisieren, dort wird mir angezeigt, sie sind aktuell.
Muss ich vielleicht etwas anderes probieren?
VG und Danke!
Last edited by Alex [GER]; Nov 30, 2018 @ 1:23pm
No mic Nov 30, 2018 @ 1:24pm 
I've installed the latest AMD driver 18.12.1 still getting crash at start up. This time it doesn't link me to this page https://www.egosoft.com:8443/jira/browse/X4-2 so I dont know what's the error this time.

GPU: AMD R9 290x
AMD driver: 18.12.1
OS: Windows 10

I've also installed the Vulkan SDK, I picked the latest one (1.1.92.1) https://vulkan.lunarg.com/sdk/home#windows
Last edited by No mic; Nov 30, 2018 @ 1:27pm
Grimmreaper29 Nov 30, 2018 @ 1:26pm 
My game keep throwing me back to the desktop and shut's off without reason. It's realy frustrating
Blc Nov 30, 2018 @ 1:26pm 
Hello, after some play time i lose parts of textures from space sphere. I have only white stripes mixed with textures .... how to fix this??? If i reload game, nothing changed. I have i5 @2.66, 8 GB RAM and GeForce GTX 1050 Ti
Chrost Nov 30, 2018 @ 1:28pm 
Maybe not using that crappy buggy messed up API someone called Vulkan -.-
Doesnt even work on Linux at all, and now on bRainFart OS neighter. Never use it anyway. I gonna stick to OpenGL !
Last edited by Chrost; Nov 30, 2018 @ 1:33pm
Lupo Nov 30, 2018 @ 1:31pm 
Originally posted by Blc:
Hello, after some play time i lose parts of textures from space sphere. I have only white stripes mixed with textures .... how to fix this??? If i reload game, nothing changed. I have i5 @2.66, 8 GB RAM and GeForce GTX 1050 Ti

Some advice from one of the Devs:

https://steamcommunity.com/app/392160/discussions/0/1743353164083520215/?tscn=1543606682#c1743353164083898340
steineib Nov 30, 2018 @ 1:39pm 
noch irgendwelche ideen die weiter helfen könnten ?
Vank Nov 30, 2018 @ 1:43pm 
im litteraly about to ♥♥♥♥♥♥♥ refund because of how ♥♥♥♥♥♥♥ stupid this is ive tried all the fixes that apply and still the ♥♥♥♥ crashes on new game like wtf
< >
Showing 1-15 of 36 comments
Per page: 15 30 50

Date Posted: Nov 30, 2018 @ 12:44pm
Posts: 36