Steam for Linux > Limited Beta > Détails du sujet
directhex 18 nov 2012 à 10h19
Game textures overwritten by Steam overlay on Intel cards
I'm seeing a few games where in-game textures are being corrupted after the Steam overlay has been opened, on Intel HD3000 and Intel HD4000. Key examples are the world select menu in World of Goo, and the track information at the bottom of the screen in Osmos. The issue does not happen with fglrx on AMD.
Affichage des commentaires 1 à 15 sur 18
< >
lordheavy 18 nov 2012 à 10h58 
Similar issue witha radeon HD 6870 and mesa drivers (9.1-devel)
Gilgamesh 18 nov 2012 à 16h57 
I had this a while back (or at least I think it's the same issue).
I could never reproduce the issue and as it hasn't occurred since then, I thought it was a one-off thing that was fixed.

Anyway, I did grab a screenshot and I would like you to confirm if it is indeed the same problem.
https://www.dropbox.com/s/53qtngessar0m0q/Screenshot%20from%202012-11-12%2019%3A00%3A18.png
The same type of corruption was constant throughout the games UI, including the HUD during gameplay, until I restarted.

I'm running Ubuntu 12.04 64-bit Unity with an AMD Radeon HD 6950.
Dernière modification de Gilgamesh; 18 nov 2012 à 16h58
directhex 19 nov 2012 à 0h58 
Nah, I've been having the reverse issue - overlay causes broken game display. Let me try & grab a screenshot.
directhex 19 nov 2012 à 1h04 
Okay, here's the post-overlay corruption on Osmos - note the screwy text at the bottom: http://steamcommunity.com/sharedfiles/filedetails/?id=109006896

Here's the post-overlay corruption on World of Goo - note the screwy, well, everything: http://steamcommunity.com/sharedfiles/filedetails/?id=109006759
kigucdoshu 24 nov 2012 à 2h45 
Dernière modification de kigucdoshu; 24 nov 2012 à 2h47
Omnius Potato 28 nov 2012 à 16h17 
Some textures of game are replaced with ones used in overlay whenever I open steam overlay, in Amnesia running with opensource radeon drivers (e.g. dust effect turns to flying letters).
[url]
Dernière modification de Omnius Potato; 28 nov 2012 à 16h19
directhex 28 nov 2012 à 16h30 
Hm... so not an Intel bug after all, but Mesa instead?
James 28 nov 2012 à 22h39 
I was also able to reproduce the problem in World of Goo using a Radeon HD 5770 with the open source drivers:

http://steamcommunity.com/sharedfiles/filedetails/?id=110668123

So it probably is either a bug in Mesa based drivers, or a bug in the overlay that is only triggered by Mesa based drivers.
Psidium 30 nov 2012 à 4h58 
I got the same problem, first before adding the PPA ubuntu-x-swat/x-upates. I thought it was an outdated driver problem, but it still happened after adding it and restarting my computer.
Frank 3 déc 2012 à 14h15 
Added to the bug database.
Tarvitz 3 déc 2012 à 14h20 
Same issue on HD6850 and fglrx-updates drivers (ubuntu 12.10 x86)
Dernière modification de Tarvitz; 3 déc 2012 à 14h20
RussianNeuroMancer 3 déc 2012 à 19h29 
fglrx-updates is September build. You need at least November build of driver for Steam. Check if it sill reproducible with Catalyst 12.11.
Installation manual: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29_BETA.2FEXPERIMENTAL
Dernière modification de RussianNeuroMancer; 3 déc 2012 à 19h29
kirrun 7 déc 2012 à 1h38 
Gentoo amd64, Intel GM45 video, emul-linux-x86-*-20121202, xf86-video-intel-2.20.15, mesa-9.0.

In World of Goo this happens only on the title screen. If I choose chapter this doesn't happen anymore. But if I return back to the title screen everything is messed up again.
Affichage des commentaires 1 à 15 sur 18
< >
Par page : 15 30 50