Steam for Linux > Limited Beta > トピックの詳細
directhex 2012年11月18日 10時19分
Game textures overwritten by Steam overlay on Intel cards
I'm seeing a few games where in-game textures are being corrupted after the Steam overlay has been opened, on Intel HD3000 and Intel HD4000. Key examples are the world select menu in World of Goo, and the track information at the bottom of the screen in Osmos. The issue does not happen with fglrx on AMD.
1-15 / 18 のコメントを表示
< >
lordheavy 2012年11月18日 10時58分 
Similar issue witha radeon HD 6870 and mesa drivers (9.1-devel)
Gilgamesh 2012年11月18日 16時57分 
I had this a while back (or at least I think it's the same issue).
I could never reproduce the issue and as it hasn't occurred since then, I thought it was a one-off thing that was fixed.

Anyway, I did grab a screenshot and I would like you to confirm if it is indeed the same problem.
https://www.dropbox.com/s/53qtngessar0m0q/Screenshot%20from%202012-11-12%2019%3A00%3A18.png
The same type of corruption was constant throughout the games UI, including the HUD during gameplay, until I restarted.

I'm running Ubuntu 12.04 64-bit Unity with an AMD Radeon HD 6950.
最近の変更はGilgameshが行いました; 2012年11月18日 16時58分
directhex 2012年11月19日 0時58分 
Nah, I've been having the reverse issue - overlay causes broken game display. Let me try & grab a screenshot.
directhex 2012年11月19日 1時04分 
Okay, here's the post-overlay corruption on Osmos - note the screwy text at the bottom: http://steamcommunity.com/sharedfiles/filedetails/?id=109006896

Here's the post-overlay corruption on World of Goo - note the screwy, well, everything: http://steamcommunity.com/sharedfiles/filedetails/?id=109006759
directhex 2012年11月24日 2時23分 
kigucdoshu 2012年11月24日 2時45分 
最近の変更はkigucdoshuが行いました; 2012年11月24日 2時47分
Omnius Potato 2012年11月28日 16時17分 
Some textures of game are replaced with ones used in overlay whenever I open steam overlay, in Amnesia running with opensource radeon drivers (e.g. dust effect turns to flying letters).
[url]
最近の変更はOmnius Potatoが行いました; 2012年11月28日 16時19分
directhex 2012年11月28日 16時30分 
Hm... so not an Intel bug after all, but Mesa instead?
James 2012年11月28日 22時39分 
I was also able to reproduce the problem in World of Goo using a Radeon HD 5770 with the open source drivers:

http://steamcommunity.com/sharedfiles/filedetails/?id=110668123

So it probably is either a bug in Mesa based drivers, or a bug in the overlay that is only triggered by Mesa based drivers.
Kahinee 2012年11月30日 4時58分 
I got the same problem, first before adding the PPA ubuntu-x-swat/x-upates. I thought it was an outdated driver problem, but it still happened after adding it and restarting my computer.
Frank 2012年12月3日 14時15分 
Added to the bug database.
Tarvitz 2012年12月3日 14時20分 
Same issue on HD6850 and fglrx-updates drivers (ubuntu 12.10 x86)
最近の変更はTarvitzが行いました; 2012年12月3日 14時20分
RussianNeuroMancer 2012年12月3日 19時29分 
fglrx-updates is September build. You need at least November build of driver for Steam. Check if it sill reproducible with Catalyst 12.11.
Installation manual: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29_BETA.2FEXPERIMENTAL
最近の変更はRussianNeuroMancerが行いました; 2012年12月3日 19時29分
kirrun 2012年12月7日 1時38分 
Gentoo amd64, Intel GM45 video, emul-linux-x86-*-20121202, xf86-video-intel-2.20.15, mesa-9.0.

In World of Goo this happens only on the title screen. If I choose chapter this doesn't happen anymore. But if I return back to the title screen everything is messed up again.
1-15 / 18 のコメントを表示
< >
ページ毎: 15 30 50