XCOM 2
252 ratings
Missing Packages Fix - Parcels and Maps Edition
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
393.027 MB
Sep 21, 2017 @ 1:04pm
Oct 11, 2017 @ 4:08pm
5 Change Notes ( view )

Subscribe to download
Missing Packages Fix - Parcels and Maps Edition

Subscribed
Unsubscribe
In 1 collection by ∑3245
E3245's Master Mod Collection for War of the Chosen
29 items
Description
This bugfix is for map mods or mission mods. smh right now FXS.

For some reason unbeknowest to us, some packages are not loaded in WotC, or rather, do not exist at all, breaking a lot of mods that adds new maps or missions. This is intentional to reduce the size of WotC. This mod fixes that problem.

Will be required for any mod that adds any new parcels or missions. For now, RealityMachina's MOCX Initiative needs this to work properly.

If you have any other packages that you want loaded, then post in the discussion section.

LOG
Release Ver: 1.300:
-Added several new packages:
  • CityCenterFountain.upk
  • CityCenterStatuesA.upk
  • StringLights.upk
  • TemperatePlateaus.upk

Release Ver: 1.200:
-Added several new packages:
  • PCP_Plates.upk
  • PCP_Plates_XPACK.upk
  • ALN_HallwayPlate.upk
  • FX_Ocean_Water.upk
  • FX_ATM_Holograms.upk
  • MissionAssets_SupplyExtraction.upk

Release Ver: 1.100:
-Added several new packages:
  • FX_Atmospherics.upk
  • FX_Billboards.upk
  • FX_Destruction_Foliage.upk
  • JB_TestPackage.upk
  • FX_Destruction_Foliage_Materials.upk

Release Ver: 1.000:
-Initial release.
Popular Discussions View All (1)
10
Dec 5, 2017 @ 3:35am
PINNED: Request the name of the package that you need for your mod
∑3245
< >
46 Comments
rpurds Jul 21 @ 2:02pm 
Any chance of changing the textures on operatives' glasses and such from the ugly checkboard pattern to the original texture or whatever they changed?
Sad Rock Jul 5 @ 6:59pm 
I've also been unsubbed from any non-wotc mods for quite some time.
Sad Rock Jul 5 @ 6:50pm 
@Dragon32

I'm not using any map packs, as i thought initially that was the thing causing the issue in the first place.
I've tried running without map packs, without this mod, without a few others, but on startup for random missions i've gotten this same error, aside from one time where the error was in response to something with a tree.

It's been black site missions, resistance missions, etc etc. Even the UFO. It doesn't seem like it's following any specific pattern as far as what missions it occurs on, just seems like a few certain maps when they're rng'd.
Dragon32 Jul 4 @ 10:49am 
@Sad Rock:
Wonder if you're using a map pack for the base game in WotC? That error appears to be complaining about a texture being one size (i.e. from the base game) when it should be another (i.e. from WotC).
Sad Rock Jul 3 @ 10:13pm 
Unsure if this is entirely related to this mod, or if this is just a general thing, but this is what i'm getting on a majority of crashes. By that, I mean all but one crash has this.


[0351.49] Log: Tactical Load Debug: Generating Map
[0352.49] Critical: appError called: Assertion failed: appErrorf [File:G:\BuildAgent\work\ce3b64a62966ccd1\branches\ShippingOzzy\XCOM2\Development\Src\Core\Src\UnLinker.cpp] [Line: 3764]
Texture2D FenceWoodenA.Textures.FenceWoodenA_DIF: Serial size mismatch: Got 524897, Expected 699697
Stack: Address = 0x492aa3dc (filename not found) [in D:\SteamLibrary\steamapps\common\XCOM 2\XCom2-WarOfTheChosen\Binaries\Win64\XCom2.exe]
Mr. Bibbles May 29 @ 7:53am 
https://steamcommunity.com/sharedfiles/filedetails/?id=1397733866

Looks like the textures to the Advent street lamp is missing.
PatientLandBeaver May 8 @ 3:38pm 
@Erazil Also confirmed this bug. Same thing happened to me on current playthrough.
maschmelzer Feb 6 @ 5:17pm 
I have had two missions that I had to fail because the location of the place to put Charges to blow up a required item was off the map, or imbeded in rock.
Erazil Jan 31 @ 1:05am 
Possibility Major Bug Found

Mission tutorial for Unlocking the Reaper :
- second part of the mission with Mox
- trigger for launch the movie and explodes the truck do not work.
Result: impossible to finish the mission, blocked campaign.

i just disabled this mod, reload the same saved game that was blocked and the trigger has worked again.

Before finding I have try relaunched twice the mission (so 2 different mission), reboot Xcom 2, reload same saved game... always buged.
Moonsword Nov 29, 2017 @ 9:59am 
I'm having problems similar to Gordo's and Brakkey Gurdy I's, with both MuseumArt_A and MuseumArt_C:
[1572.77] Error: Error, NumMips of (Texture2D FX_Billboards.ArtTextures.Field3_01) must be greater than 0. Please recreate the Texture2DArray: Texture2DArray FX_Billboards.Array_MuseumArt_C
[1572.77] Error: Error, NumMips of (Texture2D FX_Billboards.ArtTextures.StreaksWood_01) must be greater than 0. Please recreate the Texture2DArray: Texture2DArray FX_Billboards.Array_MuseumArtA

I suspect there's something missing in the FX_Billboards.upk that was added in version 1.100 related to the museum billboards.