XCOM 2
69 ratings
One Million Colours Plugin For WOTC
 
Rate  
Favorite
Favorited
Unfavorite
Tags: Modfix
File Size
Posted
Updated
0.205 MB
Sep 12 @ 1:58pm
Oct 21 @ 2:01am
4 Change Notes ( view )
You need DLC to use this item.

Subscribe to download
One Million Colours Plugin For WOTC

Subscribed
Unsubscribe
Description
REQUIRES ORIGINAL MOD: http://steamcommunity.com/sharedfiles/filedetails/?id=1091135816

Plugin to make One million colours works with WOTC photobooth.

This mod will also allow such colour customiztion on hero soldiers.

Compability:
Overwrites UITactical_Photobooth, UIArmory_Photobooth
< >
36 Comments
sebkulu Nov 20 @ 4:13pm 
Thanks for your answer :)
Oh I see, that's why it's not compatible at all...
Indeed I do not redefine the same functions and I thought compiler would add code instead of replacing it completely, apparently it does not...
-bg-  [author] Nov 20 @ 1:19pm 
PopulateGraphicsList, SetTextColor and PreviewTextColor

Also class overrides are not compatible with each other anyways, unrealscript doesn't support overriding just a function without the whole class.
sebkulu Nov 20 @ 4:56am 
Hi -bg-, I'm at work right now, so I can't look into your code, so please goocould you tell me what are the functions you redefine in both classes?
I'm asking 'cause I work on an other mod that will override those classes also, but it seems that right now both are incompatibles.
-bg-  [author] Nov 5 @ 11:48am 
Do not use indexed arrays when adding photobooth entries, refer to the more photobooth filters mod on how to add new options without fking up compability with other mods that do the same
Cato Heresy Nov 4 @ 4:57pm 
I've also noticed that [X2Photobooth] as a class is actually duplicated twice within XComGame.int It's first used mid-way for the array strings you target to add filters, then again in the post-game text section which adds the photobooth quotes.

This seems like an error, as my lines would be added to the first [X2Photobooth] section and thus not read by the game in the correct order.
Cato Heresy Nov 4 @ 4:56pm 
I wanted to publish a simple mod which adds additional quotes to the [X2Photobooth] section in XComGame.int localization file. For example:

[X2Photobooth]
m_arrSquadALines[30]="Only the very best wear this uniform"

The problem is, the game refuses to accept the new code from a mod. But if I paste the new lines directly into the vanilla XComGame file under the correct section, Photobooth accepts and shows the new strings in-game.

@-bg- Does Photobooth handle localization wierdly? I tried putting my lines into an empty XComGame.int file within your mod as a test and it still did not run.

This issue persists on a vanilla clean install with only my mod present, then with only your mod present. I have succesfully modded new strings into XComGame.int before. Any help or thoughts greatly appreciated!

Astery Oct 21 @ 9:39pm 
tried for a bit and can confirm fixed, i can take pics again, thanks bg!
Zyxpsilon Oct 21 @ 9:23pm 
Fixed it for me.. thanks! ;)
-bg-  [author] Oct 21 @ 2:02am 
ok updated both base mod and this mod to use new method that has less overrides, the weird bug can no longer be reproduced.
Skarsatai 2.0 Oct 20 @ 11:26pm 
Hello -bg- .Before my first post I deleted all config files, verified all game files. Without the million mods started a vanilla game wotc. works. activated million mods, blur appeared again. When I run wotc normally, I use 218 mods all works well without million colours. Activating million colours causes the blur.