XCOM 2
More Squad Size Upgrades - WotC
< >
562 Comments
時處暑 Feb 27 @ 11:00pm 
扩充你的小队到8人,非常棒的插件,原版的6人根本不够用。
videogamerlink Feb 26 @ 12:58am 
@Maliwan116 I modified the setting in the mod's config directly versus the created config files in Documents/my games/XCOM 2 War of the Chosen/XComGame/Config/. Just wanted to confirm that changing the value to the same value you set for robojumper's Squad Select worked for me and I thank you for posting. It saved me retaining this mod in my collection.
LightenedDark Jan 25 @ 12:10pm 
I know the mod author hasn't responded in 9 pages and a year and a half, but having this mod allow another 2 squad upgrades would be great... :)
Maliwan116 Dec 27, 2019 @ 8:13pm 
@jpod this is probably due to the fact that the Documents\my games\XCOM2 War of the Chosen\XComGame\Config\XComMSSU_Settings.ini has a setting for max soldiers set to 4 by default. I changed this to reflect what is selected for robojumper's mod and it seems to be working. I haven't messed with it enough to know if robojumper's mod is still handling default squad size or if this mod is after editing the ini.
jpod Dec 25, 2019 @ 3:36pm 
So the compatibility selection does not work. I also have robojumper activated. Started a new campaign and all went well until I got to the first mission after entering sky ranger. Even with compatibility it will only allow 4 units in the mission, went to deactivate the mod and still it was just 4 units. I proceed to unsub from this mod and it fixed it as I now have all 10 units.
Dragon32 Nov 13, 2019 @ 9:43am 
@flango:
Not this mod alone, I've used it with squads of eight troopers. I've fought off a Chose assault and assaulted Chosen strongholds but haven't had an Avenger defence mission.
flango Nov 13, 2019 @ 8:43am 
Also crashed on the Avenger Defence intro, possibly because of this mod.
flango Nov 13, 2019 @ 7:28am 
Crashes at mission intro when using more than 6 soldiers (Hunter stronghold to be exact)
Layn Nov 12, 2019 @ 10:29am 
How can I edit the vanilla upgrades? I wanted to put the Size I for squaddies and Size II for sargents.
Dragon32 Oct 16, 2019 @ 3:26pm 
@Charlemagne:
Are you running the Highlander mod and Allow For Larger Squads (or have edited the Highlander .ini yourself)?

There's only room for 9 people on the standard deployment square, the Highlander allows for it to be increased. That could cause that glitch
Charlemagne Oct 16, 2019 @ 2:12pm 
Then something seems to be wrong on my side. I've been in about 20 missions, I have both the ADVENT perk (had it for about the last 4 missions) and the Resistance perk (for all of the 20), and I have only seen an ADVENT guy once, and furthermore he was glitched underground and not available. Maybe I have just been incredibly unlucky, too. I was really looking forward to a 10-man squad (8 X-Com, an ADVENT and a Resistance).
Dragon32 Oct 16, 2019 @ 9:38am 
@Charlemagne:
No it doesn't. I've had both resistance operatives and ADVENT turncoats in my squad with this mod active.
Charlemagne Oct 15, 2019 @ 8:16pm 
Does this mod prevent you from getting random Resistance fighters/ ADVENT soldiers during missions? I have the perk for getting a random Resistance guy, but I have been in several missions and none have showed up. Perhaps because it takes over the slots?
Tim_ Oct 9, 2019 @ 1:33am 
I just completed a WOTC campaign with 104 mods including this one. This mod worked well, love it and will use it again.
Lord_Zarfax Oct 7, 2019 @ 7:06pm 
need a up date
jpsweeney94 Sep 22, 2019 @ 11:47pm 
Using with robojumper squad select. I set this mod to compatibility and i set starting squad to 6 with robojumper in mod config menu. I was only expecting to see squad sizes 3 and 4 since i started with 6... but now i still see 1 and 2 at the same price. How do i remove the first 2, only leaving the new upgrades?

thanks
Dragon32 Aug 13, 2019 @ 9:28am 
@BTAxis:
Did you try manually editing
Documents\My Games\XCOM2\XComGame\Config\XComMSSU_Settings.ini
BTAxis Aug 12, 2019 @ 4:03pm 
@Dragon32: Yes, but the config only goes up to rank 7. I was asking for rank 8, which is not possible as far as I can see.
lovett1701 Jul 17, 2019 @ 9:13am 
Thank you for this BlueRaja, my father and i played the original Xcom: ufo defense and the squads were bigger. this brings me happy memories of slaughtering aliens:steamhappy:
Dragon32 Jul 5, 2019 @ 7:50am 
@*Indecipherable Shitposting*
- Go to XComGame.ini in [Robojumper's Squad Select]'s Config folder.
- [Remove the semi-colon from the beginning of] bDontTouchSquadSize=true"
Vlad - A States Right To What? Jul 4, 2019 @ 5:55pm 
@Xarek I'm trying to follow along with your instructions but I'm confused as to what you mean by "2) Disable the Starting Squad Size setting in Robojumper's Squad Select:
- Go to XComGame.ini in this mod's Config folder.
- Uncomment bDontTouchSquadSize=true"

Specifically the two underlined phrases.
Dragon32 Jun 26, 2019 @ 5:00pm 
@mike_calhoun420:
Did you clear out your configs?
https://www.reddit.com/r/xcom2mods/wiki/mod_troubleshooting
mike_calhoun420 Jun 26, 2019 @ 4:03pm 
+1 for rank requirement 8. Tried editing the config file to set it to 8 but it just goes back to 7.
Flamingcheesepie Jun 21, 2019 @ 10:13am 
Any possibilities of getting 4 extra upgrades? Feel like there's a sense of progression through the campaign if it happened. Then you could have like 2/3/4/5/6/7 ranks each get an upgrade. Would possibly also have to expose the costs of the base squad size upgrades if so.
Commodus May 12, 2019 @ 5:40am 
Anyone know how you can get more than six soldiers in the photobooth? thanks:)
Dragon32 Apr 16, 2019 @ 9:01am 
@BTAxis:
You can change the rank requirements for the squad size upgrades.
BTAxis Apr 16, 2019 @ 2:46am 
Please consider allowing a rank requirement of 8, as several class mods, notably including RPG Overhaul, allow soldiers to rank up to Brigadier. Also, would it be possible to add MCM configuration for the vanilla squad size upgrades?
Someone Else Apr 10, 2019 @ 8:27pm 
Is there a way to increase the number of upgrades past the two provided by default?
Xarek Apr 8, 2019 @ 9:48pm 
4) Once you start the game, go to the respective MCMs and set your preferences accordingly. The Squad Size Option in Robojumper's Squad Select's MCM should be gone. Remember to set More Squad Size Upgrades to COMPATIBILITY MODE if you haven't done so already.

5) All should work well.

Now you can have squads of 9, 10, 11, or (gulp) 12 soldiers. The game might act up with 11 or 12 though during missions where you also control VIPs, aliens and other extra units. Don't go crazy.
Xarek Apr 8, 2019 @ 9:39pm 
Despite the Compatibility Mode, this Mod will affect the Squad Size setting in Robojumper's Squad Select.
For a starting squad size larger than 4 to work properly you have to:
1) Make sure to have started the game with the mods installed beforehand, so the appropiate ini files get generated.
2) Disable the Starting Squad Size setting in Robojumper's Squad Select:
- Go to XComGame.ini in this mod's Config folder.
- Uncomment bDontTouchSquadSize=true

3) Set the Starting Squad size proper:
- Go to ...\my games\XCOM2 War of the Chosen\XComGame\Config
- Edit the file XComMSSU_Settings.ini
- Set StartingSquadSize to your liking.

Default behavior is a full total of 8 soldiers (4 + the 2 base game upgrades + 2 from this mod). Note that setting StartingSquadSize above 5 is not recommended unless you have Allow For Larger Squads WotC Mod.
PossumFlavored Apr 5, 2019 @ 1:38pm 
and stile broke. Shrugs. Moving on now, thanks for trying to help
Dragon32 Apr 5, 2019 @ 1:04pm 
@Daniel_USA:
Heh. "Just".
Mr. Santos Apr 5, 2019 @ 12:04pm 
maybe you should just make a video and post it dragon?
PossumFlavored Apr 5, 2019 @ 10:59am 
@dragon32 ah, my eyes somehow just glided over that before somehow. Thanks.
Dragon32 Apr 5, 2019 @ 10:52am 
@PossumFlavored:
Have you edited StartingSquadSize? AFAIK, that's not exposed to MCM. Set that to 8 then use the 4 squad upgrades
PossumFlavored Apr 5, 2019 @ 10:06am 
@dragon32 This mod works fine, except that it overwrites robojumps squad size adjustment for me. If I wanted to max out at 8 soldiers it would be great, but im going for 12. I can still get there, its just this mod was goign to make it more dynamic if it did work with robo's for me.
Dragon32 Apr 5, 2019 @ 8:58am 
@PossumFlavored; Daniel_USA:
I'm up to a squad size of seven using this mod and Robojumper's Squad Select without a problem.

All squad size-affecting options disabled for Robojumper's Squad Select (.ini and MCM) and all squad select-affecting options disabled for MSSU (.ini and MCM).
PossumFlavored Apr 5, 2019 @ 6:11am 
Thats standard for robojumps, this mod still broke mine in the way I stated. Stuck are 4 troopers with this mod active unless upgrade the squad size via the mod.
Mr. Santos Apr 5, 2019 @ 12:45am 
dont know if it was working before but i removed this mod and just use robojumps.

it wasnt until that mod was working that I realized you have to manually move the soldiers and new slots appear.

at the screen where you select what soldiers you are going to send on a mission there is a change view button, click it and it turns into an isometric view, then hold the mouse button and the soldiers start to rotate.
PossumFlavored Apr 4, 2019 @ 9:03am 
Im having a similar problem to Daniel, its breaking Robojumpers squad select even if changes in the ini. and config menu to be compatable. Overwrites any changes Robojumper makes to squad size.
Mr. Santos Apr 4, 2019 @ 2:08am 
can't get the mod to work. I just finished the last two squad unlocks and it's stuck at 6 instead of bumping it up to 8.

i know the mod is active because i just bought the perks and the mcm shows it's there.

I use Robojump squad size and added XComGame.ini

[robojumperSquadSelect.X2DownloadableContentInfo_robojumperSquadSelect]
bDontTouchSquadSize=true

to the ini file like that page said too.

I wonder if I should remove it?
Californiadreaming Mar 25, 2019 @ 10:05am 
Never mind, I found the culprit. "Additional GTS Perks" tweaks the Upgrade II settings in the .ini, making Upgrade II occur at level 6 (Major). So I wound up with two Upgrades at major level. Solution: Go into the "Additional GTS Perks" .ini and set Upgrade II to level 5. I didn't catch that overlap when reading the description, and the issue recurred even after I had deactivated the other mod. "whew".
Californiadreaming Mar 23, 2019 @ 6:53pm 
I just hit a weird problem. I enabled Upgrade I in the GTS at lieutenant rank - no problem, all looked fine. I got someone to Captain, went looking at GTS, suddenly Upgrade II is at Major level and costs 200, Upgrade III is ALSO at Major level and costs 150 (I configured that originally), Upgrade 4 is at Colonel and costs 200. I've used this mod for quite a while on many playthroughs and never saw this before. I can't find any mod that may logically conflict. I've unsubbed and re-subbed, dropped the .config files, all the usual stuff.
duanelocsin Mar 3, 2019 @ 6:43pm 
It looks to be working and a way to get 10 players for those wanting it (including myself)
It was a combination of mods including this one I was testing out and making changes to an .ini file.

I still ended up getting my squad of 9 wiped out in a tough mission (didn't have any more healthy guys at the time) :)

As the loss was to great for me (I only play Iron man now) I restarted the campaign and changed it to 12 players....

so I started 'gatecrasher' with 8 and have increased it to 10 so far with the gts squad upgrades and will eventually purchase gts squad upgrade III and IV to see if it works fine.
b
duanelocsin Mar 3, 2019 @ 6:43pm 
found a way to get a squad of 10 (also trying to see if I can get 12):

***Made the changes and installed all the mods before launching the game and made sure I was NOT in the middle of a mission and restarted with a new campaign***

I used this mod - thanks to BlueRaja
and edited the ini settings '\Documents\My Games\XCOM2 War of the Chosen\XComGame\Config\XComMSSU_Settings -
"StartingSquadSize=6"

The next mod was 'allow for larger squad size' - thanks to Vortex
https://steamcommunity.com/sharedfiles/filedetails/?id=1166873208
as it allows for tiles larger than 3 x 3 for squad units to start out on the map(it does not actually increase squad size)

also installed the 'mod config menu' to help make adjustments to the squad selection screen - thanks to Guby.

https://steamcommunity.com/sharedfiles/filedetails/?id=667104300


MaS Feb 15, 2019 @ 12:07pm 
@Anavel (and anybody else for that matter) I noticed that one way of "getting mods" to work properly is to launch the game through steam, and than to click that little "refresh" button, the revolving arrows up in the right corner. When that's finished, start the game via the Community Mod Launcher and it might fix your issue. Did help me several times already.
Dragon32 Feb 9, 2019 @ 1:55am 
@Anavel Gato:
I've never tried adding this mid-campaign, if you're doing that you could have a problem.
Anavel Gato Feb 8, 2019 @ 4:40am 
After my 1st time to build GTS, there is no SquadSize III and SquadSize IV available. When will it appear ? How can I know that the mod is working ?
Anavel Gato Feb 8, 2019 @ 12:37am 
@Dragon32 Seem like I am able to launch the game via Community Mod Launcher. But do I need to reset the campaign ? The save game won't show SquadSize III and SquadSize IV from the Battle Tactic upgrade. And the Community Mod also warn about this mod can cause crash.

Please let me know if I have to reset my campaign or not.
Dragon32 Feb 7, 2019 @ 9:30am 
@Anavel Gato:
Yes, it does work.

Some great Mod Troubleshooting advice.
That recommends the excellent Community Mod Launcher [github.com], which everyone who uses mods should be using.
This guide gives some more detailed advice on using the Community Mod Launcher: Troubleshooting: Mods not working properly / at all
If you've just switched from the Firaxis Launcher, or are forced to use it, read the "Mods not activating/deactivating properly in WOTC" section of Mod not working? Mods still have their effects after you disable them?