Sid Meier's Civilization V

Sid Meier's Civilization V

Civilizations of Warcraft - Orcs of Durotar
< >
Venom Snake May 14, 2017 @ 10:25am 
none of theese warcraft mods work when I pick a leader none of the warcraft leaders appear.Do I need any expansions for the to work?The game lets me enable them anyway
Genos4 Jan 13, 2017 @ 8:59pm 
A fun mod, though I think the Kor'kron should require iron to build for it to be such a boost in power.
MobileEchoR Jul 18, 2016 @ 10:40am 
@Musomino I think it's because Garrosh Hellscream, is a war leader :P
Musomino Jun 17, 2016 @ 4:17pm 
why garrosh and not thrall
Cpt.Shadow54 Mar 5, 2016 @ 1:04pm 
could u make this for vanillia?
GIRNT@RO Feb 17, 2016 @ 2:36am 
i have a bug, german civ using this civ map symbol ,really weird
Arthas Feb 4, 2016 @ 3:43am 
how can i turn it on?
пажылой Nov 14, 2015 @ 8:08am 
Почему не качается?Тролли и таурены скачались сразу,а этот не хочет
Father Oct 10, 2015 @ 6:11pm 
WoW nice... see what I did there?
Burgie Aug 8, 2015 @ 3:55am 
please new mod... Same mod... But not this -insert curse name- NOT GAROSH! make it gamon !
ASTEROID May 3, 2015 @ 11:45am 
hurr durr. this mod requires gods and kings (wonder why this doesn't have a G&K tag.)
ASTEROID May 3, 2015 @ 11:42am 
I have the mod installed, activated it, clicked "single player" but this civ dosen't show up in the selection. no other mods active, mod manager doesn't tell me there's anything wrong. no BNW or G&K.
Ferdinand Porsche Aug 24, 2014 @ 12:40pm 
so, u dont need any mods to run this?
BadDoctor Aug 6, 2014 @ 8:06pm 
Bam Snow: Thanks for the response. I dunno what you've got in store for the Earthen Ring but a) knowing that your GH decision makes much more sense and b) it's sort of a brilliant idea.

Can't wait to see what you've got in store for the community!
Dan Dapper Raptor Apr 30, 2014 @ 1:49am 
I think there is a bug in this one that replaces Germany's symbol on their city title bar with the mark of the Horde. You may want to check that out.
smitty werbenjagermanjensen Mar 8, 2014 @ 4:14pm 
from the lore perspective, Garrosh never got Grom's axe (Gorehowl) until Thrall appointed him as Warchief.
Sovereign Jan 19, 2014 @ 11:25am 
yay... another swordsman based unique unit...
CallumR Jan 3, 2014 @ 6:07am 
XENOPATH Dec 15, 2013 @ 7:47pm 
I can't wait for the undead and gurubash trolls and the other civs of warcraft. Good mod 10/10.
An Abstaining Bleakpie Sep 22, 2013 @ 3:04am 
I have the mod checked but can't access the civilisation. What should I do?
Bamington  [author] Aug 31, 2013 @ 9:53pm 
Just to clarify for both of you, only the Korkron have new unit graphics. Are you not getting those?
greenphil12 Aug 31, 2013 @ 6:26pm 
Can anyone help me out? In game, my units are still using the regular Civ 5 model, instead of the orc ones. I don't have any other mods and I have already cleared my cache.
Happy Azlan Aug 31, 2013 @ 10:03am 
i loaded all mods u made too btw.
the whole rework mods.
then i tried the names, cities etc one by one, not the packaged mod.
either way still the same. damn... why ? man why...
Happy Azlan Aug 31, 2013 @ 10:02am 
i run windmill and lighthouse improvement mod
also an honor finisher mod tat changes the final policy for the honor tree.
tts abt it.
im running gods and kings. saving up for the expansion when i get my pay end of sept. hehe\

so wats the problem... why are my units still plain vanilla units?
orcs, tauren anything.... its juz plain vanilla skins.

i even tried uninstalling then installing whilst i was in game, and tried doing it preloading civ 5. either way still the same. sigh... i want my orcs...
Bamington  [author] Aug 26, 2013 @ 4:22pm 
Happy Sam: Not a problem I've seen before. What other mods are you running? What version of Civ 5?

Salty: When I refer to 'Orcish Units', I mean units controlled by the Orc Civ. Not just the Korkron :)
Happy Azlan Aug 26, 2013 @ 8:26am 
and yes i have deleted the cache....
Happy Azlan Aug 26, 2013 @ 8:25am 
anyone care to help???
mod works in a way that the skin doesnt change the models!
my units are still civ 5 skins! why isnt it orc?
RichQueso Aug 24, 2013 @ 9:17pm 
Do "Orcish units" count for all the the Horde's units (units found in the normal Civ) or just specific units? :Diplomat:
Bamington  [author] Aug 20, 2013 @ 2:56pm 
Kennethsw: The only feedback you'll get is when you go to attack a unit in the little window that shows the outcome probabilities, you should see a buff for 'Nearby Improvement', similar to what you get for a fort. Let me know if you're definately not seeing that.
kennethsw Aug 20, 2013 @ 9:17am 
Can anyone confirm if the Watchtower is working as it is supposed to ? I dont get any feedback when I palce units in and around it and cannot tell if it is working or not.
Bamington  [author] Aug 19, 2013 @ 3:01pm 
Junkerd: First thing to do always is delete your cache file. Go to My Documents/My Games/Sid Meier's Civilization 5/Cache and delete Civ5ModsDatabase.

If that doesn't solve it, try unsubbing OUTSIDE the game and resubbing INSIDE the game.
Junkerd Aug 19, 2013 @ 7:23am 
Hey, I was having the same problems at Vault Dweller, so i tried to unsubscribe from this mod, and resubscribe, but now the mod won't show up in the enable mod selecting screen?
I have tried unsubscribing and subscribing to the mod multiple times, but it never shows up in the mod selecting screen?
Dwellrar Aug 17, 2013 @ 1:52am 
I think i fixed it somehow now, so there was mostly something local nothing with the mod itself.
Bamington  [author] Aug 16, 2013 @ 5:20pm 
Vault Dweller: Make sure you're using the latest version of all the mods. That's not an issue I've seen before.

SkullKnight919: It is possible, but exceptionally difficult. It wont be something you'll see any time soon.
Yolo Swaggins Aug 16, 2013 @ 3:49pm 
if it is possible to add models i think you should use the warcraft 3 models, only if it is possible still the best mod for civ 5

thanks! :D
Dwellrar Aug 16, 2013 @ 7:59am 
I got GaK BNW all DLC and all of your wow mods.
Bamington  [author] Aug 16, 2013 @ 6:05am 
Vault Dweller: Hey mate, could you let me know what expansions and DLC you have?
Dwellrar Aug 16, 2013 @ 5:52am 
I'm having some problems in the civ select screen with orcs. all the other civs are fine, but when i add orcs all the other civs under orcs are gone. great modpack tough, keep up the great work!
Bamington  [author] Aug 14, 2013 @ 3:08pm 
Chancesheffield: Thanks for reporting this, I'll look into it.
Chanceroonie Aug 14, 2013 @ 1:00pm 
Fantastic Mods! When I saw the custom skins for the Kor'Kron, I couldn't believe how good they looked! Speeking of the Kor'Kron unit, I've noticed that I'm unable to upgrade them to a Longswordsman. Is this an issue on my end, or is that by design? Thanks for a great set of mods!
Bamington  [author] Aug 13, 2013 @ 2:21pm 
Carlou: Thanks for the kind words! I'm glad you're enjoying the mod. We should have a map out soon, it's in the works!
CaptainBreizh Aug 13, 2013 @ 10:57am 
The custom unit graphics are excellent, mate! It seems that the Warcraft mods are taking a lot of your time and work... Everybody on Civ V community seems waiting for each of your mods! I played Wow and hope that it will be gorgeous.. A scenario with a map of Azeroth might be really fun to play.
Your creating a masterpiece, maybe one of the best Civ V mod in this workshop. Can't wait for it!
Bamington  [author] Aug 11, 2013 @ 7:46pm 
If you google 'Civ V mods on Mac' you will find a very useful thread on the CivFanatics forum about getting around this issue ;)
Bajgiel Aug 11, 2013 @ 7:43pm 
nevermind, I found out the problem... Im using a Mac
Bajgiel Aug 11, 2013 @ 7:36pm 
if it helps, I have gods and kings, but not brave new world
Bajgiel Aug 11, 2013 @ 7:33pm 
absolutely nothing is showing up, in the list or in the game
Bamington  [author] Aug 11, 2013 @ 3:27pm 
nicnac: Are the mods not showing up in the list, or are the civs not showing up after you've enabled the mods?
Bajgiel Aug 11, 2013 @ 6:06am 
Bamington: I just subscribed and it's not showing up in either one.
Bamington  [author] Aug 9, 2013 @ 3:24pm 
Phila2pitt: Would you be able to send me screenshots of the defeat screen, info screen, and the 'View Replay' log (Just the end where the game finishes)?
phila2pitt Aug 9, 2013 @ 10:41am 
Never mind about what I said about how "the Warcraft civ that ends with the culture victory wins with 11 culture." I realized the 11 isn't for culture. The screen I'm getting this from is the 'You are defeated' screen, under 'Replay', then 'Messages'. The winning civ has 11 to the left of its name, while all the other civs, including the one I'm playing, have 0.

Also, I count the turns before losing now, it is 11 turnes every time, not under 10 like I thought.