Don't Starve Together

Don't Starve Together

93 ratings
Shard Configuration Mod
   
Award
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
0.010 MB
Jan 8, 2016 @ 1:27am
Jul 29, 2017 @ 12:10pm
72 Change Notes ( view )

Subscribe to download
Shard Configuration Mod

Description
WARNING:
This mod is made for dedicated servers and has no use in standart Don't Starve Together worlds created in client. This mod is also not needed if your dedicated servers run only two worlds/shards in one cluster (default connections works fine for 2 worlds/shards). If you are server admin and you want more than 2 connected worlds this is mod for you!

Forum topic and preconfigured cluster is available on DTS Forums[forums.kleientertainment.com]

New feature: unidirectional connection between shards using new . See forum post for mod override example.
New feature: automatic synchronization of connection data from master shard.

This mod uses standart 10 sinkholes generated in the world. If you manually create more, they will be used after server restart. If you want more than 10 connections from/to one world you have to create new sinkholes/stairs. Sinkholes not used are turned off and plugged.

!!! MOD DOESN'T WORK IF YOU DON'T CHANGE MOD SETTINGS !!!

On DST forums is available my util that makes configuring this mod VERY easy. It also can configure world gen overrides. It uses .NET 4.5 and won't start without it!
Popular Discussions View All (8)
15
Jul 29, 2017 @ 9:27pm
Error log.
Чаpли
5
Nov 6, 2017 @ 11:23am
Adding another world to existing cluster with this mod?
myxal
4
Jul 21, 2017 @ 9:36pm
MODS causes the server to crash, the following is the log
冷哥哥树宝宝
< >
132 Comments
TheVoid Apr 4 @ 6:08pm 
Thanks for this gem of a mod. I wouldn't have probably realised I could build my multiverse without it. Took me a while to configure everything properly, but that's part of the fun.
WhiskerMeFancy Jan 30 @ 6:17pm 
@dead baasura post the exact error message
WhiskerMeFancy Jan 30 @ 6:16pm 
@alex Use the link above to go to the forums and download the utility that creates the modoverrides.lua for you.
󰀒 Dead󰀀Bakasura 󰀒 Jan 8 @ 11:13pm 
My 3 shard does not start. In the console, it says that the mod was stopped ((
I can’t understand what I'm doing wrong ...
AlexXsWx Aug 17, 2019 @ 6:59am 
Hey, could you please explain in more details the numbers you put in configuration_options?
I've got 4 worlds - two sets of upper + caves; I want first upper to have 1 portal to bidirectionally lead to 2nd cave, and have that as only connection between the two sets.
Your example confuses me and I don't understand which numbers I need.
E.g. you write:

["Connections"] = { ["11"] = { "12" } -- bidirectional between 11-12

Does that mean setting up bidirectional connection between world-1-portal-11 and world-1-portal-12 or between world-1-portal-1 and world-1-portal-2? If latter, I assume configuring world-1-portal-10 would be number 110?
Чаpли Jul 21, 2019 @ 7:44am 
@Rudobni You don't need to use mod features for it... You can use ingame command c_migrateto([number of world]) like c_migrateto(3) for player.... If you want to migrate player 3 to world 5 you just need to do: c_select(AllPlayers[3]) and then c_migrateto(5) or do it one line...
Rudobni Jul 10, 2019 @ 1:10am 
Hello, is there a command to teleport a player to another shard ingame ?
Thank you for good mod, work perfectly.
Oarc Sep 27, 2018 @ 11:35am 
I'm having a couple of issues with this mod. If I play with the mod enabled, portals sometimes get deleted infront of my eyes or they don't go to a matching portal. And if I start a fresh server, have a character join to force the link syncing, then disable the mod and restart the server, it works fine up until I restart the server which then loses the links again.

I'm not sure where to post this but if anyone else is seeing similar issues with this mod, or knows things I can try I'd love to hear suggestions.

I am running 6 shards, only using 2-way connections and I used the config utility by the mod author. No shard has more than 10 links in my setup.

The only way I can get this to work is to launch with the mod enabled, generate the links, then restart with the mod disabled and never restart the server again so I don't lose the links...
Чаpли Jul 15, 2018 @ 3:06am 
@Patrolcus, 1) Do you have 1, 12, 13 ID's on your real server? 2) Try to put one more "," after ["12"] = { "13" } 3) Do you have is_master = true on your main server? 4) Did you add that mod on dedicated_server_mods_setup?
Nuke  [author] Jul 14, 2018 @ 1:11am 
If you are using this mod and Multi-Worlds DST at the same time that could be your problem. Multi-Worlds DST have more or less a copy of my code so if it's configured differently it may clash with my mod.