Europa Universalis IV

Europa Universalis IV

Not enough ratings
Fun and Balance
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
0.190 MB
May 17, 2015 @ 8:01pm
Jun 24 @ 12:05am
20 Change Notes ( view )

Subscribe to download
Fun and Balance

Subscribed
Unsubscribe
< >
47 Comments
taw  [author] 17 hours ago 
Lindorn: Updated now. So the mod has higher relationship limit, and 1.22.1 hotfix reduces AI penalties (which mod doesn't change) - hopefully the hotfix levels are reasonable enough.
taw  [author] Jun 23 @ 6:15pm 
Lindorn: Fun and Balance always increased relation limit, so it's much less affected.
Lindorn Jun 23 @ 5:11pm 
Hey Taw- when you get around to updating would you mind taking a look at the "too many relations" issue with AI now (-50 for allying the player) honestly playing little guys/OPMs was already hard enough - it's impossible with this change. Hopefully paradox fixes.
Lindorn Apr 25 @ 7:47pm 
Patches are usually sad days for me now because I can't play this game anymore without fun and balance :)
taw  [author] Apr 8 @ 2:01pm 
1.20 version with emergency Ming nerf released. Nerf just reduces mandate from tributary dev and increases penalty from neighbour nontributary dev. Ming is still OP as hell, and some proper balancing is needed in the futere, it will just pass reforms a bit more slowly without some effort.
taw  [author] Apr 7 @ 5:48pm 
Lindorn: I'm not even surprised.
Lindorn Apr 7 @ 5:33pm 
Hey Taw - to follow up on the claim throne CB thing from earlier - turned out it was a bug in the core game. Sorry about that!
taw  [author] Feb 1 @ 11:05am 
Nutluck: Could you screenshot the whole thing? I'm not seeing this warning, and it shouldn't be there.
Nutluck Feb 1 @ 8:16am 
When in the launcher, when you click the mod tab. It lists this mod but has a red symbol and if you click the check to use the mod it gives a warning the mod is not compitable. I launched the game and it didn't crash, but I thought you should know about the warning the game is giving for the mod.
taw  [author] Jan 31 @ 6:45pm 
Nutluck: It should work perfectly fine with any 1.19.x, nothing relevant changed in 1.19.2, it was just a small bugfix patch not affecting any of mod files.

It's also tagged in .mod to work with all 1.19. I'm not sure why you see it as incompatible, I don't see any warning locally, and if you see it, just run it anyway, or download and unpack that 7z file if Steam Workshop version doesn't work for any reason.