Arma 3
281 ratings
Improved Grenades
   
Award
Favorite
Favorited
Unfavorite
Data Type: Mod
Mod Type: Mechanics, Weapon
File Size
Posted
Updated
0.138 MB
Mar 24, 2015 @ 3:00pm
Sep 14 @ 1:07pm
12 Change Notes ( view )

Subscribe to download
Improved Grenades

Description
Improved Grenades. Increased damage/effective range for all hand and underslung grenades.
Be careful with them! RGOs can now kill.

Arma grenades have always been something of a joke. When a grenade goes off next to an enemy, they often flinch and continue shooting you. After watching Dslyecxi drop a grenade _on_ a prone enemy, and the guy lived, I knew I finally had to correct this rediculousness. I have tried to set damages to realistic values based on military references.
< >
51 Comments
Drahkken  [author] Nov 26 @ 3:51pm 
It works fine with ACE. Just doesn't change the ACE grenades.
Jelonek_NET Nov 24 @ 2:56pm 
Does it work with ACE?
Sorry for repeating this question, but I haven't seen any answer to it.
rhidenor Nov 10 @ 1:23am 
It may be caused by double images in the mods root folder and in the images folder with same name.
rhidenor Nov 10 @ 12:03am 
Warning Message: Picture \images\rgo_logo.paa not found
Any ideas?
Gunter Severloh Nov 9 @ 12:18pm 
Run it client side and join your server with it what i do and i have no issues.
Nordost Nov 9 @ 10:46am 
Hello, this mod not working on my server:
Signed on server and client not equal
All others mods (like ace, cba, works fine)
Drahkken  [author] Oct 31 @ 6:27am 
Thanks for verifying @Gunter. Good hunting!
Gunter Severloh Oct 30 @ 9:40pm 
Ya i cant reproduce it on its own in sp or mp with respawn,
so its good, issue probably comes up with
another mod that might change inventory, or weapons and ammo.
Gunter Severloh Oct 30 @ 9:20pm 
I'll test it out, it might be in combination with another mod im thinking that
causing the issue.
Drahkken  [author] Oct 30 @ 8:59pm 
I can't imagine this is directly related to my mod since I'm not doing anything to inventory. Just adjustments to the built-in grenades lethality values. Did anybody encounter this when only my mod was running and no other?