Fallout 4

Fallout 4

View Stats:
Fallout 4 > General Discussions > Topic Details
zcess81 Nov 18, 2015 @ 7:43am
R6025 - pure virtual function call "Error"
Been playing the game since the release without any issues and today I've started getting 'R6025 - pure virtual function call "Error"' every time I quit the game. Luckily this error only occurs once I quit the game and not during the game play, but still very annoying.

Anyone else been experiencing this issue? Anyone has any idea what's causing it and how to fix this error? Thanks.
< >
Showing 1-15 of 24 comments
commanderbass Nov 20, 2015 @ 3:37pm 
Same issue, no idea why.
kaffekoppen Nov 20, 2015 @ 3:38pm 
Yeah I get that too (also only when quitting the game).
dp Nov 24, 2015 @ 5:27pm 
I'm seeing this, too. Every time I quit.

Commander Kai Nov 28, 2015 @ 7:32am 
This just started for me as well.
pjcrusader Nov 28, 2015 @ 8:53am 
This started for me as well. So far I have tried uninstalling and reinstalling the game, running the vcredist in the fallout 4 folder, and completely reinstalling Windows.
DaiKhairai Nov 28, 2015 @ 1:45pm 
static snow screen effect
lagged startup main menu

ive been getting this too but i noticed it only happens, like all of you after i quit, but i quit because of the HUD static becoming so strong that i cant even see.
if you've been building your bases long enough you've probably had this issue, you know its the one where your HUD tv screen snow effect get so strong you cant even see what your trying to build?
for me however i have this issue while in combat as well so i quit because the snowy static effect gets too strong, i get this error start up the game again and its gone.

(run-time error! Program: C:\program... R6025 - pure virtual function call)

i think its related to that and its simply some visual function that supports other stuff, fails every so often but fortunately inst so important that the game would fail completely without it.

I've also noticed right before i have this little error, when i first start up my game my main menu is wretchedly slow and laggy.
Motta the Hutt Nov 28, 2015 @ 10:33pm 
I've also been getting this error whenever I quit, as of today.

On top of that, I'm getting reduced framerate while playing the game...
DiRiN Dec 2, 2015 @ 10:53pm 
I've been getting this error as of the last week as well. Upsetting me. I actually uninstalled and reinstalled all VCC and the game thinking this would fix it. NOPE. Bugthesda needs to fix this. It was probably a patch they did that caused the issues. :wftogrin::biohazard:
Last edited by DiRiN; Dec 2, 2015 @ 10:53pm
Hei$enb3rg Dec 20, 2015 @ 8:34pm 
I started receiving this after updating today, it has been a few days sense I played but it did not happen before the update. I also noticed that this game is only using half of my hardware. I cannot keep 60 fps on my GTX 960 4GB, it shows like 35% to 60% usage. It never goes above that now and my CPU is only showing around 50% to 60%. I have not changed any of my settings. I have checked the .ini file to make sure vsync is disabled and none of my nvidia control panel options have changed. I have been working on fixing all day. Super annoying now that I have to deal with a crash pop-up when exiting the game. I have always given Bethesda the benefit of the doubt due to them having a smaller team then most other bigger developers and their games having that feeling of complete freedom that makes you seem like anything is possible but I'm so sick and tired of buying their games in "Pieces" due to always having to wait on a patch for my system to run it. Feels like Skyrim all over again. Sorry for the text block.
crossmr Dec 26, 2015 @ 1:57am 
I've noticed something similar to heisenberg. I'm getting bad performance in areas I never got it before and getting this error on quit. Got almost 200 hours into this game so I know what it should behave like
Bunks Dec 26, 2015 @ 2:05am 
once you start getting this, it will only get worse over time. game performance will drop more and more over time.

Unplugg all devices, usb, mice ect. unistall the game and all the files that the game made(ie games folder/fallout 4). save your saved games.
restart with the basic mouse setup plugged in and resintall the game with everything else unplugged. after a quick start of the game and make setting changes you need to make, go back to desktop and make your ini files read only. Then plug everything back in. and reboot.

no gaurantees but this was the only thing that worked for me. i started getting the runtime crap about 20 hours into game, by 40 it was every damn time, by 60 hours the game was almost unplayable, by the 100 hour i had to unistall it all and start over.

dont let any con you into the 'you need a windows update bs" these are all red herrings and will fix nothing. The game is constantly trying to change settings and for some reason it is especially when you open up the workshop in game.

The way it was explained to me as simply as i could grasp, this was lazy programing code when it came to deleting items from memory and then wanting to recall that item again, he then pointed to the workshop in game as the ultimate culprit saying it was an addon that was thrown together in a last minute sloppy way.
Last edited by Bunks; Dec 26, 2015 @ 4:11am
Apshai Dec 27, 2015 @ 7:11pm 
*POSSIBLE SOLUTION MAYBE*

Hey fellow dorks,

Started getting this error on quit, was so far able to smash it by going to right click FO4 in steam -> properties -> browse local files -> _CommonRedist -> vcredist -> vc_redist64.exe and repairing the install. Also temp disabled antivirus for said install. Worked like a charm! I think.
The Hunter Jan 3, 2016 @ 7:33pm 
Originally posted by Apshai:
*POSSIBLE SOLUTION MAYBE*

Hey fellow dorks,

Started getting this error on quit, was so far able to smash it by going to right click FO4 in steam -> properties -> browse local files -> _CommonRedist -> vcredist -> vc_redist64.exe and repairing the install. Also temp disabled antivirus for said install. Worked like a charm! I think.
Thanks, worked for me!
Neutralize Jan 3, 2016 @ 7:37pm 
Seems to come back after a while if I let my saves pile up (maybe 100 or more). I'm curious if it's because of autosaves from leveling, or quicksaves, or what. You can also notice some seriously annoying mouse lag when you go to the save or load menu at times - usually you can expect the runtime error at exit to desktop, or at least it seems more common if you are getting this menu lag, too.
Last edited by Neutralize; Jan 3, 2016 @ 7:38pm
Ana Jan 7, 2016 @ 3:39pm 
what does this "-> properties -> browse local files -> _CommonRedist -> vcredist -> vc_redist64.exe and repairing the install"

does ? will this overwrite game data ? what about mods ? will you lose anything ?

i have this issue everytime exing to the desktop but only! if i have my pipboy on. when i exit the game with a weapon in hand or nothing then i quit normal

is this only my game or does someone noticed similar things ?
< >
Showing 1-15 of 24 comments
Per page: 15 30 50

Fallout 4 > General Discussions > Topic Details
Date Posted: Nov 18, 2015 @ 7:43am
Posts: 24