View Stats:
Ø May 12, 2022 @ 9:21pm
<Fixed!> Fullscreen issue on Pop OS
Hi guys! I recently started using Linux and saw that Crosscode had native Linux support, which was pretty exciting, but...!

I have run into this strange issue. When the game boots up for the first time it's as a window, which I can move around just fine on its' own anywhere. However, if I try to fullscreen the game it only seems to show the bottom-leftish corner of the game on the top-left of my monitor.

I've tinkered around with this. I made sure to update all my drivers, tried to run the game by using --disable-gpu (performance worsens AND does not fix the fullscreen issue), went over to the forums to look for fixed and tried out a number of things - gamescope, updating the node file, -no-border...

The game seems to run perfectly fine in Windowed mode - controller works fine, wandering around works fine, fighting works fine, and the framerate is crisp. I don't mind playing it like this if I have to, per se, but I would strongly prefer to be able to run it in fullscreen mode. Anyone got any ideas about what I could do about this? Legit have no clue what to try at this point.

(for the record, I've tried to run the game using Proton Experimental and 7. Interestingly fullscreening the game works just fine, but the game's performance significantly degrades, which is ?????? )

Edit: Updating the nw.js was one thing I tried, but defnitely not DOWNGRADING! Someone on the CrossCode discord discovered that downgrading the ns.js file down aaaall the way to v0.50.3 fixes the problem - and it does! You can get it out of the archive of their releases in the download page if anyone else needs to do something similar:
Last edited by Ø; May 15, 2022 @ 7:51am
< >
Showing 1-12 of 12 comments
Ø May 12, 2022 @ 9:35pm 
I just went back to try Proton Experimental again - performance appears to just be freaking perfect now and the issues isn't present when running it that way, so, cool! Not sure why it suddenly decided to cooperate, but at least that works now. Still not sure what to do about fullscreening when running the game natively on Linux, but it's not terribly pressing anymore thankfully.

Still would be curious to see if anyone has any suggestions about what to do about it.
Bilbo Fraggins Jun 8, 2022 @ 9:22am 
I am running into this same issue on Arch as well. Quite frustrating as I usually prefer to run native versions of games :(

Out of curiosity, are you using an ultrawide monitor?
Last edited by Bilbo Fraggins; Jun 8, 2022 @ 9:44am
Ø Jun 8, 2022 @ 2:23pm 
Nope! Just the good ol' 1920x1080p friendo!
Heroneet Jun 11, 2022 @ 10:54am 
I continue with the same problem, also, the proton/wine version have other bug related to plasma bar, so, yeah, I can't play this game for now until the devs solve this issue :/
Last edited by Heroneet; Jun 11, 2022 @ 10:55am
Bilbo Fraggins Jun 11, 2022 @ 11:35am 
Originally posted by Ø:
Nope! Just the good ol' 1920x1080p friendo!
How did you downgrade nw.js btw? Which files did you overwrite?
Ø Jun 11, 2022 @ 5:17pm 
The devs in the Discord helped me out. Here's the message I got from them copy-pasted for what ended up working for me:


Xaekai — 2022/05/15
take this file

and extract/overwrite it into your SteamLibrary/steamapps/common/CrossCode folder, and rename nw over CrossCode and things should work correctly


...and that's all it took!
josekiller Jul 7, 2023 @ 6:14pm 
my workaround is running steam and the game with intel integrated graphics instead of running with nvidia proprietary drivers
laptop with ubuntu 22.04 here
Last edited by josekiller; Jul 8, 2023 @ 10:53am
I'm also using popOS and have the same issue.
Can confirm use the compatibility proton i use 8.0-2 and now i have full screen.
Last edited by vanishedchief2021; Jul 8, 2023 @ 1:40am
Bilbo Fraggins Jul 8, 2023 @ 6:01am 
Easier way is to use the native version and then pass "--use-angle=vulkan" as the launch option. You get better performance compared to Proton, especially on the Steam Deck and it fixes the weird fullscreen issue on Nvidia.
Last edited by Bilbo Fraggins; Jul 8, 2023 @ 6:02am
Originally posted by Bilbo Fraggins:
Easier way is to use the native version and then pass "--use-angle=vulkan" as the launch option. You get better performance compared to Proton, especially on the Steam Deck and it fixes the weird fullscreen issue on Nvidia.
Thank you! Solved the problem for me!
You're welcome! I am honestly surprised they haven't patched this yet considering it's been years since this started happening.
< >
Showing 1-12 of 12 comments
Per page: 1530 50