Giana Sisters: Twisted Dreams

Giana Sisters: Twisted Dreams

View Stats:
Game won't start - X3DAudio1_7.dll is missing??
I get the game launcher, and can alter the game settings, but when I click "PLAY" I get the following error message:

GSGameExe.exe - System Error
The program can't start because X3DAudio1_7.dll is missing from your computer.

Pretty annoying!

Windows 8 x64
< >
Showing 1-15 of 34 comments
DariusOne Oct 26, 2012 @ 10:22am

Go download and install it, that should help. I personally always use the zip file, but the fixer should work too.
Last edited by DariusOne; Oct 26, 2012 @ 10:25am
dEagle Oct 29, 2012 @ 6:18am 
hi. did anyone solve the problem?? have the same here win8 - x64.
i tried to register the dll - then it says it s not compatible to win8.. i guess this dll is for win7 only ! so there is an x3daudio 8 dll in system32 folder..

Winterpast Oct 29, 2012 @ 8:20am 
Last edited by Winterpast; Oct 29, 2012 @ 8:20am
zulunation42 Oct 29, 2012 @ 9:40am 
Same game, same OS (Win8 x64) and same DLL-error. Has anyone solved it yet?
ThunderPeel2001 Oct 30, 2012 @ 10:44am 
@ZuluNation42 Yep, that worked for me! Thanks!
NYANZUNXO Jun 26, 2014 @ 7:20am 
But anyone do with download x3?
jonasclaesbe Jul 14, 2014 @ 1:33am download and install should work then
Tsunamii Feb 10, 2015 @ 11:48am 
where should i put the file? please help me
King Nerevar Feb 11, 2015 @ 9:05am 
in the direction given in the error report. If this does not help, write me a massage, I had a similar problem with Skyrim, and it was quite difficult to solve.
col.popcorn Mar 7, 2015 @ 10:51am 
The Microsoft download gives me an error log saying that everything is "already installed." And there is no "x3daudio1_7.dll" even listed in the error log of already installed files. There are x3audio1 files, just not "_7" ones.

I hate it when when video games give so much grief just to run.
King Nerevar Mar 7, 2015 @ 11:44am 
I had it on Skyrim, so....
Download all the x3daudio1 files manually and c&p it in: C:\Windows\System32
Last edited by King Nerevar; Mar 7, 2015 @ 11:44am
col.popcorn Mar 7, 2015 @ 2:57pm 
thx King Nerevar! That's what worked for me: used the dll link listed by DariusRaider above: Searched for x3daudio1_7.dll. Then used the Manual option, downloaded, unzipped, the copied the .dll file to my Windows\System32 (and for good measure put it in the \Windows directory too). Restarted. Finally the program booted.
Last edited by col.popcorn; Mar 7, 2015 @ 3:08pm
King Nerevar Mar 8, 2015 @ 12:46am 
no problem. Nice to hear that it is now working
kuZe|Shadixayn Mar 9, 2015 @ 8:29am 
< >
Showing 1-15 of 34 comments
Per page: 15 30 50