Arma 3
HCC - High Command Converter 1.5.1.1
< >
82 Comments
Molyneaux41 Oct 3 @ 1:26pm 
spot on buddy XD
Blakmane Oct 2 @ 3:42pm 
Great to hear, thanks Igitur!
Igitur  [author] Oct 1 @ 10:02am 
Hotfix 1.5.1.1 released. No new feature but the mod should work again as intended.
AchillesFromGreece Sep 30 @ 11:37am 
Hey man how long till it's fixed?
Igitur  [author] Sep 20 @ 10:50am 
Sorry guys I didn't check the mod for months. It looks like it got broken with the latest game update. I'm on vacation atm but i'll take a look when i'm back home. It might take a few weeks. Thank you for your patience.
mysales89 Sep 18 @ 4:09pm 
Hello. I have the same problem described by Molyneaux41 on 9 Sep. The menu is unresponsive. Is there any solutions available? This mod will enhance the game for me tremendously if I can get it to work.
Blakmane Sep 13 @ 3:18pm 
Mod functionality appears to be broken after the latest patch (LoW update). Any chance of an update? The 'move to high command' function is super useful and we've struggled to find similar functionality in a different mod.
Reaper Sep 9 @ 8:25am 
Have been trying to get this mod to work, is there a wiki for setting it up in a mission?
Molyneaux41 Sep 9 @ 3:43am 
Same for me. The menu is unresponsive. Only happened a couple of days ago
The_RealStarlord Sep 8 @ 2:56pm 
Does not work for me. The menu is there but does nothing.
DryBones Jul 12 @ 8:11pm 
Is this mod still working? or is out of date?
brake_stand Jul 7 @ 8:15pm 
Thank you for the reply Igitur, but you know what! I found the exact problem was that I needed to actually bind the "Open Menu" keys to somthing to have them open! lol! Apparently my "Open Menu" keys weren't actually bound to anything! Doh. Anyway this mod has totally changed the way I play the game now. Thank you again!
Igitur  [author] Jul 3 @ 12:06pm 
@brake_stand : a few users have been reporting the same issue over the last two years but I've never been able to replicate. I can only recommend to use the default keybinds for the menus and suggest to hit backspace when in High Command to display the general HC menu. You can then try to access the specific menus for your selected HC groups from there. And yes last time I checked (2 months ago) it worked totally fine with DUWS.
@Yuqi : LCtrl is not needed. Just click MMB on a WP to start/end the drawing.
@Iparkerzo : Vacant Groups are only available when other playable groups are found in the mission. I think I'll add a more general 'Add All Groups of Side' options for SP in the next update.
brake_stand Jul 2 @ 8:57pm 
This mod seems like exactly what I've been looking for. But I am also having the same problem as AlchemicalWizard in that pressing the "menu" keys with an HC squad selected does nothing but de-select the squad.. I am trying it with DUWS Enhanced but another user said he was using it in DUWS just fine?
yuqi_19821982 Jun 26 @ 10:27am 
O, sorry, its my fail, i draw line by CTRL+LMB..., the right operation is CTRL + MOUSE MIDDLE BUTTON
yuqi_19821982 Jun 26 @ 9:57am 
It looks like the SYNC-WP can not be set by line drawing. When i try to starting drawing line, the wp will follew my mouse, is this normally?
AlchemicalWizard Jun 26 @ 4:47am 
I've installed the mod, and i can tell it's installed from the extra options in HC such as the regroup and watch commands, but the menu's won't pop up after pressing any number keys on my keyboard.
lparkerzo Apr 12 @ 11:08am 
How do you add vacant groups, i have multiple groups that are not commandable, however, the option is greyed out.
dusty Apr 12 @ 4:15am 
Your mod is impressive both in quality and amount of content provided! Kudos to you dev!
Igitur  [author] Apr 10 @ 8:58am 
Good catch ! I'll work on that asap.
PedoBaerJoe Apr 10 @ 5:53am 
Is it possible to order multible artillery pieces at once? Let's say I have a hc-unit of 3 Scorchers. If I order it to fire only 1 of them is actually firing. I get the same result when ordering 3 units of single Scorchers. Everything else seems rock solid btw :D
Igitur  [author] Apr 10 @ 2:49am 
@fmrnr : Hi! Sorry, no. Most of the HC menus are created at config level. Maybe not the most flexible solution, but trouble-free and rock solid, and I'll stick to that :)

@Chrispy : Thanks for reporting ! Let me know how it goes when you disable every other mod. I'd love this mod to work flawlessly in MP but, as a single player, it's not easy for me to test everything out. Feel free to report here or in my thread on the BIS forum (linked above).

@Lathelus : yes, it's a known issue related to some non-standard configs (RHS, CUP, etc). Units are not available, even though the groups are. I gave up trying to find the rationale behind it but there is a workaround : spawn a group and close the Zeus interface. Open Zeus again and you'll notice that all the units of the group are now available in the units list.
Note that the mod allows every Zeus owner to add (and remove) the Zeus-created groups to his HC bar using 'Add Curator Groups of Side' (6-8).
Lathelus Apr 8 @ 3:09pm 
Hello! I noticed a wierd bug lately. From some time I couldn't spawn RHS USA vehicles in zeus mode. In Eden there was everything fine, only with zeus. During testing (swithing on and off my mods that is) it became clear that this mod is causing the trouble. It's not that it would be annoying or something, High Command is useless in Zeus, but just wanted to point it out to you.
chrispy Apr 8 @ 2:05pm 
I love using this mod, so i had my friends get it. Whenever we play (i host a dedicated server) their framerates are capped at like 20fps. When we all unload this mod, the problem goes away and their frames return to normal. I also have MCC and ACE, so I'll do some more testing and see if it's a conflict.
fmrnr Apr 3 @ 11:42am 
Hi there!

I mapped my "Select Menu" keys (in Options>Controls>Command) to the Numeric pad keys (Numpad 0 to Numpad 9), but the mod is set to use the keyboard number keys to navigate the menus, so I get a mix of numpad and number keys while commanding (see screenshots: {LINK REMOVED}, {LINK REMOVED}

Any chance for HCC to detect personal keybindings and use them instead of the default number keys?

Great mod btw :)
antb15 Mar 28 @ 4:21am 
Awesome! Thanks for the artillery changes :)
Igitur  [author] Mar 28 @ 1:42am 
V.1.5.1 is out. Please read the change notes.

Fixed the sync system, improved artillery and suppression functions, Groups IDs are now tracked and can be changed (0-9 : Rename Group).
Igitur  [author] Mar 27 @ 5:21am 
Hello. Sorry no, i dont play that mod so i have no idea. It seems like an interesting HC mission generator though. I'll take a look once i'm done with my own update.
Lathelus Mar 25 @ 7:21am 
hello! I've been using this addon with Dynamic Combat Ops, but after some mission updates, HCC started to break the scenario. HC with HCC won't give any orders to a unit. Do you have any idea why?
Chocolate Thunder Mar 15 @ 10:37pm 
yeah. im using Antistasi so that might have something to do with it
Igitur  [author] Mar 15 @ 2:14pm 
@PedoBaerJoe : the sync system works with the mouse action button. It's broken as of today but i'll release a fix soon. Please read the notes on WPs just above.
@Chocolate Thunder : have you tried hitting backspace to display the general menu ?
Chocolate Thunder Mar 13 @ 8:19pm 
so i selected a hc unit but when i hit something like 5, nothing comes it. it just closes the menu
PedoBaerJoe Mar 13 @ 9:10am 
ah thanks, I figured it out now. Great mod and highly usefull in some scenarios
antb15 Mar 13 @ 1:10am 
I think you need to left click + action button. The sync does work, i've used it for ground transports
PedoBaerJoe Mar 10 @ 8:05am 
leftt-clicking on a waypoint to synchronize doesn't work. It only let's me add or set a new WP.
antb15 Feb 28 @ 6:35pm 
Thanks for getting back to me! CUP compatibility would be amazing. I'm using the Dynamic Combat Ops and Dynamic Recon Ops missions, and together with CUP and your excellent mod, there is a lot of fun and variety to be had for singleplayer. Your mod does so many things that should be part of the base game. Simple stuff like getting the ai to land a heli is an huge improvement over vanilla.
Igitur  [author] Feb 28 @ 3:04pm 
Hi, my artillery functions are designed to work with the vanilla game and RHS so far. I'll see if I can find and add the CUP classnames. The sync system enables you to link an infantry unit with a heli using a "load" WP, but its broken for the time being. Please read the notes on WPs and enhanced WPs for usage.
Well, this mod desperatly needs an update. I'll try to gather some time in the coming weeks :)
antb15 Feb 28 @ 2:55am 
This mod is amazing! So many new options! I have a few questions though;
I'm having trouble with a hc group of two men in the BM21 artillery. They do not bring up the option to fire when going through the menus (as per your video), however, I can get a normal squad level group to fire as usual. I know CUP is not your mod, but is this related to the BM21 or the WCC?
Additionally, is it possible to use the synchonisation with an infantry unit and a heli unit? I've set up a series of waypoints, but I cant get the troops to use the 'getin' command. I've tried having the heli 'getout' and wait, but without the 'getin' command, they can't sync. Not biggie really, thats something that i can manually do. Thanks again for the awesome mod!
PK SPACE JAM Feb 6 @ 8:41am 
Thanks!
Igitur  [author] Feb 3 @ 9:18am 
Hey, you need to hit the number keys to display the HC menus after you've selected an hc group. Transport menu is 5. Try hitting backspace to display the general menu if a specific menu doesn't show up with the number keys.
PK SPACE JAM Feb 2 @ 9:44am 
Hello, I could use some help, would really love this to work so I can play DUWS, I uploaded the mod, and enabled it. After picking 2 members of a squad and then pressing 5, it gave me the option to make an HC group which I did. While selecting that HC I tried to order them to enter a vehicle and no option came up to put the HC into a vehicle, am I doing everything right?
{84e}Mr.SoloDolo Jan 22 @ 2:24pm 
Ok I think it is fixed now. I have done some experimenting and don't know exactly what corrected it but it works as it should now. So to be clear the problem was not due to any fault of the HCC mod, HCC does exactly what it says it does. It had something to do with the screwed up way I had something setup with scripts in the editor. Thanks
Igitur  [author] Jan 16 @ 4:35am 
No, nothing wrong if you've switched back to the regular group command bar. Tested right now and everything's fine except for the waypoints synch system that's broken since BIS changed the action button name (fixed soon). Please try without any other mods.
{84e}Mr.SoloDolo Jan 15 @ 6:51pm 
When I select another group and under menu 1 tell them to join my group they do so, but then they ingnore all movenment orders. Is there something I am doing wrong
[OG] [Ghastly] ErAs3´er Crank Dec 23, 2016 @ 2:03am 
nice schit
Stele Dec 16, 2016 @ 9:36am 
LOL Daaaang Igitur.

I agree, though. You gotta play this mod a lot to get use to the nuances. After you learn it, it is well worth it.
Igitur  [author] Dec 16, 2016 @ 8:18am 
Test, or learn, before going MP. Use it or not, like it or not, I wont give a fuck. Clear enough ?
Rolf Mützelburg Dec 15, 2016 @ 1:03pm 
Tried to use this mod on a Liberation server... As soon as I told the men to form squads they left my command and stood there like morons... Team lost 30 troops... Rage quit out of embarrassment...
Igitur  [author] Dec 13, 2016 @ 1:44am 
Ok, I'll add an option to disable the map icons as well. I dont know about the enemy 3D symbols, it doesn't make much sense since the command is generic, but I'll check it out. If you're running other mods, I'd suggest to disable them one by one and try again.
chrispy Dec 9, 2016 @ 6:16am 
I like to play arma with as much realism as possible. In its default state this mod shows unit symbols on the map. There's an option to disable 3D symbols (which i use), but i'd like to disable to map symbols as well. Additionally, for some reason I'm seeing 3D symbols of enemy units which I can't make go away.