Portal 2 > 一般的な話題 > トピックの詳細
MC Platypus 2013年2月19日 10時37分
Levels won't "build" in level editor.
I'm playing on Mac 10.7 and am completely blocked in editing levels. Regardless of how simple the change i've made was, It loads the "building geometry" bar to about 90% and it stops there. I still have the cycling wheel around the logo, so it's still "thinking," though I'm not sure what about.

It has never crashed or gotten frozen at this screen. I've never gotten an error message either. It just spins around and pretends to build my level forever until I cancel the build.

Cursory research suggests that not many people have experienced this bug, so there aren't any solutions or suggestions available. I've only found one person who has the same issue I do, and it was in a comment on youtube.

Previous to this point, I wasn't able to load ANY Portal 2 content. It would crash as soon as I attempted to load any gameplay. I fixed this by copying my portal 2 game files from my steamapps folder into my username folder. Now everything runs fine, except for this bug.

I've tried closing and restarting both Portal 2 and Steam, tried verifying my files. Any other suggestions and/or people with a similar issue?

Thanks for your help!
最近の変更はMC Platypusが行いました; 2013年2月19日 10時39分
1-15 / 118 のコメントを表示
< >
MC Platypus 2013年2月19日 10時49分 
Also, if there's a more appropriate forum for this kind of issue, I'd love for someone to point me in the right direction (or for a mod to just move this there I guess).
ARTUCINO 2013年2月19日 12時52分 
I'm having the same issues!
AllardAutomaton 2013年2月19日 13時02分 
I have the same problem. In fact, I made a post about it without seeing this one.
http://steamcommunity.com/app/620/discussions/0/846945579839317813/

This is extremely frustrating. I also have a Mac.
Robeth 2013年2月19日 14時05分 
sakurasakurasakurasakurasakura の投稿を引用:
I'm playing on Mac 10.7 and am completely blocked in editing levels. Regardless of how simple the change i've made was, It loads the "building geometry" bar to about 90% and it stops there. I still have the cycling wheel around the logo, so it's still "thinking," though I'm not sure what about.

It has never crashed or gotten frozen at this screen. I've never gotten an error message either. It just spins around and pretends to build my level forever until I cancel the build.

Cursory research suggests that not many people have experienced this bug, so there aren't any solutions or suggestions available. I've only found one person who has the same issue I do, and it was in a comment on youtube.

Previous to this point, I wasn't able to load ANY Portal 2 content. It would crash as soon as I attempted to load any gameplay. I fixed this by copying my portal 2 game files from my steamapps folder into my username folder. Now everything runs fine, except for this bug.

I've tried closing and restarting both Portal 2 and Steam, tried verifying my files. Any other suggestions and/or people with a similar issue?

Thanks for your help!

Same Thing! REALLY ANNOYING!
pesonn 2013年2月19日 14時07分 
The same problem here.. I think, the Authoring Tool is the bad guy. I can't start this Tool on my mac. It always says "Not available on your Platform...
umblikal 2013年2月19日 17時11分 
Same here
Jaxter2011 2013年2月20日 10時51分 
I'm on OSX 10.6.8 and have exactly the same problem with the 'Building Geometry' progress bar getting stuck forever at about 90%. I've also verified my cache files but that didn't help.

I've looked in the console log and can see many errors like this:

20/02/2013 17:51:17 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]
20/02/2013 17:51:19 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]
20/02/2013 17:51:28 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]
20/02/2013 17:51:32 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]
20/02/2013 17:51:32 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [394] on already claimed lock [394]: /BSem/413adcfa [GameOverlay_InGameRenderingCompleted_385.BinSemLock]
20/02/2013 17:51:37 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]
20/02/2013 17:51:39 com.valvesoftware.steam.ipctool[347] Error: ClaimLock by [385] on already claimed lock [394]: /MTX/6447e992 [GameOverlayRender_PaintCmdStream_385_mutex]

Hope someone can help as I only downloaded Portal 2 for OSX so I could build my own test chambers.
Castor Russ 2013年2月21日 0時16分 
I've had the same issue. It didn't start until I'd been using it for a couple weeks, and not sure way. Very annoying since I spent a lot of time on one chamber and now can't build it.
MC Platypus 2013年2月21日 9時42分 
I don't know whether to be happy or upset that there are so many other people with the same issue.

In the past, I've not had any issues with level editing. Worth noting.
AllardAutomaton 2013年2月21日 10時50分 
Yeah, when the level editor was first released I had no problems. I only recently wanted to start it again, and I have had no luck. It also seems that most if not all of us play on a Mac.
So it might be safe to assume this problem is only relative to OSX users.
rharrington14 2013年2月21日 11時43分 
Im on osx 10.7.5 and experiencing the same issue, I only started trying user built levels yesterday, and started trying to build them today. I can play other users levels, and I can create and save the levels I build, but not compile or "rebuild" them. My level geometry loading bar gets stuck at around 90% like several people mentioned. It seems to be a recent problem, so hopefully it is an easy fix?
Robeth 2013年2月21日 13時20分 
I'm on 10.6. I just varified the game files but everything is fine. I don't know whats going on.
Robeth 2013年2月21日 13時21分 
AllardAutomaton の投稿を引用:
Yeah, when the level editor was first released I had no problems. I only recently wanted to start it again, and I have had no luck. It also seems that most if not all of us play on a Mac.
So it might be safe to assume this problem is only relative to OSX users.
All of the things that pop up so far are mac problems. I just recently got the computer version so I don't know how long this has been happening. Has there been any updates recently?
Mitch McWiggins 2013年2月21日 14時12分 
I'm having the same problem!

It started sometime in early February. I hadn't done anything different, and this has never happened until now.

I go to build or publish any map, and it hangs/stops progress at approximately 90% of Building Geometry. I even created a tiny 1x4 map and it still happens.

I have tried:
- rebooting
- resetting modem/router
- verifying the game cache multiple times
- deleting my preview.bsp/vmf/prt/log files
- deleting clientregistry.blob
(...and nothing works. Same problem, every time.)

I'm on a 2009 iMac, OSX 10.6.8. The console doesn't give me any clues, but then again I'm not a programmer.

This is, of course, really frustrating.
最近の変更はMitch McWigginsが行いました; 2013年2月21日 14時19分
Rampant_Rybo 2013年2月21日 15時52分 
I have same problem and have struggled to find other people with the issue. I'm glad to see I'm not the only one. I have the game on Xbox 360, but the main reason I got it for my computer was the map editor and now I cannot even use it. >:(
1-15 / 118 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年2月19日 10時37分
投稿数: 118