Magic: The Gathering — Duels of the Planeswalkers 2012

Magic: The Gathering — Duels of the Planeswalkers 2012

Not opening the game
i've just gotten a new computer. I go to install Magic the gathering 2012 edition. then when i start it, it says there was a fatal error, and unknown error. Does anyone know how to fix this problem.
< >
กำลังแสดง 1-4 จาก 4 ความเห็น
I have the same problem. The game doesn't start since Windows 8.1 (I used before Windows 7). What should I do ?
You need to change to program setting in file Exporer to the following:

Image to Setting for Program[]

That fixed it for my Win8.1 system, it will not run the game in 640x480 it will just allow it to start. Youy can then go to the settings in MTG to chnage the resolution. Mine runs at 1920x1080 fine
ได้รับการแก้ไขครั้งสุดท้ายโดย Monk Ey; 21 มิ.ย. 2015 @ 3:39am
i should have stated my problems was resolved. I fixed mine by going into the program and changing it from widow 1 to 0. which made it open in a windowed mode instead of fullscreen, which allowed the game to run on my computer.
Silver 7 ชั่วโมงที่ผ่านมา 
Guys, I encountered the same error like you and I managed to fix it. What you need to do is the following:

Open (with notepad or some other text editor) the config.cfg file located in the filepath:

C:\Program Files (x86)\Steam\steamapps\common\Magic the Gathering DotP 2012

Once you have opened it, you will see a line of text something like:


These are your saved graphics settings, the values could be slightly different on your PC than what I posted above which were on mine.

Now I play my games on a 16:10 (rather than 16:9) monitor with the resolution 1920x1200 (rather than a 16:9's 1920x1080). But because in my .cfg file, as posted above, it said 1080 for height, the game crashed every time I started it because apparently it causes a fatal error if there is a different resolution written in the .cfg file than what your monitor's usual/current resolution is.

So I changed the value from 1080 to 1200 to properly reflect my 16:10 monitor's width in pixels, and then the game launched perfectly for me. This error popped up a few days later for me again (maybe it is caused if you play another game and change resolution?). Anyway, I redid these steps and the game now launches again.

If this does NOT work, you can instead try to change the number after [fullscreen] from 1 to 0. That way the game will launch in windowed mode, which is at least something. You could then change the settings inside the game to enable fullscreen and then relaunch the game and see if the error goes away.

If that did NOT work either, you could try finding the game's exe (called Magic_2012.exe) and located in the game folder whose file path I have provided above, right-click it, go to properties, click on the compatibility tab, and make sure the settings look like this:

Hope this helps
< >
กำลังแสดง 1-4 จาก 4 ความเห็น
ต่อหน้า: 15 30 50