Garry's Mod

Garry's Mod

Customizable Weaponry 2.0
Rymd Oct 16, 2015 @ 4:40am
Bugs report here.
1. Sometimes the default Holographic sight and the ACOG textures have errors, not pink and black checkers, it seems like they're misplaced.

2. RT Scopes will bug out if set on high. pic here

< >
Showing 1-15 of 813 comments
Paste Value Oct 16, 2015 @ 5:20am 
issue number 1 is often caused by textures from the M9K rifle pack. if you can spare it, disable it.
issue number 2 can be caused by out-of-date code, in attachment scripts not from this base pack. you should refer to the actual developer of the attachment. if it actually is from this base pack, please tell me.
Rymd Oct 16, 2015 @ 5:21am 
The RT Scope bug appears on ALL high-magnfication scopes on all packs including the base.
sрy  [developer] Oct 17, 2015 @ 9:52am 
set the RT scope quality to high and respawn, that's when the higher-quality RT is applied

but yes, it is a bug, thank you for pointing it out, I know what causes it, and I will fix it now
Rymd Oct 17, 2015 @ 3:38pm 
Also the Shortdot red reticle in the center is not correctly centered.
Abefroman Oct 18, 2015 @ 5:16pm 
I cant reload any of these weapons, whenever i get different ammo types, like the match and magnum rounds. when i switch to them i cant use the weapon at all.
RomanLegionary Oct 19, 2015 @ 8:11am 
My weapon doesn't reload when i press the RELOAD key, why is that?
sрy  [developer] Oct 20, 2015 @ 11:48am 
which scope are you getting that bug on? if it's a non-official one - that is entirely not my problem, whoever wrote the RT code for it did not adapt the code to varying-size render target scopes

also, I am not getting that issue with any of the render-target based attachments in the weapons that are official, so in case you are getting that issue on the official weapons there are a few possibilities:

1. there is another CW 2.0 SWEP pack, that you have installed, which has the same attachment files with old code that override the newer ones provided with the current CW 2.0 pack
2. your hardware, for some reason, does not properly support render targets with a size greater than 512x512 in source engine

if it's the former - try to find out which addon bundles together outdated CW 2.0 files and pester the uploader to remove them

if it's the latter - roll back to the render target size which is most stable, in your case, medium (512x512)
Last edited by sрy; Oct 20, 2015 @ 12:06pm
sрy  [developer] Oct 20, 2015 @ 11:58am 
Originally posted by RomanLegionary:
My weapon doesn't reload when i press the RELOAD key, why is that?

idk, disable other addons and see if that helps

if you installed the CW 2.0 mag system - why are you even whining if you didn't bother to read what it does or how it works?

most of the issues you guys report I never run into, but then again, I run on a vanilla installation of GMod, with no addons other than CW 2.0, so it's most likely some other addon that is overriding some hook that CW 2.0 makes use of

and no, I am not going to fix those edge-case scenarios with specific addons installed for a very simple reason - I am providing you an addon as it is, for free, which was originally made for my friends and I, without the intention of releasing it; if you have an issue with it that I don't have or it doesn't work with another addon - too bad for you, either uninstall CW 2.0 or uninstall the conflicting addon(s), depending on what you like more, since I'm here to maintain what is within my interests, not to add compatibility for a bunch of other addons
Last edited by sрy; Oct 20, 2015 @ 12:05pm
Rymd Oct 20, 2015 @ 6:20pm 
@Spy , The picture I took above are from the extra official pack, Its the G3A3, also I've been getting the same thing with ACOG now, default one, not from pack.

The ACOG and EOTech Textures error is still there sometimes even tho I don't use M9K packs.
sрy  [developer] Oct 21, 2015 @ 12:28am 
read the solutions I posted
Rymd Oct 21, 2015 @ 12:39am 
Going to remove some addons and try again, also my rig is high end so no worries about it
Chia Pet Oct 21, 2015 @ 8:17pm 
Alot of shotguns on the CW base (including the M3 Super 90) have this error when I press F2 to view the stats. The world turns transparent and the only way to fix it is to go in and out of the customize menu

Error message:

[Customizable Weaponry 2.0] lua/cw/client/cw_statdisplay.lua:484: attempt to perform arithmetic on field 'ReloadHalt_Orig' (a nil value)
1. origTextFunc - lua/cw/client/cw_statdisplay.lua:484
2. draw - lua/cw/client/cw_statdisplay.lua:126
3. drawFunc - lua/cw/shared/menutabs/weaponstats.lua:35
4. draw - lua/cw/shared/cw_interactionmenuhandler.lua:59
5. drawInteractionMenu - lua/weapons/cw_base/cl_model.lua:969
6. _drawViewModel - lua/weapons/cw_base/cl_model.lua:732
7. drawViewModel - lua/weapons/cw_base/cl_model.lua:586
8. v - lua/weapons/cw_base/cl_hooks.lua:34
9. unknown - lua/includes/modules/hook.lua:84
sрy  [developer] Oct 21, 2015 @ 11:11pm 
thanks for reporting
Rymd Oct 21, 2015 @ 11:23pm 
Help me, just got this new bug, I can't switch sights anymore lately, whenever I switch to a sight that has multiple colors and I press 1 to switch it just switch to a different color endlessly.

By the way, the scopes all fine now, removed all community pack.
Tamer Oct 22, 2015 @ 6:57pm 
Minor Bug: ACOG Backup sights unavailable with simple telescopics
Affects: All weapons using ACOG sights
Details: When simple telescopics is enabled, i cannot use the backup sights.
No Significant console output
No conflicting addons installed, tested recently
Severity: 1/5 (Minor nuisance; 5 being game crashing)
Workaround: Disable Simple telescopics

If you need me to, i can try an hunt around for more info, But this is all i can find easily
< >
Showing 1-15 of 813 comments
Per page: 15 30 50