Cities: Skylines

Cities: Skylines

513 ratings
Vehicle Effects 1.8.1
 
Rate  
Favorite
Favorited
Unfavorite
Mod
File Size
Posted
Updated
0.275 MB
Oct 14, 2016 @ 11:08am
Oct 23, 2018 @ 4:23am
24 Change Notes ( view )

Subscribe to download
Vehicle Effects 1.8.1

Subscribed
Unsubscribe
In 5 collections by Acc3ss Violation
Dutch Railway collection
84 items
Freight Trains
31 items
Passenger Trains
49 items
American Trains
10 items
Acc3ss' Mods
6 items
Description
Allows effects to be added to vehicles with xml files!

Recent features

- Load (sort of) custom particleeffects via xml! Check this discussion page on how to do it and for sharing examples!
- Load custom sound effects via xml! Check this discussion page on how to do it and for sharing examples!
- Editor for creating and previewing configs in the Asset Editor! (The button may be hidden behind a EAE panel if you use that as well. Just drag the panel away)
- Mod folders are now searched for VehicleEffectsDefinition.xml


Other features

- Light, sound and particle effects can be added to any vehicle.
- Several new particle and sound effects made for use with vehicles.
- Press Ctrl + Alt + V to reload effects (useful for asset creators)

Known issues (asset creators)
- Config does not load when bundling vehicles with non-vehicle assets in a single workshop item:
a vehicle asset file (.crp) MUST be first in the list when ordering all .crp files in the upload alphabetically by filename. If a non-vehicle asset is first the mod WILL NOT be able to find the config files.


Partially based on Network Skins by boformer to get the xml files working.

GitHub page[github.com]


Check this discussion page for a (partial) list of assets using this mod!
I've updated several of my assets to include a config file to make use of this mod, so check those out as well.
Popular Discussions View All (10)
12
Mar 25 @ 1:18pm
PINNED: Custom Sounds - Tutorial + sharing
Acc3ss Violation
20
Dec 11, 2016 @ 4:36am
Adding new effects
Thaok
7
Dec 30, 2017 @ 11:55am
PINNED: Made an asset? Leave a link here!
Acc3ss Violation
< >
151 Comments
Acc3ss Violation  [author] Apr 20 @ 2:02am 
Sure, you can send it
Distanced Apr 19 @ 1:51pm 
Steam's not letting me share the link, I can dm you it if you add me
Distanced Apr 19 @ 1:48pm 
I did some more digging and actually only effects for assets I'm testing are not working anymore. Here's a link to the mega folder with the output log and my definitions file, maybe you'll find an error in there that I haven't

{LINK REMOVED}

Acc3ss Violation  [author] Apr 19 @ 11:48am 
Acutally, I just checked a normal log of mine, it also has the same GameSettings error message in it (for every mod, not just this one), so I doubt that's the issue. I'd appreciate a pastebin of the entire log.
Acc3ss Violation  [author] Apr 19 @ 11:47am 
The Unknown effect logs are fine, I have 211 instances of it in the log even though the mod's working fine for met. The game logs any failed attempt to find an effect, so even though the mod handles the missing effect just fine, you still get a lot of entries in the log.

As for the GameSettings issue, I thought I had fixed that once before, but I might be confused with another mod. Is it the most recent workshop version you are using or a local copy?
Distanced Apr 18 @ 8:33pm 
Am also getting a ton of Unknown Effect messages. If you need more I can post the entire vehicle effects portion of the output log to a pastebin
Distanced Apr 18 @ 4:27pm 
Mod has ceased to work for me, output_log.txt has this mentioned:

GameSettings: 'VehicleEffectsMod' is not found or cannot be loaded. Make sure to call GameSettings.AddSettingsFile() to register a settings file before using SavedValue(). [Settings - Internal]

Is there a known fix?
Acc3ss Violation  [author] Mar 29 @ 10:49am 
That message shows for every mod the game loads, doesn't really mean anything except that the mod got loaded. I was more thinking about any log file lines starting with the text "Vehicle Effects", which are log messages made by the mod itself. It should log all effects it loads (or tries to at least) and any errors it runs into. Those would be useful in finding the issue here.
YellowFoxBoi Mar 28 @ 5:31pm 
It says:

Fallback handler could not load library C:/Program Files (x86)/Steam/steamapps/common/Cities_Skylines/Cities_Data/Mono/data-000000001C4D0A90.dll
Assembly VehicleEffects, Version=0.1.6870.23922, Culture=neutral, PublicKeyToken=null loaded. [Mods - Internal]
Acc3ss Violation  [author] Mar 27 @ 11:43am 
Alright then, here are some questions. Is the mod enabled in the content manager (probably, but I'm asking to make sure anyway)? Are they custom configs you made yourself or from a mod/asset on the workshop? If they're your own, are you sure the filenames are correct with the correct extension (.xml) and all asset names in the files are correct as well? If they're from a workshop item, which one?

I also just realized it will not load from the game's local 'assets' folder if there are no enabled assets in there. If you don't have any, just create some random thing in the asset editor and make sure it's enabled in the content manager.

You can also check the game's output_log.txt for lines starting with Vehicle Effects, it should log all custom effects and definitions it loads and any errors as well.