Age of Wonders III

Age of Wonders III

28 ratings
Empire Building Mod Hero Compatibility v2.0
   
Award
Favorite
Favorited
Unfavorite
File Size
Posted
8.838 MB
Jun 26, 2017 @ 12:36pm
1 Change Note ( view )

Subscribe to download
Empire Building Mod Hero Compatibility v2.0

Description
This is a reduced version of the Empire Building Mod that doesn't change heroes. Thus it should be compatible with most mods that modify hero upgrades (as Eomolchs Hero Development Mod). It replaces the old Hero Compatibility EBM and fixes bugs, improves balance, adds more content (eg. 3 more alternative MCUs) and tweaks some of the added units graphically.

DON'T USE THIS MOD IN ADDITION TO THE REGULAR EMPIRE BUILDING MOD! This will not only remove hero compatibility but most likely also cause some issues with the upkeep.

In this version Veterans Hall and War Hall are not mutually exclusive.

(The reason why I created a new mod instead of updating the old mod, is simply that it saved me a lot of time: Instead of adding all the stuff to the original version I could just remove all hero related files from the base mod. )
< >
29 Comments
Goemoe May 27 @ 6:50am 
Don't bother. Currently all is working well with the mix of mods we use. :)
Der Mentat  [author] May 26 @ 8:52am 
Great to hear, you like the mod. The compatibility patches unfortunately only work with the standard EBM. (It would require new compatibility patches to use this mod as a basis.)
Goemoe May 19 @ 12:14am 
When I use this mod, all empire building mod compability patches tell me they miss the empire building mod. Are they not needed for this mod? (Decodence, Arsenal etc.)
Goemoe May 17 @ 9:19am 
Thank you for doing this mod! We enjoy it much and we don't like the changed hero advancement so it was a big help for us to get this variant of your work :)
Der Mentat  [author] Apr 22 @ 2:53am 
The unit compatibility mod probably adds all the changes to heroes again and makes it thus incompatible. I just tested it with only the Hero Mod Compatibility active and could choose professions for my leader as well.
Dragon Apr 11 @ 11:39pm 
@Der Mentat So I experimented with this mod and found that the profession mod indeed worked, however I found that it only worked on Heroes and not the Leader them selves, some how the Profession is not available for the Big Guy/Gal in charge, so your leader doesn't get to chose a profession? That doesn't seem fair =) just thought I'll let you know...P.S. I was using the other Empire Building Mods, like the total conversion and unit compatibility, so I'm not sure if they bugged out the leader not having the professions to chose from or not, but just thought that info would help out any bug solving. =D Thanks
Der Mentat  [author] Feb 7 @ 4:33am 
I can only say that this mod shouldn't be used in combination with the base mod (as pointed out in the description).

This version is specifically created to allow compatibility with the Hero Professions Mod (and similar mods), but for many other combinations it's not needed. (You should for example be able to use the base EBM together with the Hero Development Mod.)

So in many cases the base EBM is the better choice.
jtcbrown Feb 6 @ 7:05pm 
So... some mods have compat patches, like Legendary Heroes, which require the base mod - but then some mods don't, and would seem to require this version... it is a conundrum :D

(I'm having late-game crashes and can't continue game; trying to find cause.)

Insomniel Oct 3, 2019 @ 5:40am 
Ah, that's a shame. Thank for letting me know and creating this mod in the first place!
Der Mentat  [author] Oct 3, 2019 @ 4:12am 
This compatibility version doesn't include the Frostling Valkyrie and other small changes (the most important ones are listed in the changelog of the EBM). Unlike the other compatibility mods this mod is unfortunately extremely difficult to upgrade and it would be even easier to create a new version 3.0...