Steam

Steam

267 ratings
An Unofficial Guide to Special K
By Aemony
An unofficial collection of guides and instructions for Kaldaien's Special K framework/mod.
2
   
Award
Favorite
Favorited
Unfavorite
Introduction
Special K[special-k.info] is an extensible game modifying framework created by Kaldaien. This framework can be used to modify graphics related settings of games. The framework supports both local (game-specific) and global (system-wide) injection, whatever matches the user's need the best.


More Special K resources:
- Discord[discord.gg]
- Forums[discourse.differentk.fyi]
- Wiki[wiki.special-k.info]
< >
89 Comments
MrPancake50 Jan 3 @ 2:05pm 
Hey, im trying to edit the number of cores for lost planet 2 as it only likes 6 or less for some reason. I tried changing the "OverrudeCPUCoreCount" option in the ini file. but that didnt work. Does anyone have any other ideas?
DoublePlusUngood Mar 5, 2021 @ 10:03am 
Crap, no editing comments but for me.
Make sure to NOT be in fullscreen mode. If all this was already mentioned sorry but I ain't got time to go through 9 pages.
DoublePlusUngood Mar 5, 2021 @ 10:00am 
Also HIGHLY recommend a ReShade, just using legacy Colorfullness and Curves alone on default take away the absolute horrible desaturation this game has and brings back the contrast. Reds look red not sun-bleach barely pink...
I mention cuz this white haze trend drives me nuts but can confirm the fix and special K didn't conflict with ReShade.
DoublePlusUngood Mar 5, 2021 @ 9:55am 
For anybody info my onscreen framerate monitor (have only used Nvidia) still shows the game at 60 fps after this fix.
Make sure Vsync is turned OFF in options.
Will still say 60 fps onscreen but upon checking my monitor menu (hopefully yours has one) it says 144hz with Gsync on.
With Vsync on my monitor reports 60hz so I know it's working.
SPQR_Jack Nov 26, 2020 @ 10:37am 
Sup man, I've been trying to use the Special K to fix the Final Fantasy VIII remastered frame rate problem. I downloaded the 0.10.3.7 version from: https://github.com/Kaldaien/SpecialK/releases/tag/sk_0_10_2 , did a manual local instalation (copied the SpecialK32.pdb and SpecialK32.dll to the game folder and renamed the dll to OpenGL32.dll), but when I try running the game I get an error message saying:The procedure entry point wglGetProcAddress could not be located in the dynamic vehicle library Final Fantasy VIII Remastered\FFVIII_EFIGS.dll.
When I delete the specialK files from the game folder the games starts normaly again, but whenever I try using SpecialL's file I get this error message.
Any idea how to fix this?
adnan? Aug 7, 2020 @ 4:41pm 
Just did my bad
Aemony  [author] Aug 7, 2020 @ 4:35pm 
@adnasn, please post over on the dedicated forum for Special K: https://discourse.differentk.fyi/
adnan? Aug 7, 2020 @ 4:22pm 
adnan? Aug 7, 2020 @ 4:20pm 
Hello! i've been having a lot of issues with RE4, each time i run it the "metal gear detected" sound plays and game crashes then a crash log appears. Anyone know anything about this?
Aemony  [author] May 26, 2020 @ 10:45pm 
@One Eyed Leftist: You probably had rundll32.exe processes running in the background that were responsible for the global injection.

SKIM64.exe and the new SKIF.exe tool in the Steam release is basically just frontends that loads the DLL files through rundll32.exe processes that runs in the background. Often times, when a user is unable to remove the Documents\My Mods\SpecialK folder, its because either one of those processes are running with a lock on the Special K DLL files, or the DLL file is injected in a process which then retains a lock on the files.

The usual recommendation I have to work around this is the following

1. Disable auto-start in SKIM (or SKIF, if that's being used).
2. Restart your system.
3. Remove the SpecialK folder.