Arma 3
36 ratings
[CRASH FIX] 0xC0000005 - STATUS_ACCESS_VIOLATION
By Dragon
I found a way to fix a crash related to memory allocation. If you running Arma 3 on Windows 10 [64-bit] and your game crashing constantly you might try to fix it by following instructions in this tutorial.

I can't guarantee that this will help you but it's worth to try.
   
Award
Favorite
Favorited
Unfavorite
How to fix 0xC0000005 - STATUS_ACCESS_VIOLATION
Change the security settings
  • 1. Find the game folder (usually located at C:\Program Files (x86)\Steam\steamapps\common\Arma 3)

  • 2. Right click on Arma 3 folder, select Properties and go to the Security tab

  • 3. Click on Edit and give all groups and profiles Full control

  • 4. Click on Apply and go to Advanced

  • 5. Click on Change right next to the Current owner

  • 6. Type in your pc's User Name and verify the name

  • 7. Click on Apply and Close the window.
Try with different memory allocators
  • 1. Open Arma 3 Launcher and go to PARAMETERS --> ALL PARAMETERS --> Advanced --> Memory allocator

  • 2. Check how the game works by selecting different memory allocators
Delete Arma 3 directory from AppData folder
  • 1. Go to C:\Users\YOUR_USERNAME\AppData\Local
    (To access AppData folder, simply type %localappdata% in Windows Search or press WinKey + R and type it there)

  • 2. Delete the "Arma 3" directory or rename to something else
    (for example "Arma 3 - Backup" just to keep it as backup just in case)

  • 3. Now open the launcher and try again. The "Arma 3" directory will be recreated.
Change Platform to 32 bit
  • 1. Open Arma 3 Launcher and go to PARAMETERS --> ALL PARAMETERS

  • 2. Change Platform to 32-bit.

  • 3. Add the -nologs parameter to the Command line.
Restore the parameters to default
  • 1. Open Arma 3 Launcher and go to PARAMETERS

  • 2. Click on Restore defaults.
Update your BIOS
< >
9 Comments
Чухан Mar 12 @ 9:33am 
this instructions killed arma
NoSok _SydBy Feb 27 @ 10:00am 
Да у меня тоже самое, в поддержку писал пока тишина.
Bandit9999 Feb 24 @ 12:10pm 
Since yesterday's update I have permanent crashes when I push the button "scenarios".
I can play the campaign, can open the editor and play my own missions there. Everything without problems.
But at the moment when I want to open scenarios ... the loading screen appears, a few seconds later the game crashes. And I got this 0xC0000005 - STATUS_ACCESS_VIOLATION

I try the thngs you write, it didn*t work.
I install the game new, it didnt help.
I has let check my hardware in a services, anything ok.
I try other gammes, anything works well.

Anybody have the same probem sinces the update yesterday?
Anybody have any idea?
Johnny Nov 2, 2020 @ 10:44am 
Yeah none of this worked for me....
K-9 [redneck] Jul 3, 2020 @ 1:09pm 
Got a ? for ya .... I need to get the DLC "Old Man" but STEAM seems to have removed it. I need one of the A3 files to make my campaigns work properly. Got any ideas?
Trojan79 Jun 28, 2020 @ 1:39pm 
my problem solved thanks to different memory allocators :steamhappy:
GambleZ_AE Apr 8, 2017 @ 1:35pm 
Guys I used to get this problem a lot and after trying all these fixes which didnt work, I decided to update my motherboard bios/drivers which made my ram compatible fixing all my problems. I strongly suggest updating your motherboard drivers unless you have a potato pc ;p
comrade tim curry Apr 7, 2017 @ 7:52pm 
im going to suicide
Terminator Apr 5, 2017 @ 7:12pm 
Been looking for possible fixes for a long time, thank you so much mate!