Age of Wonders III

Age of Wonders III

92 ratings
Triumphant Heroes for Empire Building Mod
   
Award
Favorite
Favorited
Unfavorite
Mod
File Size
Posted
0.414 MB
Sep 10, 2016 @ 3:38pm
1 Change Note ( view )
You need DLC to use this item.

Subscribe to download
Triumphant Heroes for Empire Building Mod

Description
This Mod makes Triumphant Heroes and the Empire Building Mod compatible. It requires in addition both original mods:

https://steamcommunity.com/sharedfiles/filedetails/?id=745699351&searchtext=

https://steamcommunity.com/sharedfiles/filedetails/?id=519469975&searchtext=triumphant+

Occasionally I had to change available spells for particular heroes to make it work, but the unique properties are still the same.
< >
11 Comments
dmcf Feb 14, 2018 @ 1:32pm 
Looking forward to that compatibility mod
dmcf Feb 14, 2018 @ 12:50pm 
Ok - thanks for your replies and all your work
Der Mentat  [author] Feb 14, 2018 @ 12:48pm 
The Unit compatibility version would indeed require a new compatibility mod to work with Triumphant Heroes (additionally i think I never updated this version as it would require a lot of work, so it has less content anyway).
I'm going to create a compatibility mod for New Arsenal though, hopefully finished within this month...
dmcf Feb 14, 2018 @ 12:38pm 
Ah right thanks for the explanation. I know changed my mind and want to try with Unit Compatibility version of Empire Building to try other unit mods (New arsenal etc along with both). Which would need another compatibility mod? Sorry - i'm a pain in the arse i know. And thanks again for making this mod
Der Mentat  [author] Feb 14, 2018 @ 12:35pm 
That's strange, usually the game only recognizes missing mods if they are part of the dependencies of one mod.
Just to be sure that we are refering to the same issue: My suggestion was to use EBM Hero Compatibility + Triumphant Heroes (However it shouldn't work if you use EBM Hero Compatibility + Triumphant Heroes for EBM + Triumphant Heroes).

BTW you can theoretically use the full EBM and the Hero Development Mod at the same time (some skills will be available multiple times though), only if you want Hero Professions Mod in addition it wont't work with the full EBM.
dmcf Feb 13, 2018 @ 10:45am 
Thanks - i did try that but game said i needed to install the complete Empire mod or uninstall Triumphant Heroes - refused to accept the Hero Compatibility one. No idea why. I just installed full version of Empire Building instead and didn't use Hero Development mod
Der Mentat  [author] Feb 13, 2018 @ 5:58am 
If you use the Hero Compatibility version there should be no issues if you combine it just with the regular Triumphant Heroes Mod. There's no additional compatibility patch needed.
dmcf Feb 12, 2018 @ 8:13pm 
Any chance of a compatibility patch for this to work with the Hero Compatibility version of Empire building mod?
http://steamcommunity.com/sharedfiles/filedetails/?id=956473040&searchtext=empire
Der Mentat  [author] Aug 16, 2017 @ 11:01am 
Hi Gilafron, sorry for the late reply. I don't think I can create compatibility patches for every combination of mods (I can't easily copy changes from one mod to another, so I have to completely work through all the files again). But you still could combine both mods, you just need to select the coresponding race skill when a hero from the Triumphant mod joins you.
Gilafron Jul 30, 2017 @ 11:39am 
I like this mod. However, it doesn't work with Empire Unit Compatability. It would be nice if it would work with that one.