Garry's Mod

Garry's Mod

368 ratings
[TTT/Sandbox] Riotshield
 
Rate  
Favorite
Favorited
Unfavorite
Type: Weapon, Addon
Tags: Fun, Roleplay
File Size
Posted
Updated
0.660 MB
Jan 21, 2015 @ 9:45am
Mar 23, 2017 @ 8:35am
45 Change Notes ( view )

Subscribe to download
[TTT/Sandbox] Riotshield

Subscribed
Unsubscribe
Description
All of my addons are up for adoption.
If you're interested in the continuation of one or more of my projects, please feel free to do so.
You are free to change, add and reupload. However I would greatly appreciate you mentioning me as original author.

This is a fully functional riot shield for the detective.
It stops any bullet that hits the shield but no more.
Additionally, it does not offer any protection against fire-, fall, explosion or suffocation damage.

The original idea and design is not mine, however I have provided the most part of the current functiality.

Here is the link to the original addon, all credits of course go to the original artists.
Should you, as the official creator(s) of this addon, still feel offended I will of course take it down immediatly.

First of all, sorry for not updating the description.
The functionality of the shield has changed quite alot, so let's get started.

The riotshield now can only be held in front of you like any normal weapon, too.
While doing this, it (of course) stops bullets from hitting you.
Bullets hitting the shield instead deal damage to it, ultimately leading to it's destruction.
It does take quite a while for it to break and this is also configurable.

While holding the shield, you can use it's active ability by holding right click.
This will make you accelerate in the direction you're facing and anyone standing in your way will, based on the speed with which you hit them, either just be knocked back and taking some damage or will be kompletely knocked out and drop their weapon. The speed threshold at which this happens is also configurable, just like every aspect of the charge itself.

If you want to learn more about the configurability of the shield, just type "riotshield_" into the console and a bunch of commands should show up. They're pretty self-explanatory and after a bit of toying around (you'll have to do that anyways), you should get a pretty good grasp on which aspects are configurable.
Please keep in mind that you should not extend the charging duration past the charge's cooldown because this leads to very weird bugs.

Special thanks to SOFA for creating the ingame icon, looks very nice and fits in with the standard theme very well.
Popular Discussions View All (3)
5
Jan 29, 2016 @ 10:00am
Bug-report: Traitors get Shield on Round start
DeathWalkR zockt nix mehr lol xd
2
Apr 15, 2017 @ 6:18pm
Lua Error Causing Weapon to be unusable
ISR Mafia
2
Sep 20, 2016 @ 3:01am
Suggestions
Oladin
< >
109 Comments
Mr.Grumpy Mar 6, 2018 @ 7:51am 
For me it also doesnt apear in the weapons list / inventory and when its damage you can repair and when it destroyed the nest shield you spawn will say 300/300 but only has one hit point....
Gloomba-King Aug 23, 2017 @ 1:53pm 
why doesn't appear in my weapons when i get it?

What i mean is it doesn't apear in the weapons list of what i have on me
Vietnamese Farmer Jun 22, 2017 @ 2:50pm 
I believe the active ability isnt working.
Bergster Mar 23, 2017 @ 12:49pm 
Yeah the addon is still good without it; it's just a nice additional feature. Not sure how easy of a fix it is, but I wouldn't blame you if you didn't want to.
Oladin  [author] Mar 23, 2017 @ 11:22am 
Sounds good. Hmm, I noticed too that the charge knockback doesn't work. However I do ask myself if it is necessary at all. After all, it is still nice engage/disengage tool
Bergster Mar 23, 2017 @ 10:56am 
Thanks for updating the addon! The new lua file isn't giving errors anymore, so that problem's been solved. However, after updating all my files, the charge ability still won't deal damage or knockback :(. Not sure what the cause could be at this point if it's working as intended for you, but not for me. If anyone else is having this problem, please leave a comment; I want to know if it's a problem that's specific to me, or if it's a universal problem.
Oladin  [author] Mar 23, 2017 @ 8:38am 
I am sorry I had you wait for so long. I have updated the addon, please let me know if it worked.
Bergster Mar 23, 2017 @ 7:33am 
By the way Oladin, are you going to upload your files anytime soon? It's been over a month since we last discussed it and it doesn't seem that difficult or time consuming to do.
Bergster Mar 23, 2017 @ 7:32am 
If you're getting lua errors then you should try reading the comments, the problem's already been resolved.
ISR Mafia Mar 14, 2017 @ 4:19am 
still didnt fix this after half a year.... horrible support