Umurangi Generation

Umurangi Generation

32 ratings
How to Get "Speed runner" (even though it's bugged)
By Erratic_Engineer
The "Speed runner" achievement is broken for a lot of people. This seems to be a bug with one of the more recent patches. This guide will show you how to use Steam to download and run an older version of Umurangi Generation.
2
2
2
2
   
Award
Favorite
Favorited
Unfavorite
Introduction
The Speed runner achievement appears to be broken for many people, myself included. This appears to be an issue introduced with the updates published in 2022. Fortunately, Steam allows users to download earlier versions of the game, ones in which the achievement isn't bugged, that we can use to unlock it!

It's at this point I must say I'm indebted to StepS's guide on downgrading Beat Saber, without which I would have never known that this sort of thing was possible. That guide has additional reading into this sort of technique, so please check it out if you're interested in learning more.
1) Determining The Codes Needed to Download
In order to use Steam to download a specific version of Umurangi Generation we are going to need three codes: the App ID, the Depot ID, and the Manifest ID. We can look up all of these using SteamDB.[steamdb.info]

The App ID for Umurangi Generation is 1223500. The Depot ID is 1223501. However, the Manifest ID is unique for each version. I mentioned earlier that the bug appears to be introduced in the 2022 updates; possibly the June update but I'm not 100% sure. To be safe, I chose the 2021-Oct-12 update which has a Manifest ID of 5540599311058635572
2) Using the Steam Console
Press Win + R to bring up the Run prompt. Input steam://open/console and run it.


Steam should switch to a console section with an entry field at the bottom. The format we use is "download_depot [App ID] [Depot ID] [Manifest ID]". So for the 2021-Oct-21 version the code is "download_depot 1223500 1223501 5540599311058635572"

Press Enter to begin your download. Steam will not display download progress, but it should be running in the background. Wait until you see the message that begins with "Depot download complete".
Take note of the file path, you'll be using it shortly.
3) Managing Files
Open up your file directory, find your Steam Library, and then go to steamapps->common->Umurangi Generation. There should be another Umurangi Generation folder in here. Inside this one are your game files. I recommend backing them up somewhere if you don't want to re-download the game once you're done with this whole affair, but either way, remove it entirely. We don't want any conflicts or weird behaviors due to "mixing" this current version with the old version.

Now go to where you downloaded the old version. You can copy the address you received from your Steam Console and paste into the address bar of your file explorer. Once you are there, move everything into your steamapps\common\Umurangi Generation folder. Remember: there should be two "Umurangi Generation" folders, one inside the other.

Congratulations, you have downgraded your game! In your Steam program go back to your library and play your game like normal to re-earn the Speed runner achievement. Once you are finished with this version of the game either replace your game files with your back-up, or have Steam re-download the current version to restore everything to normal.
8 Comments
cXrdyceps Apr 24 @ 11:23am 
You're an absolute legend... and I'm a complete idiot. I was deleting the wrong folder. Worked perfectly following your instructions and got my first ever Completed Game. Thank you so much!
Erratic_Engineer  [author] Apr 23 @ 7:48pm 
So the game works fire when you launch manually, but Steam is having an issue running it? I can't say I've heard of that issue before. Apologies in advance if you've already thought of this, but are you sure the game files are in the proper spot? If I remember correctly, the folder structure is a little odd: there are two "Umurangi Generation" folders. It should be something like steamapps\common\Umurangi Generation\Umurangi Generation\[game files go here].
cXrdyceps Apr 23 @ 2:51am 
I did all of this but, when launching the game (after installing the old version and deleting the original files), I get an error message saying I'm missing the .exe. Then, if I close that text box and try to launch the game again, Steam automatically starts downloading the latest update.

I also tried launching the old version of the game by executing the .exe directly from the folder. That way I can open that version of the game, but I can't use the Steam interface nor get the achievement (I tried). Does anyone have this problem or know how to fix it? It's honestly so sad this game's been abandoned like this.
Natonoi Apr 16 @ 3:49pm 
Thanks for the help.
spring Sep 10, 2023 @ 6:41am 
thank you, that worked! :eleven:
cantini Sep 9, 2023 @ 3:13pm 
Thanks for the work around!
incipit Jul 24, 2023 @ 6:30am 
worked, thx a lot!
Canal Apr 16, 2023 @ 7:45am 
Holy shit, surprised this actually worked- thanks so much for helping me get 100% on this game!