Return to Castle Wolfenstein

Return to Castle Wolfenstein

303 ratings
RtCW Troubleshooting Guide
By >M@tEo$<
RtCW is running under the iD Tech III (or Quake 3 Engine), and was released in 2001.

Since then, hardware and software have evolved, and with time it is not uncommon to experience incompatibilities, from just a FPS loss to a game not starting at all or crashing after configuring the video settings.

Several users posted multiple threads about a batch of issues, and dedicated users with the right knowledge kept helping them with saying always the same words.

The point of this guide is to sum up, all in one place, the issues experienced in the past and give one or several solutions, because in computing world, there's always several solutions at hand :)

If you're unhappy of this guide or else, feel free to comment or contact me, it can evolve too :)

Thank you for reading! Let's hope this guide will sort things out for you :)
5
   
Award
Favorite
Favorited
Unfavorite
Before trying anything
There's a free mod recently released called RealRtCW which improves on its own the support of modern systems

Try installing and running it, it will probably work:
https://store.steampowered.com/app/1379630/RealRTCW/

Else, just check below!
Updating the game files
Not required in most cases but can help

Important note:
In some cases, this is required for ioRtCW!
If the game doesn't start with some error like missing files, you'll have to update your game!

You can find the original 1.4 and 1.41b installers for Windows there: https://www.wolffiles.de/index.php?filebase&fid=4992

OR

It's all in the ZIP file called 'patch-data-141.zip' on the ioRtCW GitHub releases page in the below section, or if you want a direct link:
https://github.com/iortcw/iortcw/releases/download/1.51c/patch-data-141.zip

This patch contains up-to-date PK3 files as well as binaries for the 3 main OS (Windows, Unix and Mac); for Windows just extract and replace EXE, DLL, CFG and PK3 files in the correct folders

Multiplayer-only
Firstly, recommended but not needed, get and install the Patch 1.41b (Steam release is 1.32; this patch is MP-only, it does not include previous patch data):
Windows (ZIP) - http://download7.gamershell.com/filehell/98922190874e62a5b98f5cd7e1af775a5204ee9f003546/patch/Wolf-1.41b.zip

Alternative link - http://www.wolffiles.de/index.php?filebase&fid=2413

For Linux users, here's a tutorial for CD owners under Ubuntu:
http://ubuntuforums.org/archive/index.php/t-1451501.html

Then, go to your RtCW installation, and remove the pb folder (outdated and can't be auto updated anymore), and download/extract this one:
http://69.65.113.18/rtcw-pb.zip

Alternative link - https://www.dropbox.com/s/zpb9k7hcvwy0f03/rtcw-pb.zip?dl=0

Optionally, If it isn't installed, you can also get the PBSVC, it helped some users when the PB has troubles to initialize itself:
http://www.evenbalance.com/downloads/pbsvc/pbsvc.exe
If you're OK with installing custom (safe) binaries
Some people don't like to download and install/run custom binaries (DLL and EXE files for Windows), because they're afraid they could infected or something

If you don't want to go through that guide and just want to have the game running with better stability, improved performances, with support of modern systems features (more screen resolutions, better aspect ratio, some security fixes here and there, custom alternative renderer, etc.), then you can simply grab ioRtCW

Your game will need to be up to date in some cases to properly run it, see the first section above

The source and the releases can be found on GitHub, in other words it's safe: https://github.com/iortcw/iortcw/releases

You can grab patched content as well as localization files there too

I suggest to just take single-player (SP) files; MP doesn't come with PunkBuster because it's a proprietary software for instance

ioRtCW is used as a base by projects such as RtCW Coop or Venom Mod

Important note about x86 vs x64 releases
If you already have a save game, have in mind they're not compatible between x86 and x64!
So take the x86 release of ioRtCW!

As for installation, you will notice that the package content matches the game installation structure, with EXE/DLL files at the same level as a Main folder
The default installation path is C:\Program Files (x86)\Steam\steamapps\common\Return to Castle Wolfenstein, but may vary if you've installed Steam on an other drive or if you have several steamapps scattered accross different drives

Once installed, it'll will look like something like the screen capture below:
https://steamcommunity.com/sharedfiles/filedetails/?id=1127050002

You can then rename the original EXE to something else or move it elsewhere and then rename the ioRtCW one to match the original name (WolfSP.exe), so it is automatically launched through Steam (else you'll play the game through ioRtCW only if you execute the ioRtCW EXE file)

Else, if you want a vanilla fix (e. g. no replacement of binary files), just scroll down!
Game doesn't start at all
If nothing happens when you launch the game through Steam after the usual preparation window disappear, it is probable that you have Windows Vista/7/8, and that you have Steam and the game installed in Program Files.

If so, you'll need to start the game as administrator in order to have writing permissions in this folder, so the game can generate a configuration file (wolfconfig.cfg) in its Main subfolder.

To do so, you have several solutions:
- Create a shortcut on the desktop (if you have not one yet, right click on the game in your Steam game list, and select the option to create one), then right click on it, Properties, Compatibility, and tick the box Run as administrator. With this method you'll need to launch the game through that shortcut, but I'm not sure you'll have Steam overlay.
- Browse the game folder, usually Steam\SteamApps\common\return to castle wolfenstein\, right click on WolfSP.exe, Properties, Compatibility, and tick the box Run as administrator.

Thanks to Pork-Chop Express for reporting this issue! :)

An other reason may be the presence of Glide Wrapper on your PC; Uninstalling it will allow the game to run.

Thanks to dagami84 for the report!

Source:
http://steamcommunity.com/app/9010/discussions/0/616199736995090697/

Last but not least, if these did not help you, try to rename/move out (but don't remove!) the gl folder inside the game installation. If it still doesn't work, few people had it working by putting opengl32.dll inside the gl folder. This DLL is located in C:\Windows\System32 (don't move it, make a copy!).

Source (not the oldest though):
http://steamcommunity.com/app/9010/discussions/0/594820656446873167/#c594820656451347157
Game crashes and doesn't start after changing the resolution ingame
Also very well known as GLW_StartOpenGL() - could not load OpenGL subsystem.

This is a common issue since Windows Vista. And there's several solutions, so choose the one you appreciate the most :)

Editing the configuration file back to default
Browse /SteamApps/common/return to castle wolfenstein/main.

Open the file wolfconfig.cfg using the Notepad, search (CTRL + F) for the line r_mode, and set it to 4.

The game should load again.

If you want more information about this cvar, start the game, open up the console and type /modelist.

Resetting the whole file to its default
Simply remove the file described above ^^
Upon the next launch, the game will detect the fact the file isn't existing and will generate it with the default hardcoded value.

Install unofficial binaries
There are several projects who aimed to update RtCW binaries just to have a better support of modern systems.

A still maintained, and the most advanced fork of RtCW, is ioRtCW. It is available in 32 and 64 bits, for all of the 3 PC OSes. You can download the latest release here:
https://github.com/iortcw/iortcw/releases

If you're interested in it, you can follow the dev there, and also submit issues and ask for features:
https://github.com/iortcw/iortcw

And also join the IRC channel #iortcw @ Freenode for a quick chat with the main dev:
http://webchat.freenode.net/?channels=iortcw

And here's a tip as to how to automatically set the game resolution to your desktop one:
https://steamcommunity.com/app/9010/discussions/0/619573787630197940/?insideModal=1#c613948093879704747

Thank to a.j for digging this post :)
Game crashes with the error "q_strncpyz null src"
Reported in the comments section of this guide by the user Razdor who has found himself the solution and shared it, so here it is:
Browse /SteamApps/common/return to castle wolfenstein/Main.
Open the wolfconfig.cfg file using the Notepad, search (CTRL + F) for the line r_glIgnoreWicked3D, and set it to 1.
Can't run the game above 800x600. Upper left corner of the screen enlarged.
The user Nettacki has experienced and found a solution to this issue, and he kindly shared it on the forums, there:
http://steamcommunity.com/app/9010/discussions/0/846960628329529873/
Display is zoomed-in, no matter what resolution it is
If you experience this, you're problably running the game under Windows 8 or above.

Microsoft implemented something to automatically resize screen elements to adapt them to high resolutions... and old games don't like this ^^'

Simply browse your installation folder (usually C\Program Files (x86)\Steam\steamapps\common\Return to Castle Wolfenstein), right click on WolfSp.exe, Properties, Compatibility tab, and check Disable display scaling on high DPI settings, then hit Apply.

Thanks to heterosexual in the comments section (January the 6th, 2017).

Thanks to maryzzz for the reminder about this; I personally completely disabled that OS thingy:
http://steamcommunity.com/app/9010/discussions/0/152393186481620460/?tscn=1486283713#c133256240732000252
Corrupted renderer (the menu is mainly black, ...)
A confirmed reason is the presence of nGlide on your computer, a software supposed to improve rendering of old games, which is not compatible for everything nor everyone it seems.

If you have it, disable or uninstall it.

If you don't have it but you have a similar issue... There's a little chance nGlide can help. It seems RtCW tries to run with the 3Dfx feature when it thinks it can, but sometimes the graphic card isn't actually compatible. nGlide can force to use your graphic card instead.
Also keep in mind it will probably make the resolution not changeable, in other terms you will be stuck at 800x600; But, again, this is an extreme issue and rarely happens.
Source: http://steamcommunity.com/app/9010/discussions/0/540740501103521797/?tscn=1399314016#c540740501358611754

Thank to Mortal Dictata for the troubleshooting process and patience :)
FPS rate horribly low
This is an other common issue due to how the new hardware handles the rendering.

You just need to edit a cvar, r_primitives, either directly in the CFG file or through the console ingame, or as a launch parameter. I will cover the 3 possibilities :)

Editing the CFG file
Browse /SteamApps/common/return to castle wolfenstein/Main.
Open the file wolfconfig.cfg, search (CTRL + F) for the line r_primitives, and set it to 2.

Setting the new value through the ingame console
While ingame, bring up the console, and type /seta r_primitives 2.
seta is used to permanently save the new value, while set is just for the current session, fyi.

Setting the new value as a launch parameter
In your Steam Library, right click on the game, click Properties, then Launch Parameters... and type +set r_primitives 2 in the text field. The value will be set upon each launch of the game through Steam this way.

Source
Well, I don't know who exactly was the first to suggest this on the Steam Community Forums, so I will quote the one I recall who have added a source: MANGEL TEKILA

See: http://steamcommunity.com/app/9010/discussions/0/846959179178992411/#c846959179211164678

ATI users
If you have an ATI video card and still experience low FPS, try to rename wolfsp.exe to quake3.exe; ATI has predefined parameters, and it seems they haven't used the ones of Q3 for RtCW... Reported to work several times on the Internet and on Steam Community forums.
Mouse is behaving strangely (like moving on its own)
This is especially for users with an high-DPI mouse.

See Display is zoomed-in, no matter what resolution it is section for the fix; it's the same setting causing it for Windows 8 and above users.
Game freezes when the player reaches the map's end
It happened to a few people, and it seems lowering the settings or resetting the configuration file works.

You can find the configuration file there:
/SteamApps/common/return to castle wolfenstein/main/wolfconfig.cfg
MP: No server listed
The server list you can see is streamed by a Master Server, which receives from the servers information and then sends them to clients. iD Software discontinued its support, thus by default there is no servers listed. But a solution exists:
http://steamcommunity.com/sharedfiles/filedetails/?id=166033677
Comments, suggestions, criticism?
Feel free to submit any comments, suggestions or (constructive) criticism which could help making this guide better :)

Thank you for reading!

Regards,

Mateos
< >
288 Comments
3a4em Apr 27 @ 7:55am 
Go friend I need u help me
>M@tEo$<  [author] Nov 26, 2021 @ 11:49am 
With these, there should be native widescreen, and with it a better weap fov IIRC
I know the Enemy Territory silEnT mod has a specific cvar for weap fov
Beyond that, dunno
Dee Nov 26, 2021 @ 7:58am 
i am but i dont know how to change the weapon fov
>M@tEo$<  [author] Nov 26, 2021 @ 7:41am 
Use ioRtCW or play through RealRtCW on Steam
Dee Nov 26, 2021 @ 6:44am 
how do i change weapon fov? its really zoomed in for me like at the bottom of the screen
Rawdaz Nov 22, 2021 @ 9:32am 
eh, didn't worked :(
>M@tEo$<  [author] Sep 30, 2021 @ 12:33pm 
Sorry for the delay, I just got my internet back
There's a screenshot at the bottom of the "If you're OK with installing custom (safe) binaries" section showing what the folder should look like when the extraction is done right
TheTainted_Wisdom Sep 19, 2021 @ 3:04pm 
I don't even know what that means. I just clicked "extract all" and tried to run the exe files.
>M@tEo$<  [author] Sep 19, 2021 @ 1:55am 
Hello
Have you extracted the patch content at the right directory level? ^^'
TheTainted_Wisdom Sep 19, 2021 @ 1:36am 
Game wouldn't even fucking START. Tried every combination of advice from the section about it not starting and not only did it not work, I keep getting demanded permission to run the game as administrator EVEN WHEN I WENT BACK INTO THE SETTINGS AND MADE IT STOP RUNNING AS ADMINISTRATOR. The option didn't even appear at all on the shortcut, and to top it all off, when I tried running the patches for the game BOTH of them said that it "Could not find a copy of Wolfenstien. Click OK to exit"... EVEN WHILE *IN* THE FOLDER WITH THE GODDAMN GAME!!!

PC gaming is the fucking WORST!...