rFactor 2

rFactor 2

131 ratings
Longford 1967
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
525.334 MB
Aug 14 @ 11:18am
1 Change Note ( view )

Subscribe to download
Longford 1967

Subscribed
Unsubscribe
Description
Longford began hosting motorcycle events in the early 1950s, and car races soon after, including two Australian Grand Prix. The lineup included touring cars, sports cars, and the Tasman Series featuring a number of the top F1 drivers and teams. The circuit was last used for the 1968 event. The public road circuit started amongst sheep paddocks, moved past the town's water tank, down a steep slope, passed under the brick arches of the railway viaduct, and onto King's Bridge over the South Esk River. The circuit approaches the town and turns in front of one of the local pubs, passes a few houses and crosses the rail line again at a level crossing. The road continues out of town between Hawthorn hedges and Plane trees and back amongst paddocks, past the disused Tannery, and turns right at a t-junction towards Long Bridge which recrosses the river. Another t-junction turns up hill and takes the cars flat-out for around two kilometers to the final corner, the slowest on the circuit, and back to the start line. This version of the track was created by 'woochoo'.
< >
42 Comments
leoanimi Sep 30 @ 10:40am 
Phenomenal! Thank you so much. I have a question: has anyone tried the BT44B and March 761 in an offline race? In the handful of times I've tried a mixed field they have been crashing at almost every turn.
ironside52 Sep 13 @ 6:27am 
Loving this track just a shame it doesn't feel the same way about me lol. Great work
Apex Predator Aug 27 @ 1:43am 
Enjoying this track so much, even though it keeps killing me.
09 Aug 26 @ 6:44am 
UuuRah.
Kudos n thanks
Semper Fi
Richard "ZZ" Busch Aug 19 @ 2:08pm 
Great job woochoo!! Fun track to drive.
woochoo Aug 19 @ 1:22am 
ah, right, I guess i forgot that. Thanks for mentioning it, in case other people are in the same situation
M D Gourley Aug 19 @ 12:32am 
Ok..found the setting, it needs to have 'Circuit Detail on Full' to show up...only had it set on High...LOL...low powered Graphics Card.
M D Gourley Aug 19 @ 12:14am 
Well, I'm at a loss...still no Station or Train showing up...tried Practice, Qualifying checked...maybe my Graphics Card is underpowered and can not render it as I have low'ish settings in rF2....was looking forward to doing some screenshots with it...LOL:steamhappy:
woochoo Aug 18 @ 11:53pm 
delighted the train is so popular :steamhappy:
M D Gourley Aug 18 @ 11:22pm 
Thanks for taking the time to reply...will check it out:steamhappy: