STEAM GROUP
Steam Remote Play homestream
STEAM GROUP
Steam Remote Play homestream
2,359
IN-GAME
28,660
ONLINE
Founded
November 7, 2013
slouken Sep 9, 2014 @ 1:35pm
Streaming at higher resolution than the host computer
I just ran across this great guide on streaming from a low resolution display to a higher resolution display. The steps here are for NVIDIA, and there's a link at the bottom for AMD:
http://linustechtips.com/main/topic/212054-stream-at-resolutions-higher-then-the-host-computer-with-steam-in-home-streaming/
< >
Showing 1-5 of 5 comments
NeptNutz Sep 9, 2014 @ 6:19pm 
This was easy!

Streaming from 1440x900 host to 1920x1080 client using AMD Catalyst 14.4.

Went to:
My Digital Flat-Panels >> HDTV Support (Digital Flat-Panel) >> 'Add 1080p60 format to the Display Manager'.
and checked it.

That's it! It works!!! :grinsam: (I can't decide if this makes me feel old, stupid, or both.)

UPDATE: I'm not complaining, but a thin, green line is apparent on the bottom of the client display. I turned off the overlay. No luck.

UPDATE 2: Thin, green line seems particular to HW encoding--at least in this arrangement. Batman: AA showed up software only and no green line. I went and un-checked HW encode and Metro 2033 did not have the green line either.

*GOOD NEWS*: At least in Metro (DX9, MAX SETTINGS, @ 1080p), frame rate is easily 10 fps higher in hardware encode than software encode.
[I'm assuming Batman would fare as well if HW encode were working there.]
Last edited by NeptNutz; Sep 10, 2014 @ 11:08am
sss Dec 11, 2021 @ 11:10am 
My host computer has a 1280x1024 monitor, and I wanted it to stream to my laptop that has a 1920x1080 screen.

The instructions for AMD seem to be outdated. Here's how I did it, no third party software needed:

On the host computer, open the Radeon Software, go to "Display", click the "add" button next to "custom resolution". Enter your desired resolution and confirm. If you get an error message that the desired resolution is incompatible with your display, open "Timing standard" in this dialog and switch it from "manual" to "CVT" or "CVT reduced". Only the latter worked for me. Then make sure that "GPU scaling" is set to "off" in the display section of the Radeon software.

To confirm that it worked, go to your Windows desktop, right click, "Display settings", and check if your new custom resolution was added to the list of resolutions. This only happened for me when I set GPU scaling to off.

The higher resolution should now be selectable in the graphics settings of your games.

On the host computer I also went to "Settings > Remote Play > Advanced host options" in Steam and enabled "Change desktop resolution to match streaming client".
Last edited by sss; Dec 11, 2021 @ 11:28am
_I_ Dec 11, 2021 @ 2:32pm 
similar steps for nvidia
the host display will say out of sync or unsupported res or similar, if its beyond its limits, but it will stream at that res
Last edited by _I_; Dec 11, 2021 @ 2:32pm
Karl Martell ⚜ Apr 25, 2023 @ 2:07pm 
I just enabled Virtual Super Resolution from AMD Software.
I'm using a 1440p external monitor, connected to M1 MacBook Air, and Steam Link app from AppStore.

Steam Link Options
  • Launch Mode = Desktop
  • Framerate Limit = 60 FPS (for 60 Hz display)
  • Resolution Limit = 1440p (native resolution of client)
  • Hardware Decoding = Enabled
  • Allow Direct Connection = All Devices

Advanced Host Options
  • Change desktop resolution to match streaming client
  • Enable hardware encoding on AMD GPU
  • Prioritize network traffic

Originally posted by sss:
My host computer has a 1280x1024 monitor, and I wanted it to stream to my laptop that has a 1920x1080 screen.

The instructions for AMD seem to be outdated. Here's how I did it, no third party software needed:

On the host computer, open the Radeon Software, go to "Display", click the "add" button next to "custom resolution". Enter your desired resolution and confirm. If you get an error message that the desired resolution is incompatible with your display, open "Timing standard" in this dialog and switch it from "manual" to "CVT" or "CVT reduced". Only the latter worked for me. Then make sure that "GPU scaling" is set to "off" in the display section of the Radeon software.

To confirm that it worked, go to your Windows desktop, right click, "Display settings", and check if your new custom resolution was added to the list of resolutions. This only happened for me when I set GPU scaling to off.

The higher resolution should now be selectable in the graphics settings of your games.

On the host computer I also went to "Settings > Remote Play > Advanced host options" in Steam and enabled "Change desktop resolution to match streaming client".
[TGW] ScHiFfi Jul 20, 2023 @ 8:23am 
Originally posted by sss:
My host computer has a 1280x1024 monitor, and I wanted it to stream to my laptop that has a 1920x1080 screen.

The instructions for AMD seem to be outdated. Here's how I did it, no third party software needed:

On the host computer, open the Radeon Software, go to "Display", click the "add" button next to "custom resolution". Enter your desired resolution and confirm. If you get an error message that the desired resolution is incompatible with your display, open "Timing standard" in this dialog and switch it from "manual" to "CVT" or "CVT reduced". Only the latter worked for me. Then make sure that "GPU scaling" is set to "off" in the display section of the Radeon software.

To confirm that it worked, go to your Windows desktop, right click, "Display settings", and check if your new custom resolution was added to the list of resolutions. This only happened for me when I set GPU scaling to off.

The higher resolution should now be selectable in the graphics settings of your games.

On the host computer I also went to "Settings > Remote Play > Advanced host options" in Steam and enabled "Change desktop resolution to match streaming client".

Thank you so much for this detailed instructions. This really helped me and I can now play in 4k on my TV. I wish steam would hake an official guide for custom resolutions on amd and nvidea cards for steam link
< >
Showing 1-5 of 5 comments
Per page: 1530 50

Date Posted: Sep 9, 2014 @ 1:35pm
Posts: 5