BreadCannnon Jan 17, 2016 @ 9:29pm
Steam lag on open from Windows taskbar?
When I open Steam from the shortcut in windows taskbar, the icon highlights then reverts.

Steam takes an odd amount of time to open this way, but if I click in notification area and double-click that Steam icon, it opens instantly.

I've already done a reinstall and, a steamflush from the run command.

Any ideas?
Last edited by BreadCannnon; Jan 17, 2016 @ 9:49pm
< >
Showing 1-15 of 18 comments
Bad 💀 Motha Jan 17, 2016 @ 9:31pm 
If it is in Notification area, then it is already open/running.

Stop pinning Steam as an icon to the Taskbar, it doesn't work well that way.

When u launch Steam, have it on the Desktop, when launch right click it, click Run As Admin.
Last edited by Bad 💀 Motha; Jan 17, 2016 @ 9:31pm
BreadCannnon Jan 17, 2016 @ 9:48pm 
I know it is running and, I do not keep icons on my desktop.

I am trying to figure out, why opening my library by clicking the taskbar icon, now lags.

I have accessed steam this way for two years and never had an issue.
Bad 💀 Motha Jan 17, 2016 @ 10:12pm 
Just right click the taskbar icon and click Library or where ever you want to go.
And never do Steam Repair or Flush; that wipes all your local settings for Steam.
That is basically a last resort type of method.
BreadCannnon Jan 17, 2016 @ 10:19pm 
I have tried that, it still lags something fierce.

Instant of popping open instantly, it takes about 20 seconds. I know 20 seconds seems trivial.

It just bothers me, something has suddenly changed and, I cannot figure out why.
Bad 💀 Motha Jan 17, 2016 @ 10:24pm 
What OS?

Could be Aero or other OS Visual related settings doing it.
Such as having all the visuals enabled in Windows OS, windows can lagg due to settings such as "Fade during maximize/minimize of windows" one I always disable cause it makes any Window "lagg". By disable this, everything is fluid without delays.
BreadCannnon Jan 17, 2016 @ 10:54pm 
Oh silly I did not list that before.

Windows 7 64 Bit

I have Aero disabled, because Fallout 4 fusses about it.

Is that "Fade" feature you mention part of Aero, or something in another menu?

urso Mar 4, 2016 @ 2:21am 
Hey, i dont know if you already have the problem, but i was having the same problem and found the solution. You probably have an AMD video card so, just dont install the crimson driver, go back to the catalyst and you will be fine, you might need to format the pc but im not sure if is needed, but here, after a lot of work i found that this new driver CRIMSON was the problem.
BreadCannnon Mar 4, 2016 @ 3:31pm 
You're right I do and the lag started happening around the crimson update. Thanks for commenting, Urso.
Berks Apr 5, 2016 @ 1:38am 
The recent update that just came out today fixed this problem, just thought I'd let you know.
BreadCannnon Apr 5, 2016 @ 2:43am 
Hey Berkelium, the recent update for Crimson?
Berks Apr 5, 2016 @ 4:12am 
AMD Radeon Software Crimson Edition 16.4.1 Beta/Hotfix

After I saw the update notification, I did it straight away. Now its smooth as butter, very fast response.

Just for reference I'm running Windows 10 Pro 64bit with a Gigabyte Windforce R9 290 4GB OC.
Last edited by Berks; Apr 5, 2016 @ 4:17am
BreadCannnon Apr 5, 2016 @ 10:58pm 
Hey good on the find, Berkelium. The update fixed this issue on Windows 7 64, also.
Berks Apr 6, 2016 @ 3:06am 
Glad it helped :)
Moro Astray Jul 15, 2017 @ 10:10am 
I know this is like 1 year after, but I'm having the exact same problem and I also use AMD (RX 480). Any idea if it's the drivers again?
BreadCannnon Jul 15, 2017 @ 1:56pm 
Hey sorry but I'm on Windows 10 now with a GTX 1070.
I would suggest you check the installed driver and match that against AMD's website to see if your driver is up to date.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: Jan 17, 2016 @ 9:29pm
Posts: 18