BioShock

BioShock

Näytä tilastot:
BioShock > Yleiset keskustelut > Aiheen tiedot
Win 7 64Bit Bioshock Start Crash Fix (permanent fix) Per 2K games official response. Works.
http://support.2k.com/entries/21128312-Bioshock-Crash-to-Desktop-on-Windows-7-Fix

What it says:

Bioshock is crashing to the desktop on Windows 7 and Windows Error Reporting says the faulting module is OLEAUT32.dll. How do I fix this?

The solution is to navigate into the Steam files, find the Bioshock.exe and run it in compatibility mode for Vista SP 2. Running it in compatibility mode for any other version of Windows has no effect.

((I did this just now and it worked immediately.))

Directions:

Navigate to the Bioshock start file, should be located here:
"C:\Program Files (x86)\Steam\SteamApps\common\Bioshock\Builds\Release\Bioshock.exe"

Right click "Bioshock.exe"

On the popup menu click "Properties"

Click the "Compatibility" tab at the top

Check the box "Run this program in compatibility mode for:"

Change the drop down to: "Windows Vista (Service Pack 2)"

Click "Ok"

Launch Bioshock.

Tested and worked for me. Enjoy

- Kill
< >
Näytetään 1-12 / 12 kommentista
Yeah doesn't work for me... So what now?
Delectus 15.5.2013 kello 11.26 
It doesn't work for me...anyone know what to do? I really want to play this game again...with W7/64
Hmm, odd, I did exactly the steps that I put down and it works. No issues since.

The only other thing I have heard mentioned that might work is plugging in a microphone. But that is more of a workaround than a fix.

If you check your compatibility settings they are still set the way I said? Any change if you check run as administrator?

If you check your event viewer does your crash show the faulting module is OLEAUT32.dll?
i did it, then it says run. so i do, then steam says app already running. but it is not running. what do i do now?
Check your running processes in the task manager. It's not open, but still technically running, that's probably what your problem was. Just hit end process and try reopening the game when that happens.
i wil try that./
Apocalypse 10.12.2013 kello 11.44 
Looks more like the DRM-trojan is not closing properly, because there is no sight of the bioshock.exe in the task manager ;-)

The solution is to navigate into the Steam files, find the Bioshock.exe and run it in compatibility mode for Vista SP 2. Running it in compatibility mode for any other version of Windows has no effect.

Well, well, it seems like this as the same effect as any other compatibility mode on my system: None.
Viimeisin muokkaaja on Apocalypse; 10.12.2013 kello 11.46
ELE 17.5.2014 kello 13.48 
Worked for me. Thank you very much.
Regarding the whole sound issue... i looked in device manager and realized windows had loaded generic sound drivers.
as soon as i updated all my drivers to the manufacturers drivers, i no longer needed compatibility modes of any kind to run and my sound works perfectly.
my particular audio drivers were realtek.
i went ahead and updated all my motherboard drivers, and graphics drivers, et al
Viimeisin muokkaaja on Worst. Player. Ever; 8.3.2015 kello 23.40
It fixed my issue, my computer is a Windows 7 vista anyway, so i had to decrease the graphics to minimum, but i can not wait to play, so thanks for the help. :)
Odjobb 9.6.2016 kello 16.37 
says my faulting module is bioshock.exe
< >
Näytetään 1-12 / 12 kommentista
Sivua kohden: 15 30 50

BioShock > Yleiset keskustelut > Aiheen tiedot
Lähetetty: 9.5.2013 kello 1.49
Viestejä: 12