BioShock > General Discussions > Topic Details
cmh175 Jul 31, 2013 @ 9:15am
How to easily fix Bioshock Crashing and Sound issues (This works!!!)
There's been a lot of discussion and theories on how to accomplish this. This is one of the greatest games available so I'll share how I fixed the crashing and sound issues. My method to fix the game is quite simple and works perfectly. I did this on Windows 7 64 bit, although it could work on 32.

First, set the game to run in compatibility mode for Vista. I don't know if it works with particular packages or not, I just used Vista. It does NOT need to run as admin. Now when you start the game it wont crash, and you can change settings like resolution and sound. How ever there may no longer be sound when you get past the plan crash.

To fix the sound issue go to Sound inside of the control panel. Make sure you have the correct device selected. If you hear sound when you hit Test you should be fine. Disable the other unused devices.

Next right click on the sound icon in the toolbar, and select Recording Devices. Right click and enable Show Disabled Devices. Now enable Stereo Mixer.

Open Steam and right click Bioshock and click Properties. Click Set Launch Options, and type -nointro. (without the period). This part is important! I don't know why but skipping the intro credit videos makes all the difference. Otherwise it'll still crash.

That's it! That's all I did to fix the crashing and sound issue and the game now works perfectly. Enjoy this awesome game and pass this on to anyone else experiencing this issue.










Last edited by cmh175; Aug 2, 2013 @ 9:56pm
Showing 1-15 of 26 comments
< >
cmh175 Jul 31, 2013 @ 1:15pm 
If you're running Vista and have the crashing issues try compatibility mode for XP service pack 2. However most of my research show it's the Win7 users that get the crashing, Vista just had trouble with the sound.
Ez reporterino #muted Aug 3, 2013 @ 6:27pm 
Mine still doesn't work after changing the compatibility mode :(, it asks me if I want to allow this program to make changes in the computer, after allowing it just says "Failed to start(Unknown Error)"
davidsadi Aug 4, 2013 @ 1:08pm 
I set the exe compatibility to xp sp3 and worked like a charm. Been playing it all afternoon Win 764bit machine
cmh175 Aug 5, 2013 @ 7:44am 
There's apparently a small percentage that still have that issue. Did you try everything I posted though? The "-nointro" part is what really makes a difference. I don't know why, but skipping the opening videos and going straight to the main menu keeps the game from crashing. If XP mode works too that's fine. I'm not sure though if the High graphical settings are going to work since they're DirectX 10. If you want the best performance and graphics you'll need Vista compatibility. Try everything I posted step by step, if the game still doesn't work try K2 support. That's what Steam will advice if you open a support ticket.
Last edited by cmh175; Aug 5, 2013 @ 7:44am
edogg7 Aug 7, 2013 @ 1:02pm 
snowboardpunk17 ,Dude thx , now i can play the game on 1080p with out crashing, all i did was
the win vista thing and it work good. thx ( win8)
Tathier Jack Aug 14, 2013 @ 6:21am 
Thank you Snowboardpunk17 and Steam support!!
Got the game working after following your article! Felt so good after the disapointment of having just bought the Bioshock double pack and then not beeing able to play the first game. I owe you one ;)
Psych Aug 16, 2013 @ 10:48pm 
I fixed it by plugging in a webcam. lol
cmh175 Aug 21, 2013 @ 6:45am 
I'm glad it works for you, but plugging in stuff like microphones or webcams probably just automatically enables the stereo mixer, which is what you really need.
DaWeaves98 Aug 21, 2013 @ 8:09pm 
Confirmed, I did all the steps and the sound still wasn't working. Plugged in a connection to the headphone jack on my computer, opened up the game and all sound was working.
natebud Oct 5, 2013 @ 11:06pm 
I cant find Stereo Mixing even when I do check "show disabled devices." Please help.
Varth Dader Oct 6, 2013 @ 8:57am 
You saved my skin. I begged and begged my mother to put 10 euro on steam so i could buy Bioshock 1 and 2, and i'm sure she would be ♥♥♥♥ed if i told her that the game doesn't work.
Tudo Azul Oct 6, 2013 @ 9:03am 
very polemic
Novosis Dec 6, 2013 @ 11:24pm 
I followed the instructions and the audio now works. However, narrated portions do not work. The parts where Atlas comes on the radio to give you instructions and the Audio diaries do not work at all. The radio icon does not come up, there is no voice talking, and there are no subtitles. I'm not sure what's wrong here.
natebud Dec 7, 2013 @ 8:36pm 
what worked for me was installing bioshock without letting it make changes to my computer and now it works fine, though i did try this on a different computer
Hellsin Dec 8, 2013 @ 10:51pm 
it also works when you plug in your headset, mic/headphone jack seriously, worked for me
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Jul 31, 2013 @ 9:15am
Posts: 26