They Are Billions

They Are Billions

View Stats:
Massive FPS Drops since patch 6.2?
Is anyone having the speed/fps game spike like crazy. Since this new patch, the game runs faster which is great, but I'm getting a ton of stuttering to the point that the game will suddenly freeze up and then shoot ahead in speed. Units literally teleporting around, including zombies.
< >
Showing 1-15 of 25 comments
keeeper Feb 23 @ 7:38pm 
Have exactly the same situation. I am aware that playing on a tiny PC with low power Celeron unit (integrated graphics) even on HD and low settings can't guarantee high performance, but I could at least get those 15-30 fps what was quite playable. But now the game freezes even while paused what is super annoying!
Did it start from 6.2?
Originally posted by keeeper:
Have exactly the same situation. I am aware that playing on a tiny PC with low power Celeron unit (integrated graphics) even on HD and low settings can't guarantee high performance, but I could at least get those 15-30 fps what was quite playable. But now the game freezes even while paused what is super annoying!
Lololol 15-30 fps is playable? My mobile phone has more grunt.

iRkshz Feb 23 @ 11:47pm 
Originally posted by PuppyStomper:
Is anyone having the speed/fps game spike like crazy. Since this new patch, the game runs faster which is great, but I'm getting a ton of stuttering to the point that the game will suddenly freeze up and then shoot ahead in speed. Units literally teleporting around, including zombies.
ya I have same troubles... sh!ty 6.2 patch :(
ant.723 Feb 24 @ 12:14am 
me too. and the funny thing is after the freeze it doesnt affect the zombies. they freeze in one spot and when it unfreezes they moved like 50 feet.
keeeper Feb 24 @ 12:56am 
Originally posted by Hurricane:
Originally posted by keeeper:
Have exactly the same situation. I am aware that playing on a tiny PC with low power Celeron unit (integrated graphics) even on HD and low settings can't guarantee high performance, but I could at least get those 15-30 fps what was quite playable. But now the game freezes even while paused what is super annoying!
Lololol 15-30 fps is playable? My mobile phone has more grunt.


Yes, my phone is also more powerful than my PC that I use mostly for reading, writing and some indie games. And yes again - TAB in 15-30FPS is playable due to active pause - when the game stops it's very smooth - I send the troops, build structures without any delay, then unpause and don't care about FPS drops. At least it was like that until the last patch which affects the paused game and makes it extremely unpleasant..
Last edited by keeeper; Feb 24 @ 12:57am
Same problem as few days ago in 0.6.1 before roll back. Looks like the problem of the new code is still not fixed. My game freeze right at the beginning until 6hrs passed, then the random stuttering.

Edit: I tried to untick vsync and it works a little bit better, but still it is not quite playable
Last edited by Jimmy King; Feb 24 @ 3:57am
Twogun Feb 24 @ 4:17am 
had this issue during the last wave.

also experienceing hard crashes that i cannot even ctrl alt delete out of since the patch, forcing me to shut off my cpu. not an issue prior.
Numantian Games  [developer] Feb 24 @ 4:37am 
Hi!

For those with problems with the 0.6.2 version, Can you try the Test Branch? To do that, go to the steam library, then right click on They Are Billions, then Properties, select the tab Betas and there select the beta Test and press OK.

Try the new version and please tell us the result. We have made an update to work better with low spec computers.

Thanks!
I've been having the OP's issue before 0.6.2.

I have an ultra high-end pc (1080ti x2, core i9, 64 GB RAM, etc..) but I've been having laggy/freeze and constant fps drop (144 straight to 4x without panning the camera much) during gameplay (GPU doesn't even care to spin the fan so I guess the game doesn't really require much). Been messing around with NVIDA and GPU settings but nothing helps.

It's playable but the experience will be very much better if the developers can fix performance issue. I love the game, I'd love it better to play it smoother.
Last edited by tridung13062; Feb 24 @ 4:40am
Originally posted by Numantian Games:
Hi!

For those with problems with the 0.6.2 version, Can you try the Test Branch? To do that, go to the steam library, then right click on They Are Billions, then Properties, select the tab Betas and there select the beta Test and press OK.

Try the new version and please tell us the result. We have made an update to work better with low spec computers.

Thanks!

Just tried the test version. System is responsive, scrolling and zooming are ok, pause resume also fine, just one thing: the game runs in turtle speed. More than 20 sec for an hour, and the army animation seems not moving in contant speed, but smooth though. Other "static animation" speed like tesla tower and sawmill looks normal.
iRkshz Feb 24 @ 6:50am 
Originally posted by Jimmy King:
Originally posted by Numantian Games:
Hi!

For those with problems with the 0.6.2 version, Can you try the Test Branch? To do that, go to the steam library, then right click on They Are Billions, then Properties, select the tab Betas and there select the beta Test and press OK.

Try the new version and please tell us the result. We have made an update to work better with low spec computers.

Thanks!

Just tried the test version. System is responsive, scrolling and zooming are ok, pause resume also fine, just one thing: the game runs in turtle speed. More than 20 sec for an hour, and the army animation seems not moving in contant speed, but smooth though. Other "static animation" speed like tesla tower and sawmill looks normal.
same
Numantian Games  [developer] Feb 24 @ 7:33am 
Hi!

OK We have updated again the Test Branch. Can you try it once more? Please restart Steam to force the update.

Thanks for your cooperation!
tac Feb 24 @ 10:43am 
Still laggy here (since around 6.2) using the test branch.

Phenom II X3 3.2 GHz
8GB Ram
Geforce 450 GTS
Wow thanks for the response. Going to try that now. Should we leave that option on if it fixes the problem? Or should we turn it off?

* Edit - Still having some issues. Particularly at the start of games and coming off of a pause. I'll get some stuttering where the game seems a bit behind, then speeds up to catch up. Still feels unstable.
Last edited by PuppyStomper; Feb 24 @ 11:31am
< >
Showing 1-15 of 25 comments
Per page: 15 30 50

Date Posted: Feb 23 @ 5:19pm
Posts: 25