Far Cry 5

Far Cry 5

Editor - (FIXED) Slow motion in game?
So I just got Far Cry 5 not too long ago in the steam summer sale and the game runs really well on my system (it's enough to run it on a stable high setting if it matters). Since then I have tried out the map editor a few times. When actually working on the map everything seems to work fine. However, once I want to play my map I can get into my map just fine and play it, but it seems everything is running in slow-motion. My character shoots slower, runs slower, other characters are slower, along with the whole arcade pop-up going away slower (which is very annoying). I don't know what is doing this. It should be noted that the pause-menu and in-editor (edit mode) do NOT run any slower, just in-game when playing my custom map. I know what some of you are thinking, because you might've had a similar problem. NO, this is NOT lag. My game (with an empty map) runs a good 200 or so fps, so this ain't lag. If you are wondering how slow, it is as slow as when you get a pop-up on the screen on the main game, so yeah...

(Solution) Just turn on vsync. Should straighten out the game as it seems to crap out at higher fps for some reason.
Last edited by Moxotoch Hawkin; Aug 22, 2018 @ 1:34pm
< >
Showing 1-6 of 6 comments
Patriot Jun 28, 2018 @ 6:28pm 
You don't get any of your perks.
Moxotoch Hawkin Jun 28, 2018 @ 8:36pm 
Originally posted by Steeltooth:
You don't get any of your perks.
Ok, I see your point. But it's not like that, this is slower, as slow as when you get a pop-up on screen. For example, there is a pop-up that slows down the game and says, "Cult Outpost Liberated" (or something similar to that) when you take an outpost. Well it's about as slow as when that popup is up, but ALL the time. Thank you for the err... attempt tho.
Last edited by Moxotoch Hawkin; Jun 28, 2018 @ 8:36pm
kingdouchebag Aug 21, 2018 @ 1:33pm 
I get this problem too and its annoying as hell
Moxotoch Hawkin Aug 22, 2018 @ 1:32pm 
Oh I forgot to post the fix I got long ago... ooops. What you do is, go in-game in the editor, settings, and turn on vsync. Dunno why, but at higher fps the editor seems to crap out on itself. This wont affect the regular game.
Sevilla212 Feb 8, 2021 @ 10:59am 
Originally posted by Moxotoch Hawkin ☭:
So I just got Far Cry 5 not too long ago in the steam summer sale and the game runs really well on my system (it's enough to run it on a stable high setting if it matters). Since then I have tried out the map editor a few times. When actually working on the map everything seems to work fine. However, once I want to play my map I can get into my map just fine and play it, but it seems everything is running in slow-motion. My character shoots slower, runs slower, other characters are slower, along with the whole arcade pop-up going away slower (which is very annoying). I don't know what is doing this. It should be noted that the pause-menu and in-editor (edit mode) do NOT run any slower, just in-game when playing my custom map. I know what some of you are thinking, because you might've had a similar problem. NO, this is NOT lag. My game (with an empty map) runs a good 200 or so fps, so this ain't lag. If you are wondering how slow, it is as slow as when you get a pop-up on the screen on the main game, so yeah...

(Solution) Just turn on vsync. Should straighten out the game as it seems to crap out at higher fps for some reason.

The ♥♥♥♥♥♥♥ Master , Thank you so much ^^
Sarge3D Oct 19 @ 5:45pm 
THX Moxotoch Hawkin works for me.
Load Editor Map, start to play your Map,push Esc go to Options/Grafiks/Gear wheels/Vsync ON
< >
Showing 1-6 of 6 comments
Per page: 1530 50