Mount & Blade: Warband

Mount & Blade: Warband

View Stats:
Massive FPS drops
I played a lot with the demo on Ubuntu, and had around 30 FPS with medium settings. Now, I bought the Steam version and switched to Kubuntu. Now, I have 4-5 FPS with the lowest possible settings. What could be wrong?
< >
Showing 1-6 of 6 comments
Idibil Jun 15, 2015 @ 11:03am 
Surely, you need to ajust your configuration, rgl_config.txt (you can find this in warband main folder and in your documents\warband folder)

How should I adjust? I turned some quality settings to 0 but still no change.
Idibil Jun 15, 2015 @ 12:07pm 
Sorry, you are linux, this file: rgl_config.txt in folder \users\username\My Documents\Mount&Blade Warband

You try this:

texture_detail = 70
render_buffer_size = 15
max_framerate = 120
use_pixel_shaders = 0
use_vertex_shaders = 0
fake_reflections = 1

use_ondemand_textures = 1 #if crash move to 0 depend on your pc
use_ondemand_textures_mt = 1 #if crash move to 0 depend on your PC

force_single_threading = 1
debug_mode = 0

force_vsync = 1
postfx_dof = 0
postfx_hdr = 0

use_instancing = 1
number_of_ragdolls = 4
number_of_corpses = 4
blood_stains = 0

I had this same problem. Try turning off the particle effects in the video options. It worked for me.
Morkonan Jun 15, 2015 @ 9:25pm 
Particle Effects do cause massive FPS losses, especially when your around a lot of horses and dust being kicked up. However, disabling particle effects entirely also removes some other effects from the game.

The way to do it properly is to only disable the "dust" particle effects, as the other particle effects have nowhere near the effect that dust particles do.

Here's a copy/paste from my notes on the issue, with the relevant Taleworlds threadlink:

**************
http://forums.taleworlds.com/index.php?topic=170758.0

Burgass is correct about the blood.
The file to be edited is particle_systems.txt
I'm not certain the exact edits to make...but you might get more help at The Forge. Try the Q&A thread/search there.

Me and some mates had the same problem, and i tried to make some changes to the particle_systems.txt and i found an easy change that atleast worked for us.

Code: [Select]

psys_game_hoof_dust_mud 78080 prt_mesh_mud_1 5 0.700000 10.000000 3.000000 0.000000 0.000000
0.000000 1.000000 1.000000 1.000000
0.000000 0.700000 1.000000 0.700000
0.000000 0.600000 1.000000 0.600000
0.000000 0.400000 1.000000 0.400000
0.000000 0.200000 1.000000 0.220000
0.150000 0.500000 0.100000 0.000000 0.000000 15.000000 6.000000


change the lines above to those below.

Code: [Select]

psys_game_hoof_dust_mud 78080 prt_mesh_mud_1 5 2.000000 10.000000 3.000000 0.000000 0.000000
0.000000 1.000000 1.000000 1.000000
0.000000 0.700000 1.000000 0.700000
0.000000 0.600000 1.000000 0.600000
0.000000 0.400000 1.000000 0.400000
0.000000 0.200000 1.000000 0.220000
0.150000 0.500000 0.100000 0.000000 0.000000 15.000000 6.000000
200.000000 0.500000


It went from being practically unplayable with as few as 30 mounted units to run smoothly with several hundred.

the only thing that was changed was the bold number: psys_game_hoof_dust_mud 78080 prt_mesh_mud_1 5 0.700000 10.000000 3.000000 0.000000 0.000000
What that number changes is the lifetime in seconds for the particles created by the horse dust from 0.7 seconds to 2.0 seconds.

//dnatabar

I know this is kind of late, but if you change the 2.0000000 value to 0.00000000 It completely disables it, helps a lot

**************************
End copy/paste

Thanks to the original posters!
Thx for all who helped

Last edited by Mapper of the Problematique; Jun 15, 2015 @ 10:26pm
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jun 15, 2015 @ 1:53am
Posts: 6