Dying Light

Dying Light

View Stats:
Dying Light > General Discussions > Topic Details
coda Feb 6, 2015 @ 5:52pm
Fix for "FATAL ERROR Cannot initialize renderer".
After searching on the internet for about 10 minutes for this error it seemed like a lot of other people have this and there's no real solution to it.

I managed to fix it for me though.

I've tried many things, but nothing worked. Will this work for me?
Here's my guess.
  • Go to C:\Users\[user]\Documents\DyingLight\out\logs
  • Check the latest log

If you see this on the 2nd last line then it might work for you:

ERRR: [ERRR] > Cannot load 'rd3d11_x64_rwdi.dll'

Info
This issue is caused by DirectX. You need to reïnstall DirectX.

Actual Fix

  • Press the Win key+R to get the Run Box
  • Type Regedit and press enter
  • Find the following Registery key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX
  • Look for "Version" It probably has the value 4.09.00.0904
  • Double click on "Version" and change the number from 4.09.00.0904 to 4.08.00.0904 and press OK
  • Close Regedit
  • Download DirectX web-installer from the MS website and search for "directx end-user runtime web installer".
  • Install DirectX normally
  • Restart PC
  • Pwn some zombie butt.

I really hope this helps for some of you too!
Last edited by coda; Feb 6, 2015 @ 5:54pm
< >
Showing 1-2 of 2 comments
[B|H] Ghosti#2845 Feb 7, 2015 @ 10:57pm 
I had the same error, but fixed it in a different way.

-First updated to Actual Version of DL,

-installed all of the DirectX and vcredist packages Manually (Repair function,starting with the oldest).

-Then I installed that Support patch ( https://steamcommunity.com/app/239140/discussions/0/604941528483950342/ ). Do NOT overwrite any files!

Well, thats it. After that, I was able to play and kick some Zombies asses. :D

I hope it helps you, too!

If there are some mistakes in my writing, please don't blame me, I'm from germany. ;)
bowmop Jun 26 @ 11:05pm 
Tried coda's method on same error message with call of juarez on windows 10 did not have
ERRR: [ERRR] > Cannot load 'rd3d11_x64_rwdi.dll' error in the logs but it still worked when I restarted computer.
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Dying Light > General Discussions > Topic Details
Date Posted: Feb 6, 2015 @ 5:52pm
Posts: 2