Fallout 3 - Game of the Year Edition

Fallout 3 - Game of the Year Edition

Samwell Tarly Jun 26, 2018 @ 6:41pm
IMPORTANT! Fallout Stutter Remover causes crashing! Here is the fix!
Hello everyone! I apologize for not making this post sooner. I have been meaning to, but have been very busy with work lately.

Just a heads up, please follow the main pinned thread about fixing Fallout 3 first before attempting this! The multicore fix and FOSE are essential for the following to work.




Have you tried to get Fallout 3 GOTY running on Windows 10 with no success? Does your game keep crashing every 5-10 minutes or so for no apparent reason?

I had this problem two weeks ago and it was frustrating to say the least. However, after a lot of research I think the problem has been isolated by the Nexus community...and the problem is Fallout Stutter Remover.

After going through the forums on Nexus, I was not the only one having issues with Fallout Stutter Remover. In fact, many people mentioned that Fallout Stutter Remover worked great up until recently. Come to find out that the crashing may have been caused by recent Windows updates and FSR (Fallout Stutter Remover) not meshing well.

So, if you are using Fallout Script Extender aka FOSE (which I highly recommend you use), and Fallout Stutter Remover and are still experiencing crashing, this is what I recommend trying. Again, this may not work for everyone. Hell, it might not help anyone. However, this fixed the crashing issue for me on Windows 10 Home Edition. I have played for about 5 hours and have not experienced a crash (which is actually a first for me).


1) With FOSE and FSR installed, open your Fallout 3 goty folder. (Usually found in C:\SteamLibrary\steamapps\common\Fallout 3 goty). This will depend on where you installed the game of course.

2) Next, navigate to the following: Data\FOSE\plugins\sr_Fallout_Stutter_Remover.ini

3) IMPORTANT - Make a backup of sr_Fallout_Stutter_Remover.ini file and put it in a different directory. This is important because if the fix does not work for you, you will be able to go back to your default file for your previous settings.

3) Open up the .ini with Notepad or Notepad ++.

4) Now, you will need to find and change these two lines in the file sr_Fallout_Stutter_Remover.ini :
"

bHookCriticalSections = 1
bHookLightCriticalSections = 1

To :

bHookCriticalSections = 0
bHookLightCriticalSections = 0

(These two lines should be very close to the top, right when you open up the file.)

Unfortunately, changing these 2 lines makes stuttering when loading new cells reappear, limiting the benefits of this mod. The same happens with all versions I tried, 4.0.7, 4.1.26 and 4.1.36.
"
(All credit goes to "FirstChildren" on Nexus for this fix.)

If you can tolerate a very small stutter when loading new areas of the map, the game has been rock solid stable for me.

5) Save the file.

6) Close Notepad.

7) Enjoy a stable Fallout 3! I hope this fix works for you guys as it has helped me.



If this has helped you, let me know so that we can spread the word. Fallout 3 is one of my favorite games of all time, and I want people to experience it. However, it is not fun for anyone to load up the game and have it crash every few minutes. If you need more tips, I recommend checking out the Nexus website; look up Fallout Stutter Remover, and read the posts found in the Posts section.

Thank you all for your time!






Last edited by Samwell Tarly; Jun 26, 2018 @ 6:55pm
< >
Showing 1-15 of 32 comments
Estuansis Jan 5, 2019 @ 12:13am 
Old-ish post but relevant. My game still has some stability issues, but testing showed easily repeatable crashes with FSR. This fixed those particular crashes. You don't get the buttery smoothness anymore because it will now stutter on loading cells and objects, but you still get all the other benefits.
Samwell Tarly Jan 5, 2019 @ 1:00pm 
Glad this at least helped someone haha It was a game changer for me and really improved my game's stability.
Ira Hayes Jan 6, 2019 @ 3:47pm 
This should be stickied. Came back to this game in years and spent whole day trying to figure out what mod was breaking the game lol
On the subject, have you tried changing other settings related to bHookCriticalSections
bHookLightCriticalSections ?
Samwell Tarly Jan 7, 2019 @ 4:45pm 
Originally posted by Ira Hayes:
This should be stickied. Came back to this game in years and spent whole day trying to figure out what mod was breaking the game lol
On the subject, have you tried changing other settings related to bHookCriticalSections
bHookLightCriticalSections ?

I remember those lines in the ini files. Can't remember doing anything with them though. For the playthrough I was using (then I made this post), I did not edit those lines. I left them at their default values.
Markie Jan 25, 2019 @ 2:20pm 
Thanks! I was investigating some curious crashes on my properly modded FO3 and this was the cause.
Kvinden Jan 26, 2019 @ 9:29am 
Yes, this thread should be pinned. Thanks for sharing the tip.
Lots of players use the stutter remover and this will save their game.
Kabukimono Apr 11, 2019 @ 10:39am 
Thank you so much for sharing. I was about to go insane installing and deinstalling mods changing load orders even if loot thought it wasn't a good setup. Nothing worked until i applied your fix. Finally i can enjoy the guddamn game!
Samwell Tarly Apr 13, 2019 @ 11:59am 
Originally posted by SadYokai:
Thank you so much for sharing. I was about to go insane installing and deinstalling mods changing load orders even if loot thought it wasn't a good setup. Nothing worked until i applied your fix. Finally i can enjoy the guddamn game!

Glad I could help. More people need to hear about this. It could also help push for a patch in the modding community
Kalidor Apr 13, 2019 @ 4:00pm 
it would be easier to use this instead https://www.nexusmods.com/fallout3/mods/23542
Insectoid51 Sep 24, 2019 @ 11:24pm 
Major props. Saved my entire game. Thank you, sir. (I've spent a few days looking for a fix)
Samwell Tarly Sep 25, 2019 @ 4:27pm 
Happy to have helped. Enjoy your time in the wasteland =)
=CrimsoN= Sep 26, 2019 @ 6:35am 
I'm also on Windows 10 and these are my settings for the Master section:
bManageFPS = 0
bHookCriticalSections = 1
bHookLightCriticalSections = 0
bHookHashtables = 1
bReplaceHeap = 1
bReplaceGetTickCount = 1
bFastExit = 1
bFlushLog = 1
iSchedulingResolution = 1
bReplaceRandom = 1
bExperimentalStuff = 0
iMainHookPoint = 1
}

Under Heap replacement:
Heap = {
_comment =This section is disabled by default - see Master/bReplaceHeap
_comment =I recommend enabling it however.
_comment = Heap replacement can produce MAJOR improvements in performance on Oblivion at a significant cost in stability
_comment = It crashes instantly on Fallout3 last I remember checking
_comment = It seems to work on Fallout: New Vegas ?
_comment = Algorithms: 1=FastMM4, 2=Microsoft (slow on XP), 3=SimpleHeap1, 4=TBBMalloc, 5=ThreadHeap2, 6=ThreadHeap3, 8=tcmalloc
_comment = Algorithms numbers 1, 4, and 8 require external DLL files in the Data/OBSE/Plugins/ComponentDLLs folder
_comment = Size is in units of megabytes, and only effects algorithms 3, 5, and 6 (other algorithms dynamically determine their own size)
iHeapAlgorithm = 6
bEnableProfiling = 0
iHeapSize = 256
bEnableMessages = 0
bZeroAllocations = 0

I also use an ENB with memory management enabled and NVAC (which is surprisingly compatible with Fallout 3). Coupled with Zans Autopurge (might not be necessary) and increased initial heap size. Along with the standard Fallout.ini fixes (i.e. bUseThreadedAI=1
iNumHWThreads=2). With all of that, my game doesn't crash after about 3 hours of continuous play (that's only because thats all I tested, it still didn't actually crash). With these settings, I also still get the performance advantages with the stutter remover. Even when the FPS drops in a few areas, it maintains relatively smooth gameplay and is very much playable, but its only a few areas.

This was years of testing, but it might be worth a shot if you have similar specs (may not be specifically based off my specs though, except for the memory stuff). I'm on Windows 10. GTX 1080ti, i7-4790k, 16gb RAM.
Last edited by =CrimsoN=; Sep 26, 2019 @ 6:35am
Lucifer69 Sep 27, 2019 @ 7:39am 
Don't necro a useless post. Stutter remover is more placebo than the "multicore" fix. Some people claim it to work, others claim to say they don't even need the fix.

Before using stutter remover, first make sure you are actually experiencing "stutter". What is stutter? Simply put, it’s any RENDERING anomaly that occurs that causes the time between frames to noticeably vary. Why is this important? Most of the stuttering you experience is actually "pop-in". Pop-in is a performance issue in three-dimensional graphics, causing objects or textures to "pop" suddenly into view as they are loaded, rather than smoothly moving into view.

The effect can be incredibly similar. Both can make the game feel... like it's pausing/ freezing. The issue is stutter remover won't do ♥♥♥♥ for pop-in. Only having a faster drive will. Even on an Adata XPG SX8200 Pro, I still get a bit of pop-in, though it's many times less than what it looks like on my WD 7200 HDD.

Then you also have the instability that stutter remover introduces to the game so even if it fixed anything, it's hell to get it to work. What works for you is not a guarantee that it will work for everyone. Best to avoid that cluster ♥♥♥♥.

Just use the 4GB LAA Patch, FOSE, and your unofficial patch of choice. Plus other required fixes/ patches if you want to mod (archive invalidation, etc.).
Last edited by Lucifer69; Sep 27, 2019 @ 7:46am
=CrimsoN= Sep 27, 2019 @ 7:49am 
Originally posted by Lucifer69:
Don't necro a useless post. Stutter remover is more placebo than the "multicore" fix. Some people claim it to work, others claim to say they don't even need the fix.

Before using stutter remover, first make sure you are actually experiencing stutter. What is stutter? Simply put, it’s any RENDERING anomaly that occurs that causes the time between frames to noticeably vary. Why is this important? Most of the "stuttering" you experience is actually "pop-in". Pop-in is a performance issue in three-dimensional graphics, causing objects or textures to "pop" suddenly into view as they are loaded, rather than smoothly moving into view.

The effect can be incredibly similar. Both can make the game feel... like it's pausing/ freezing. The issue is stutter remover won't do ♥♥♥♥ for pop-in. Only having a faster drive will. Even on an Adata XPG SX8200 Pro, I still get a bit of pop-in, though it's many times less than what it looks like on my WD 7200 HDD.

Just use the 4GB LAA Patch FOSE and you unofficial patch of choice. Plus other required fixes/ patches if you want to mod (archive invalidation, etc.).

I agree that the so-called "stutter" is largely just texture/mesh loading and all assorted pop-in stuffs, but I don't agree that the stutter remover is just a placebo. It definitely has some memory management functions (like heap replacement) that (from my limited understanding), serve to partition more memory (either RAM or video memory) for the purpose of reducing pop-in.

I to have Fallout 3 on an SSD for the same reason as you do (to reduce pop-in). But I've definitely had a noticeable decrease in performance when not using the stutter remover's memory management functions than when I actually use them.

Of course, I also have about 100 HD texture mods (that are something like 20GB of additional textures in size), so maybe the beneficial effects of the stutter remover's memory management (and aforementioned ENB memory management) are more easily visible than by just playing the game with default game textures.
Last edited by =CrimsoN=; Sep 27, 2019 @ 7:52am
Lucifer69 Sep 27, 2019 @ 7:56am 
Then just increase heap allocation. You don't need stutter remover at all. Plenty of good choices for heap. If you must have it, just disable all of the features except heap, but be careful increasing it too much.

Again, a useless addition of info. I don't use it at all, just tried with 102 plugins, and it doesn't help. Enabled all of the garbage settings and crashed before I could walk. Tweaked it to your settings, still crashes in under 10 seconds. Disabled everything except heap and it works, sort of. Still got a crash after 10 minutes. Uninstalled stutter removed, and reverted to a save before using it. Viola, game runs smooth as usual.

So, maybe I'm an exception, maybe not. I do have 4 different rigs. XP, 7, 8.1, and 10. The stutter remover either makes it worse, or no change at all for all 4.
Last edited by Lucifer69; Sep 27, 2019 @ 7:59am
< >
Showing 1-15 of 32 comments
Per page: 1530 50

Date Posted: Jun 26, 2018 @ 6:41pm
Posts: 32