This topic has been pinned, so it's probably important
Morning Coffee  [developer] Feb 1, 2013 @ 7:02am
Issues and temporary workarounds
Thank you for buying the game, and I appreciate your patience with the issues that some of you are having. Launching a game when you're essentially a one man team was bound to be a bit rocky, and I really appreciate the community effort to find and resolve some of these issues until I can fix them officially.

This thread contains some common issues that people have found and fixes for them, until I get around to resolving them officially. This list will get reduced over time as updates are pushed to Steam.

Game Crashes at Unreal Logo / UDK.exe has stopped working
This is a generic UDK error that can have many causes. The following are some fixes that have worked for other members in the community.

- Updating to a later version of PhysX drivers has resolved this issue for many. Regardless of whether your graphics card is ATI or NVidia, you can install newer drivers found in your Antichamber Steam directory: *installdir*\Binaries\Redist\physx\PhysX-9.12.0613-SystemSoftware.msi. This is not installed by default, as the drivers that shipped with UDK are required for some, while these newer ones are required for others.

- Renaming *installdir*\Binaries\Win32\PhysXLoader.dll to something else (anything) has also resolved this issue for others.

- Try running the game as an administrator.

- Try changing the default resolution the game is trying to load in (see below).

If none of these fixes helps you and you cannot find a fix via the community forums, please do the following:

Right click Antichamber in your Steam Library, go to "Properties", "Set Launch Options" and add -FORCELOGFLUSH

Try running the game again, and email *installdir*/udkgame/logs/launch.log to This will give me a better idea of what your specific issue is, and how to go about resolving it.

Resolution settings
Until the options wall in the game is redone to support more resolutions, you can get around this problem by opening *installdir*/UDKGame/Config/DefaultEngine.ini and changing the following lines, at the bottom of the file:


Change ResX (width), ResY (height) and FullScreen values to the desired resolution values. This may help anyone who tries to run the game and only sees a black screen, as the game did not originally display in a supported resolution.

Rebinding Keys
In game reconfigurable controls are something I am still working on to support officially (having in-game art register the keys correctly, etc.). Until that goes in, you're free to change them manually.

Open *Installdir*/UDKGame/Config/DefaultInput.ini, search for "Antichamber Keyboard Bindings", and then change the keys to what you need. A more complete guide was written by another user here:

Controller Support
It is possible to play the game with an XBox controller, but it wasn't tuned correctly so I ripped it out for the launch. I thought it would be better to have no support rather than unfinished support, but I can see that many people would still like to be able to play with a controller.

To re-enable (unofficial) support, in *Installdir*/UDKGame/Config/DefaultInput.ini, search for "Antichamber Controller Bindings" and replace what is there with the following.

; Antichamber Controller Bindings

; Secondary default bindings

; Primaray default bindings
.Bindings=(Name="XboxTypeS_Start",Command="GBA_ShowMenu | OnRelease CancelExit")
.Bindings=(Name="XboxTypeS_RightShoulder",Command="StartTriFire | OnRelease StopTriFire")
.Bindings=(Name="XboxTypeS_LeftShoulder",Command="StartTriFire | OnRelease StopTriFire")

The buttons will all work (hold B to walk), but the motion on the thumbsticks isn't tuned and accelerates too harshly. When this stuff has been resolved (in code) and tested properly, this will all be put back in officially.

Game Crashes when drawing huge loops / cubes
If you draw a very large loop or cube (e.g. trying to make a cube close in on yourself), it's likely the game will crash as an algorithm will go out of control and try to do more than one million iterations in a single frame. There is no puzzle in the game that requires this (there was an earlier issue with "Over The Edge", which has since been resolved), so for now, don't do it. I will be looking at improving this algorithm over time to resolve this issue completely.
Last edited by Morning Coffee; Mar 12, 2013 @ 9:30pm
< >
Showing 1-15 of 188 comments
Zevwolf Feb 1, 2013 @ 7:01pm 
Please check the discussion titled: "Game failing to launch, please help" I have encountered what appears to be a rare problem that none of the mentioned solutions has solved. Thanks!
Last edited by Zevwolf; Feb 1, 2013 @ 7:01pm
ourorboros Feb 2, 2013 @ 8:45am 
believe me... i have spent a fair while trying to get the game to work >.< updated drivers, manually changed the resolution in multiple different config files, changed it for both windowed and fullscreen mode and so on, i've finally given up and im just gona have to be patient /cry
completed the game, great game, dude!

now I feel like I have to follow that dam pink cube that kept popping up several times.... dont think I followed that path to completion. :(

side note: found it kind of annoyign that I had to forcequit the program if i wanted to close it unless I beat the game. any chance you could add a "close game" button next to the "clear save data"?
kumabushi Feb 2, 2013 @ 4:47pm 
It says right on the settings menu to hold Esc for several seconds to quit.
Dont beat yourself up too much about speed runs...... there are ALWAYS going to be people that break your game. IE: using an object like a tray of food in half life 2 to fly through levels to make speedruns.

That was built into the physics engine, there was no way around that lol.
ourorboros Feb 4, 2013 @ 7:20am 
yeah, dont worry too much mate, though do remember some of us cant even play at minute due to problems with the resolution and would really love a fix*hopeful puppy dog eyes*
Ace Feb 4, 2013 @ 11:06pm 
I'm glad to see a dev who is open and forthcoming to the community. Not many around who do that. I hope you find a fix for the red gun crashing issue. Not just for over the edge (which is driving me crazy atm) but also becuase I just want to turn the entire game into red blocks. Pretty sure I could fill everything with them given enough time :D
viola Feb 5, 2013 @ 1:56am 
I'd like play this game not only desktop but on laptop, but system requirements are extremely high to old laptops.
I have the laptop that barely run Team Foretress 2 on medium video option. (Geforce 6400 Go)
Is it possible optimization or just makes a video option or low specification?
(sorry for my bad English)
Morning Coffee  [developer] Feb 5, 2013 @ 2:20am 
It's unfortunately difficult to make low spec options for Antichamber, because there aren't really options that I can disable / turn off. The linework has a fix cost, as does the lighting. Multiple rendering is what hurts it the most, and the game definitely needs that. Some of the algorithms are also pretty computationally intensive.

I have done a whole lot of optimisation on the game and have had some people say that it doesn't need super high specs (for example, a friend finished it on a media server and said it was "surprisingly playable" at 15fps), but follow that information at your own risk.
viola Feb 5, 2013 @ 3:22am 
Well, it's time to bought a new laptop for Antichamber. It's true that my laptop is too old. Thank you for answering :'-)
UnShame Feb 7, 2013 @ 6:06am 
Is clipping through elevators a bug or not?
Morning Coffee  [developer] Feb 7, 2013 @ 2:33pm 
Northrop_ Feb 7, 2013 @ 8:09pm 
Tryed everything, still the game crashes at startup. A black screen and a short sound followed by an UDK.exe error message.
Morning Coffee  [developer] Feb 7, 2013 @ 8:57pm 
If you are unable to get the game running at all, you should contact Steam Support and ask for a refund, as the game had issues running on your hardware.
Morning Coffee  [developer] Feb 7, 2013 @ 9:40pm 
It may be a conflict between the version of the UDK that the game runs on and your setup. Unfortunately, if the Engine is crashing before it even gets to loading Antichamber related files, that's an issue with Unreal vs your setup.

In order to know more about the problem, I would need you to email *installdir*/UDKGame/Logs/Launch.log to, but this often doesn't give useful information (as in the case of the PhysX driver issue) or points to issues with the engine vs your hardware. It's really difficult to debug these issues effectively if the game doesn't even start, because Unreal doesn't give useful errors or anything to debug most of the time, which is why at times I just need to suggest refunds. There are instances where there's not a lot that I can do.
< >
Showing 1-15 of 188 comments
Per page: 1530 50