F.E.A.R.

F.E.A.R.

F.E.A.R. > General Discussions > Topic Details
lee Nov 20, 2012 @ 6:18am
If you use Logitech keyboard and/or mouse...
Your fps will be around like ~30. My rig is i7 gtx680, but game can't handle advanced mouse, so gives you framerate drop. Wow. This is so funny, I can't even get mad...
< >
Showing 1-13 of 13 comments
Error - ß ☀ Nov 21, 2012 @ 1:41am 
I used a Logitech wireless mouse with the dongle connected to my wired USB (non-Logitech) keyboard and it never dropped below 60 FPS for me. Maybe its because the Logitech device wasn't connected directly to the computer, so perhaps the small USB hub on the keyboard acted as some kind of buffer to prevent the issue or I was just lucky since your rig is definitely more powerful than my setup.
rfzm ↑ Nov 21, 2012 @ 2:39am 
well this game is sadly very poorly optimized so you wont always run it at 60 frames despite high end rigs.
Out Nov 21, 2012 @ 9:24am 
Easy to fix. Device manager > disable "HID-compliant devices" for mouse/keyboard.
frodough Nov 29, 2012 @ 6:14pm 
Originally posted by Rushonal:
Easy to fix. Device manager > disable "HID-compliant devices" for mouse/keyboard.
Yea, I tried this G19/G500 and my LCD screen stopped working and keyboard software wouldn't load unless I re enabled them and restarted.

What a stupid bug that of course couldn't be bothered to be fixed at any point in time.
frodough Nov 29, 2012 @ 6:29pm 
I found that just closing the logitech gaming framework - the program used to display stuff ont he LCD of the G19 - fixes this problem without having to disable any of the HID entries.

EDIT: Nope, FPS still drops over time, sigh
EDIT 2: Disabling the first 2 out of 4 HID entries in Device Manager seemed to work.
Last edited by frodough; Nov 29, 2012 @ 6:37pm
CarlinFan Dec 7, 2012 @ 9:02pm 
I use a g15 and only have to disable 'logitech gaming virtual mouse' in device manager. Been playing for hours on end now with constant 60 fps and working LCD.
Last edited by CarlinFan; Dec 7, 2012 @ 9:02pm
Rossos Dec 9, 2012 @ 7:16am 
In addition to this Logitec Hardware Issues thread I would like to share how I've solved a strange thing with my FEAR choppy and laggy gameplay. Yes, it's the disabling HID devices, read below for more description:

I've played this game on Win7-64 last year, and everything was fine. But recently I wanted to play it again, so I did. This time the gameplay was very choppy and laggy, especially if I would to fire weapons/throw granades/interract with objects. Having in mind that I've undergone a recent computer format and reinstallation of the same OS I've had previously I was certain it is some software and not hardware issue. (Having intel i7-930 with 6gb of ram and HD5850 1gb there should be any problem running a 6 years old game, well... maybe my vga is a special case in some games, but as I've said, I've run this game before, with no probs, same hardware, not a single USB flash drive more lol)

In the end of it all I had a problem which many people in the community have. Of course google helped me find it. Strangly there wasn't any link/reference to this "inSteam" community, only to the old forums, which at the moment of posting this reply were "Undergoing maintenance". The solution was to disable HID-complient devices in my Device Manager.

You can find this and many more solutions to FEAR here: http://forums.guru3d.com/showpost.php?s=0e612bc7f9e9c0ad6d749fe5db76f952&p=3668045&postcount=12
The post is a collaboration of many possible solutions to the choppy/laggy gameplay problem. Hope it's helpful!
Steelfold Jul 19, 2013 @ 2:52am 
This really helped me out.
I wonder what bug caused this engine to behave like DOOM 20 years ago.
After disabling the HID compliant devices I went from 7 fps straight up to 333 fps (670 GTX)!
Only wonder what side effects I call over me by doing this...
Manul Dec 18, 2013 @ 10:28pm 
If you don't want to get side effects, just enable the device back in Control Panel after playing the game.
littlemaths Jan 17, 2014 @ 9:52pm 
Awesome. Thanks to everyone who identified this fix. Playing it with a GTX650 TI and wondering why the heck I was getting 8 FPS.
< NEW PLAYER > Jan 23, 2014 @ 9:13pm 
Is that the reason my shots have a delay?
EDKILL13 Jan 27, 2014 @ 2:30am 
Logitech keyboard and mouse `n everything runs sweet o.0
Evangelina Mar 13, 2020 @ 6:32pm 
Originally posted by Rossos:
In addition to this Logitec Hardware Issues thread I would like to share how I've solved a strange thing with my FEAR choppy and laggy gameplay. Yes, it's the disabling HID devices, read below for more description:

I've played this game on Win7-64 last year, and everything was fine. But recently I wanted to play it again, so I did. This time the gameplay was very choppy and laggy, especially if I would to fire weapons/throw granades/interract with objects. Having in mind that I've undergone a recent computer format and reinstallation of the same OS I've had previously I was certain it is some software and not hardware issue. (Having intel i7-930 with 6gb of ram and HD5850 1gb there should be any problem running a 6 years old game, well... maybe my vga is a special case in some games, but as I've said, I've run this game before, with no probs, same hardware, not a single USB flash drive more lol)

In the end of it all I had a problem which many people in the community have. Of course google helped me find it. Strangly there wasn't any link/reference to this "inSteam" community, only to the old forums, which at the moment of posting this reply were "Undergoing maintenance". The solution was to disable HID-complient devices in my Device Manager.

You can find this and many more solutions to FEAR here: http://forums.guru3d.com/showpost.php?s=0e612bc7f9e9c0ad6d749fe5db76f952&p=3668045&postcount=12
The post is a collaboration of many possible solutions to the choppy/laggy gameplay problem. Hope it's helpful!

You're a hero. Thank you. Had to disable every single HID compliant driver related to the Logitech Mouse except the USB mouse itself. For people with the issue, here's the short version of what to do.

there's a bandwith issue with Direct Input and the JupiterEX Engine (F.E.A.R., and Condemned: Criminal Origins), and I use a Logitech G5 Mouse, and it's affected by this problem.. So yes, by disabling direct input hooks that XFire does, we ignore the Direct Input bandwith bottleneck issue, thus not crippling ingame framerates!



For users with Logitech G series Mice and Keyboards that suffer framerate issues? you may want to do this HID Driver fix too, cause it's known to cause framerate issues ingame due to the Direct Input bottleneck on the JupiterEX Engine (as I stated above, lol). To do it you must disable all "HID-Compliant Device" drivers with "046D" in the the HardwareID. Sadly, this makes Logitech's SetPoint Program totally useless.. but at least keeps your FEAR framerates up eh?

Here's Manual Instructions for that fix:

* Go into Device Manager (Start > Control Pannel > System > Hardware (tab) > Device Manager)
* Hit the Plus (+) sign beside "Human Interface Devices"
* Right-Click on the first "HID-Compliant Device" in the list and select "Properties"
* Click on the "Details" tab
* Open the drop-down list and select "HardwareID" from that list
* Check if it has "046D" in the HardwareID.. usually looks like "HID\VID_046D&PID" for where it would have it
* If it has the "046D" in the HardwareID, close the properties menu and select that "HID-Compliant Device" and Right-Click on it and select "Disable"
* You may need to check serveral "HID-Compliant Device" drivers, for me it was two of them, the 2nd and 3rd in my list

---

Credits go to the autor of that post on the 3DGuru forum, i paste here for the future, one never knows when the 3Dguru forum can go down. Cheers.
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

F.E.A.R. > General Discussions > Topic Details