Batman™: Arkham Knight

Batman™: Arkham Knight

View Stats:
BIG SHAQ 👑 Jun 22, 2015 @ 8:54pm
HOW TO GET BEST PERFORMANCE [OPTIMIZATION MUST READ!!!!!]
WARNING: THIS GUIDE IS FOR THOSE WHO WANT TO BE HELPED AND WANT TO PLAY WITH A DECENT PERFORMANCE. THIS GUIDE MAY WORK ON YOU OR MAY NOT. EVERYTHING YOU DO IS AT YOUR RESPONSABILITY. IF IT DIDN'T WORK FOR YOU PLEASE KEEP YOUR MAD FEELINGS AND ANGER FOR YOURSELF AND DON'T EXPRESS IT ON THIS THREAD OR BLAMING ME FOR SOMETHING. IF IT WORKED THAN I AM VERY HAPPY FOR YOU. FOR EVERYTHING YOU DO FIRST MAKE A BACKUP.


IMPORTANT: After downloading the driver make sure the Physx is set to GPU not CPU or Auto. You can change it in Nvidia control panel 3D settings > Configure surround, Physx

Steam Guide: http://steamcommunity.com/sharedfiles/filedetails/?id=467817222

So first of all, if you still have a lock on 30FPS do this change:
Remember to do backup of the file before you change anything.

I am using a GTX970 gpu and with those settings my game runs smoothly at 60fps without any lags and with nice graphics quality.

SKIP INTRO
Get rid of that mean intro saying you who made the game and start playing already without waiting.

Right click and select properties for the game, click launch options and add -nologo. Will boot straight into the main menu afterwards

Launch the game and it go directly to the menu.

- Increase FPS to 60+:
Go to [...]\steamapps\common\Batman Arkham Knight\BMGame\Config and look for BmSystemSettings.ini (open with notepad)

Change MaxFPS=30.000000 to MaxFPS=120.000000 (save)

- Get better performance:
Go to [...]\steamapps\common\Batman Arkham Knight\BMGame\Config and look for BmSystemSettings.ini (open with notepad)

1. Change bAllowD3D9MSAA=False to bAllowD3D9MSAA=True (This allows you to use MSAA with D3D9)

2. [Reserved]

3. Change TextureResolution=1 to TextureResolution=2 (This allows you to change the texture resolution from Normal to High but somehow it keep changing back to normal I don't know why because in my case while looking at the options in-game the texture resolution is set on Normal and there is no other options (no high, no ultra, just nothing). But you can try.

4. Ingame decrease shadows to low or normal. No need to put it high, just in case to get more frames/s (who cares about shadows anyway ;/)

5. Motion blur possible solution
Set MaxFilterBlurSampleCount=1

6. Turn off Bloom: Bloom=False

7. Turn off Reflections: Reflections=False
AllowImageReflections=False
AllowImageReflectionShadowing=False

8. Change AllowOpenGL=False to AllowOpenGL=True (This allows you to use OpenGL for better performance)

9. FOV not available yet

10. Film grain removal:
Distortion=False
FilteredDistortion=False
(Not sure if works but you can try. Personaly I didn't see any difference when I tested it with true or false)

Tweaks to improve texture quality and uncapped framerate performance by Kaldaien updated and dedicated to 3 new sections in the guide i wrote. (Please check)


Originally posted by The_Winkler:
I can't find BMSystemSettings.ini in my config folder.
Run the game first so that it will load the file by default. After downloading it you have to run the game first.

SLI config
Originally posted by Zorbak1:
SLI not currently working for me, and i have the new drivers installed.
Look for bEnableCrossfire=False and change it to True. Maybe that will help.

Originally posted by MistaKilla:
Ok for people who are running SLI Setup, Make sure you allow D3D10 = true as op said. I went into nv inspector and found that sli settings for the game do exist but they run on D3D10 so if you enable that you will see that both of your cards being used. I am running 670sli and doing this has helped a lot. Able to even run at 1440p with all gameworks stuff off and texture at normal and quality at high. It is the blur that results in frame drops.


Save everything and ready to go.

IMPORTANT: SET THE FILE TO READ-ONLY AS THE GAME RESET THE SETTINGS EVERYTIME.


Post here feedback if it worked for you or not.

Feedbacks:

Originally posted by Rin D. Pryde:
Ok, my two cents.

In my case it looks like motion blur is bugged - game runs ok, but the second you move the camera and motion blur kicks in the fps drops dramatically. And there is no way to turn the blur off right now - even if you disable it in the BmSystemSettings file - the game just won't start (crashes after intros).

But you can try the following in the Batman Arkham Knight\BMGame\Config\BmSystemSettings.ini:

Change Bloom and AllowRadialBlur to "False", MotionBlurSkinning to 0, and MobilePostProcessBlurAmount to 0.0 - it helped me a lot, though still hardly enjoyable fps.

PS. Don't forget do copy config files to restore them if something goes wrong =)

Originally posted by Sygma:
not sure the d3d10 help, it made things worse on some ends.

Btw the textures are forced at anisotropy x4 in the ini, change it to x16 and in the nvidia profile, textures high quality. It kinda look very good after that

Originally posted by iUberGeek:
Another tip for those playing on a laptop with Nvidia Optimus switchable graphics: Switch to windowed or borderless display modes using GeForce Experience in order to avoid severe flickering and stuttering.


Originally posted by HolyGrail:
Just came from redit. Also make sure your PhysX settings are set to GPU and not CPU or Auto
Nvidia control panel 3D settings > Configure surround, Physx

Originally posted by HolyGrail:
Wow, going from full screen to windowed really helped. Everyone should also give that a go.

Originally posted by Sevket:
And dont forget setting "prerenderedtextures" to "1" from nvidia settings


Gameplay proof:

https://www.youtube.com/watch?v=zd_DNUNDSR0

Combat gameplay + Batmobile

https://www.youtube.com/watch?v=KQCPDHoL2xY

BEAUFITY THE GAME [MOD]

http://steamcommunity.com/sharedfiles/filedetails/?id=468744403
Last edited by BIG SHAQ 👑; Jun 28, 2015 @ 5:40pm
< >
Showing 1-15 of 932 comments
Hugal Jun 22, 2015 @ 8:55pm 
Sticky this ♥♥♥♥
EGirls-R-Us Jun 22, 2015 @ 8:56pm 
It's pretty sad that we as consumers have to do this in order to make our game work properly for PC. Devs really need to learn this ♥♥♥♥.
Pcnuttie Jun 22, 2015 @ 8:56pm 
I'll have to try that. I wonder why there isn't ultra settings for beast PC users. I'll have to see if it works. I am sure it will. I am in the eastern time zone and still waiting for it to unlock.
Rossi1911 Jun 22, 2015 @ 8:56pm 
+1
Spoderman Jun 22, 2015 @ 8:57pm 
It seems like we cant max texture resolution with a 970, Because the 3.5 vram....
Hugal Jun 22, 2015 @ 8:59pm 
Originally posted by SunBro:
It seems like we cant max texture resolution with a 970, Because the 3.5 vram....

Cant you bypass the limit if you mess with the files?
True Jun 22, 2015 @ 9:00pm 
at this ♥♥♥♥♥♥♥ point, its seems like ill be happy just to run it on low
True Jun 22, 2015 @ 9:00pm 
but i hope this helps
caxtilteca Jun 22, 2015 @ 9:01pm 
Originally posted by Kal-El:
I'll have to try that. I wonder why there isn't ultra settings for beast PC users. I'll have to see if it works. I am sure it will. I am in the eastern time zone and still waiting for it to unlock.
released before time, it was supposed to be released tomorrow but people couldnt wait, i think there's a day one patch that will increase performance and other things, i was watching a walkthrough on youtube for ps4 and the game kinda looks better
BIG SHAQ 👑 Jun 22, 2015 @ 9:01pm 
Originally posted by ㋡ Hugal~:
Originally posted by SunBro:
It seems like we cant max texture resolution with a 970, Because the 3.5 vram....

Cant you bypass the limit if you mess with the files?
I tried to bypass it by changing the value but I think he is right because of 3.5 vram. So the solution for this is to apply some SweetFX to make the game cooler with nice quality by using MSAA and FXAA. (The MSAA within the game I think is not enough). I will work on this and I will post the result.
Rossi1911 Jun 22, 2015 @ 9:01pm 
Originally posted by TrueBobert:
at this ♥♥♥♥♥♥♥ point, its seems like ill be happy just to run it on low

What's your PC specs?
Hugal Jun 22, 2015 @ 9:02pm 
Originally posted by Poseidon:
Originally posted by ㋡ Hugal~:

Cant you bypass the limit if you mess with the files?
I tried to bypass it by changing the value but I think he is right because of 3.5 vram. So the solution for this is to apply some SweetFX to make the game cooler with nice quality by using MSAA and FXAA. (The MSAA within the game I think is not enough). I will work on this and I will post the result.

What about Nvidia's Control Panel?
-Digital¹ Jun 22, 2015 @ 9:02pm 
Actually ''Normal'' is the highest texture resolution in the game, it has zero to do with the ''3.5gb of vram'' issue. Read the description of Normal texture setting in the game
True Jun 22, 2015 @ 9:05pm 
Originally posted by Rossi1911:
Originally posted by TrueBobert:
at this ♥♥♥♥♥♥♥ point, its seems like ill be happy just to run it on low

What's your PC specs?
on a laptop
specs arent really an issue, just it seems like it doesnt run regardless for some poeple
Spoderman Jun 22, 2015 @ 9:07pm 
Originally posted by d4ng3rousmindz:
Actually ''Normal'' is the highest texture resolution in the game, it has zero to do with the ''3.5gb of vram'' issue. Read the description of Normal texture setting in the game

It says "standar textures" in normal.
So, hopefully is there a high resolution textures.
< >
Showing 1-15 of 932 comments
Per page: 15 30 50

Date Posted: Jun 22, 2015 @ 8:54pm
Posts: 932