SiN
SiN > General Discussions > Topic Details
BarrybarryK Feb 4, 2013 @ 4:36pm
Custom Resolutions for SiN 1
Although by default Sin 1 has pretty rubbish resolution support with just 6 modes, most of which aren't even of any use these days, the Quake 2 engine is pretty capable of coping with high resolutions, this tweak will let you set whichever resolution you like.

First of all you'll need a Hex editor, I use HxD[mh-nexus.de] but any should do.

browse to your sin.exe file (STEAMDIRECTORY\steamapps\YOURSTEAMNAME\sin 1\sin.exe) , make a copy and name it something like sin.exe.bak just so we have a backup incase things go wrong.

After your backup has been created open up your sin.exe with your hex editor. This hack works by replacing the "mode 6" resolution (default value of 1600 x 1200) in the exe with one of our own so open up a search/find dialogue box and enter 40060000B0040000 as the Hexadecimal value to search for. In my copy it was at offset E4394, yours will likely be in the same place.

4006 and B004 are the two values we'll be replacing, 4006 is the notation for 1600 (the horizontal resolution) and B004 is the notation for 1200 (the vertical resolution).

You can find out the hex values for your resolution using a converter like this one[www.statman.info]

I want 1920 for horizontal resolution and 1080 for vertical (1920x1080), if I enter 1920 into the converter and hit the "to hexadecimal" button it gives me "780" but before I can enter it I need to add a "0" to the beginning to get "0780" then swap the two around in pairs to get "8007" which is the value we'll put in replacing "4006"

It's exactly the same for the vertical resolution. If I enter 1080 into the converter and hit the "to hexadecimal" button I get the value "438", again we add our leading zero to get "0438" the swap the two pairs around again and we end up with "3804"

You can see these edits here[imgur.com] but it should work with almost any resolution provided you get your values correct.

After that it's just a case of saving and loading the game up, and setting your video mode as "1280 x 1024" in the menu or typing "gl_mode 6" in the console to set our new video mode

You might also want to set a new fov setting as well using the "fov" command, 90 is the default with about 105-110 looking about right on a 16:9 resolution display (so "fov 110" to set) and "vid_fullscreen 1" will set the game to fullscreen.

All of these tweaks (fov and fullscreen) should save themselves in the game settings so you don't have to reset them again and here's a link to a screenshot of sin running at 1920 x 1080
1920x1080

Last edited by BarrybarryK; Feb 4, 2013 @ 9:07pm
< >
Showing 1-15 of 27 comments
polaris1985 Feb 5, 2013 @ 6:07pm 
Thank you!
Thanks BarrybarryK, this is most helpful! :D:
Mr.Mister Aug 9, 2013 @ 5:45pm 
Thank you so much!
Kvaki Aug 31, 2013 @ 8:05pm 
Thx!
SuchACard Dec 13, 2013 @ 1:46pm 
This is great. Remember really liking this game when it first came out and I'm really looking forward to playing it again looking better than ever. Thanks for the awesome help.
Dog9Mango Jan 12, 2014 @ 3:51pm 
Thank you, now the game is actually playable!
HOSHI82 Feb 7, 2014 @ 10:49am 
The console command for fov doesn't work for me. Even in the config.cfg it set the fov to 110, but it is still streched... anyone got an idea?
Sergio Apr 4, 2014 @ 7:19am 
thx dude ! awesome
pagb666 Aug 2, 2014 @ 4:44am 
Worked like a charm. +Rep
Hegemon00 Dec 4, 2014 @ 2:27pm 
Okay, here's my problem. One year ago when I bought SiN I had 17" LCD monitor which native resolution was 1280x1024. So I've followed this gudie and set my desired resolution without any problems. Since september I've got new widescreen monitor and I wanted to play SiN again. Before messing with Hex editor I've checked the video settings first and I've noticed that the highest resolution is already set to 1280x1024! I've followed this guide again and changing it from 1600x1200 to 1600x900 (my new native resolution) did nothing. 1280x1024 is still the highest otpion in video settings. Anyone know which values should I modify now? My SiN became a real mess...
Judge Fear May 27, 2015 @ 9:14pm 
Thank you. That helped a lot.
jhr_digitalartist Jun 24, 2015 @ 5:33pm 
gonna have to do something, the base game looks terrible on my current gen pc
Guy_From_Hell Jan 14, 2016 @ 1:06pm 
Originally posted by Hegemon00:
Okay, here's my problem. One year ago when I bought SiN I had 17" LCD monitor which native resolution was 1280x1024. So I've followed this gudie and set my desired resolution without any problems. Since september I've got new widescreen monitor and I wanted to play SiN again. Before messing with Hex editor I've checked the video settings first and I've noticed that the highest resolution is already set to 1280x1024! I've followed this guide again and changing it from 1600x1200 to 1600x900 (my new native resolution) did nothing. 1280x1024 is still the highest otpion in video settings. Anyone know which values should I modify now? My SiN became a real mess...
Try looking for E4430 address
and replace 80020000 E0010000 as provided in OP (it's 640x480 res)
Darkamo Jul 10, 2016 @ 7:24am 
hello i tried to set the resolution to 1366*768 so it does 5560 3000 but it didn't work :c , i follow step by step the tutorial too
Darkamo Jul 10, 2016 @ 7:50am 
ok i got it partically now , i sitwhed to the resolution but not the only thing that is display on the screen is a fine line of the menu i have done vid_fullscreen 1 , it does nothing help pls !
< >
Showing 1-15 of 27 comments
Per page: 15 30 50

SiN > General Discussions > Topic Details