Aru Kahomi Mar 22, 2013 @ 12:25pm
Game Crashes
Everytime I start the game, I play like 10-20 minutes and then it crashes, someone has a fix or something to help me out?
Showing 1-15 of 21 comments
< >
nodnarb751976 Mar 23, 2013 @ 4:59pm 
I am having the same problem. The game plays just fine for about 20 minutes and then I get a message stating that "Civilization V has stopped working. Windows will close the program and notify me if a solution is available."
Dr. Locke Mar 23, 2013 @ 11:22pm 
Play on DX 9. It's the only way the game wont crash on you. The developers recently made a patch that basically ♥♥♥♥ed up the game for 90% of the people playing.
Aru Kahomi Mar 23, 2013 @ 11:29pm 
Yeah, that's what am I doing
jonkthedonk Mar 23, 2013 @ 11:55pm 
It crashes on DX 9 aswell, just after i try to start the DX 9 version i get runtime c++ errors..
utopianwizard Mar 24, 2013 @ 8:10am 
I have played Civ game through all the expansions etc., and ever since I bought Gods and Kings can't play it at all, any version, and DX level, after having done every single one of hte so-called fixes that both Steam and 2K have put out there to try to get it working. I bought the latest expansion four months ago, and have been so frustrated with the situation I"m almost ready to take them both to small claims court and give them both bad ratings with the BBB.
nunominal Mar 24, 2013 @ 11:45am 
I have the crash happening as well. I only have DX10 and it worked fine until the recent 'patches'(if this is what they are called). The crash is happening at the autosave points it seems. If the new 'patches' make a player with only DX 10 capabilities now have to play on DX11 ... CIV developers have an extra issue. I would love to see this fixed.
lowellcl104 Mar 24, 2013 @ 9:30pm 
I have the same problem, running Win 8 WAY-Y-Y over the required minimums, but using a standard (non-touch) monitor. Runs for a few turns then stops. Also, just today it stopped defaulting to anyone other than the Japanese. I can force it to load another, but by itself it's stuck in Japan.
Martin Mar 24, 2013 @ 11:00pm 
I can't tell you a definate fix for this, but, I used to get this error. Originally, I didnt have a Dx10 video card, a proper one. Even playing the game in dx9 still crashed randomly.

After getting a decent card, the error disappear... then later reappeared. This however, was linked to faulty memory, which when replaced, hasn't had a error since. You can send the civ error codes to tech they may or may not help.. I don't know of any reader for the error logs, trying to read them in edit mode just give code and some basic config infos non of which really help with the error, however if the log mentions kernal errors, either you souns, video drivers need updated, or you have faulty memory or a faulty cpu. The cpu is unlikely. Update your drivers and then directx from the microsoft website.

If you have 2 ram sticks, remove one and try the game on a small map, if it still faults, swap them. If neither fixes. If you have 4.. or they work in tandom with each other.. then you need to run a memory checker on them, (with 4 you can remove 2 at a time if in tandem) or run them one at a time. Memory checkers, can take several hours to run thier tests and may not find the problem. Easiest fix for me, was just swap them both with the shop i bought it from. No problems since.
utopianwizard Mar 25, 2013 @ 4:48pm 
Okay, everyone. I just yesterday got so tired of it all, I totally uninstalled Steam along with all my games etc. and reinstalled DX registry etc., then after that I reinstalled Steam and reinstalled Civ 5 which also of course installed the Gods and Kings expansion. I then checked the Civ 5 Properties, making sure it was not set on Windows 7 compatibility mode, I tried to start the game after all installs were done, and it worked perfectly. I don't know why, but I had noticed that Steam was seeing my operating system was Windows XP (with that special added patch # 2), and this was what finally led me to totally uninstall everything. then reinstall it all to see if Steam still saw my os as XP, and it did. What I reailized at this point was that the updated Steam system wanted to see it as XP so it would use those settings to run the game outside any compatibility mode which I had done early on b/c it made sense to me. I even asked Steam and 2K support why Steam system would see my os wrong, and got no answers from them, either one.

Bottom line. I can only suggest that for both Windows 7 and 8, to get them out of any compatibility mode and allow Steam to see your os as XP witht the second update patch), then see if the game will run. Now, one caviat is that I have only started playing the game since day before yesterday now, and hopefully it will continue to play correctly. I'm not angry with the game itself BECAUSE I LOVE CIV GAMES. I blame the two parties, Steam support and 2K support for not taking the time to test the game since its inception in the context of things like Steam seeing an operating system incorrectly when it automatically looks at your system online. Someone should have noticed this (expecially if this is the only reason why somej/maybe most purchasers could not play the game since Gods and Kings. Now we have a new version coming out apparently, and I am scared to buy it b/c I'm GUN SHY about making any changes because I want to play Gods and Kings for awhile. I'm afraid to try any mods at all too, even though I have never been able to get any of them to work before Gods and Kings anyway.

So that's where I"m at with it all and I truly hopes it helps you guys who love Civilization games. IF it works for ya, spread the word on my experience to those others who may not have seen my questions and irks about Steam and 2k support systems.

CC Ryder (utopianwizard)
utopianwizard Mar 25, 2013 @ 4:49pm 
Oh and also it is now running on Direct X 10/11
Big Jizzle Mar 25, 2013 @ 7:24pm 
Bought the game, can't play. Eitehr Dx 9 or 11.

Great game 10/10..
nelliebear Mar 25, 2013 @ 9:24pm 
I have had a crashing issue ever since the patch in November. Sometimes I'd get a few turns in, sometimes it would happen on the first turn. I tried everything I could find on anywhere I could look and nothing worked. Until tonight. I finally got it working again. I don't know if you are having the same issue I was, but the thing that seems to have finally fixed it is: delete all the mods you have. Like I said, I tried everything I could find and nothing worked, but this finally did. Good luck. I know your frustration. Civ is by far my fav steam game and I have been unable to play it for almost 6 months. I was so frustrated! Hope this works for you!
utopianwizard Mar 26, 2013 @ 3:36am 
Gaben, try what I did and what nelliebear did. I would first check on Steam to see what it reports as to which operating it identifies on your computer. If it says like it did on mine, Windows XP while in truth my os is Windows 7 Home Premium, then your problem may be similar to what mine was. I had up til then tried Windows 7 compatiblity mode but as soon as I set it to Windows XP (sp2), then suddenly it works perfectly. Then if its not this, try Nelliebear's fix, getting rid of any mods you may have added.
nunominal Mar 26, 2013 @ 7:01am 
UtopW : Thanks for the info. I might just have to wait for 2K, etc, to fixthis problem. I can't even find on Steam where they post which operating it is identifying my computer as. (?)

If you've got the time to list out the procedure you did a little more simply (for folk like myself) I would attempt it. Do I lose my whole Steam account and have to make a whole new one, etc. etc.?

I do love Civ --- (side note: just wish the benefits for peace loving Civs were more rewarded/recognized).
Giller Mar 26, 2013 @ 8:22am 
My system does a full crash when I am playing multiplayer (but not when I am playing a hotseat game). Any ideas why?
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Mar 22, 2013 @ 12:25pm
Posts: 21